Results 1 to 6 of 6

Thread: OpenSuse 11.4 on a Macbook Pro - Failed installation.

  1. #1

    Default OpenSuse 11.4 on a Macbook Pro - Failed installation.

    Hi folks, i'm trying to install OpenSUSE 11.4 on a Macbook Pro 5,1 (later 2008). From boot menu i have chosen all the possible options, but i always get the same result.

    I began choosing 1024x768 and standard kernel and i get a black screen. Reboot.
    I chose VESA and kernel with security adjust. Black screen, then reboot.
    Finally, i chose VESA and kernel with no-apic and the installation wizard loaded. I configured all and OpenSUSE began to install, but when it was finishing, the screen turned black.

    Any idea? Possible solution?

    Thanks =)

  2. #2

    Default Re: OpenSuse 11.4 on a Macbook Pro - Failed installation.

    As usual, try to add "nomodeset" to the boot options.

  3. #3

    Default Re: OpenSuse 11.4 on a Macbook Pro - Failed installation.

    Ok, i am going to try it and i'll post the result.

    Thanks!

  4. #4

    Thumbs down Re: OpenSuse 11.4 on a Macbook Pro - Failed installation.

    I tried with "nomodeset" in boot options but i got another black screen.

    First, i used generic kernel with 1024x768 and nomodeset. It seemed to boot but when the progress bar was finishing, the screen turned to black and i had to reboot.

    After, i used security kernel with VESA and nomodeset. This time i saw the boot messages and all seems ok, but (as the first time) when it was finishing i got again the black screen.

    Finally, i tried with no-ACPI kernel, VESA and nomodeset, but the same.

    What's wrong ?

  5. #5

    Default Re: OpenSuse 11.4 on a Macbook Pro - Failed installation.

    What graphic card has this Macbook Pro? Are you booting a liveCD or a DVD? Can you boot any other distro liveCD?

  6. #6

    Default Re: OpenSuse 11.4 on a Macbook Pro - Failed installation.

    This MacBook Pro has two graphic cards. An integrated (Nvidia 9400M) and a dedicated (Nvidia 9600M GT). I think all distribuitions use the dedicated graphic card.

    I'm booting from the LiveCD and i have been able to install Ubuntu and OpenSUSE 11.3 without any kind of problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •