I can't get my laptop to print to my desktop via CUPS ipp. I admit to being over my head. Kubuntu somehow had auto discovery once you checked "allow remote printing" in the printer config. The desktop printer would automatically show up on the laptop. Once I would tell ufw firewall to allow CUPS, it automatically printed. I can't get it to do the same in openSUSE. I have the opensuse desktop firewall turned off to rule it out. I have configured CUPS to share the printer. If I go to Yast>Printer>Print Via Network and check "request printer info from cups server" and enter cups IP, it shows up on the laptop, but print jobs will not go through. What am I missing?