Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Eclipse exits on openSUSE 11.4

  1. #1

    Default Eclipse exits on openSUSE 11.4

    Hi there!
    I just installed Eclipse Helios on a fresh installation of openSUSE 11.4 (32 bits), and when I stop the cursor over any class name or method name in a source file, Eclipse exits unexpectedly.
    When I start Eclipse again, it starts as usually... But again, when I stop the cursor over any class name or method name in a source file, Eclipse exits again.

    Note: I have installed jdk 1.6 and NVIDIA 173.14.28 for my FX5500 video board. I use KDE desktop environment installed from openSuse 11.4 DVD. (No extra applications.)

    Now, I had to re install openSUSE 11.3 in order to work with Eclipse again.

    Do you have any idea?

    Thank you, in advance.
    [Adrián E. Córdoba]

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Eclipse exits on openSUSE 11.4

    What does eclipse show as terminal output after the crash if you start it
    from the command line?

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  3. #3

    Default Re: Eclipse exits on openSUSE 11.4

    I'm sorry, but I had to re install openSUSE 11.3 in order to work with Eclipse again.
    I beg your pardon.
    [Adrián E. Córdoba]

  4. #4

    Default Re: Eclipse exits on openSUSE 11.4

    Nobody with the same problem?
    [Adrián E. Córdoba]

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Eclipse exits on openSUSE 11.4

    aecordoba wrote:

    >
    > Nobody with the same problem?
    >

    It is a problem: How can we help you to solve your problem if you no longer
    have the system where the problem appears? And hence cannot give us more
    detailed information.
    I only can tell you that on my eeepc 1201n (which is not yet in the footer)
    with os 11.4, gnome 2.32, 64 bit and using eclipse helios sr2 there is no
    problem at all (at least not until now). So it is a bit difficult to tell
    from a system that works what might be the reason why another system does
    not work with the same opensuse version and which does no longer exist since
    you downgraded it.

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  6. #6

    Default Re: Eclipse exits on openSUSE 11.4

    Martin:
    All data you gave me are valuable data.
    For example: My Eclipse Helios version was not SR2 and openSUSE 11.4 was 32 bits with KDE desktop environment.
    I understand you.
    But I trying to find out if the problem was on my particular installation/environment.
    If somebody tried the same environment (openSuse 11.4 32 bits with KDE desktop) and Eclipse Helios SR2 with good results, I'd again try to re install 11.4 and test again.
    But that is too much work with my development environment (certain java version + apache httpd + apache tomcat + oracle + setting all options) that I need to work, if I go forward an go back every day.

    Thank you again.
    [Adrián E. Córdoba]

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Eclipse exits on openSUSE 11.4

    I know that does not help you much so I hope someone jumps in who has a
    similar installation as yours (32 bit and kde, I think kde or gnome is
    unrelated but who knows) and can give advise.
    I had a somewhat similar problem with helios on my notebook in the company
    which I thought was an eclipse problem but it was not. It was one of the
    plugins (in my case the subclipse plugin). The solution was then to change
    some library via yast to another version (do not remeber which).
    Since you seem to have a lot of plugins installed as far as I understand,
    you should consider also the possibility that it is one of the plugins (if
    the error did not happen before you installed the plugins).

    Just one suggestion. If nobody has an idea what might be the reason for the
    problem, you can do the following:
    If your system is powerfull enough or you can use a pc for that, install
    11.4 in a virtual machine (vbox or vmware), set your environment up with
    eclipse helios sr2 and check if it works.
    At least you can even if it does not work find info about the crash post it
    here or google for it and probably the solution will be as simple as
    changing one of the conflicting libs in the system.
    I know this is maybe a lot of work depending on your environment, but that
    is what I need to do to ensure that my development notebook works before I
    upgrade it, since it has also a somewhat complicated setup.

    --
    openSUSE 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.5 | GeForce
    9600 GT | 4GB Ram
    openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | KDE 4.5 | Quadro FX
    3600M | 4GB Ram

  8. #8
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Eclipse exits on openSUSE 11.4

    Using eclipse as flex developer for years, so here is my 2 cents.

    1. Uninstall Eclipse if you have installed it from repositories
    2. Go to eclipse site and download desired version (classic, for C++, for Java... or what you need)
    3. unpack to a directory you will keep it and make shortcut so you can start it easily (eclipse does not need to be installed, just run it)
    4. Before you run it, open eclise.ini and increase the memory usage of it. Double the size its there by default. Then you can experiment.

    this should be some minimal values:

    -Xms256m
    -Xmx512m
    -XX:MaxPermSize=256m
    -XXermSize=64m

    you may wish to increase -Xms256m to 512 and -Xmx to 1024m (go upto 2048m if you have 4GB of ram)
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  9. #9

    Default Re: Eclipse exits on openSUSE 11.4

    Thank you! I'll try your suggestions.

    Note: I didn't install Eclipse from a repo. I installed it by "tar -zxvf" of the Java EE Eclipse edition from eclipse.org.
    Thank you again.
    [Adrián E. Córdoba]

  10. #10

    Default Re: Eclipse exits on openSUSE 11.4

    Hi!
    I installed opensuse 11.4 and I encountered the same problem.
    I have eclipse JEE Helios SR1 running with java-1_6_0-sun-devel & java-1_6_0-sun.
    Whenever I try to autocomplete a package name with CTRL+SPACE, eclipse crashes and BugDaddy shows up asking me if I want to save the bug report.(link to the report)

    link to the output of eclipse on the terminal after the crash.


    Thanks in advance for your help.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •