Results 1 to 9 of 9

Thread: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

  1. #1

    Default YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

    Hello,
    With a default 11.4 (64bit) install, selecting XFCE for the desktop environment I get the following appear in an "xmessage" window.

    "GTK GUI wanted but not found, falling back to Qt".

    This appears whenever I click cancel in any YaST dialogs, or the "Install/Remove Software" dialog from the XFCE menu.

    eg. Opening the YaST->Firewall dialog to check the current status of the firewall, then clicking cancel will show the "xmessage" window.

    Is this message harmless and my system is still ok ? It happens everytime with a XFCE install, I have reinstalled 11.4 several times to check.

    Thanks

  2. #2

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4XFCE

    wisepenguin wrote:
    > Hello,
    > With a default 11.4 (64bit) install, selecting XFCE for the desktop
    > environment I get the following appear in an "xmessage" window.
    >
    > "GTK GUI wanted but not found, falling back to Qt".
    >
    > This appears whenever I click cancel in any YaST dialogs, or the
    > "Install/Remove Software" dialog from the XFCE menu.
    >
    > eg. Opening the YaST->Firewall dialog to check the current status of
    > the firewall, then clicking cancel will show the "xmessage" window.
    >
    > Is this message harmless and my system is still ok ? It happens
    > everytime with a XFCE install, I have reinstalled 11.4 several times to
    > check.


    Yes, it's harmless. If you like the qt GUI, go into the sysconfig editor
    and find the options for YaST and select qt. That will stop the
    warnings. If you don't like qt, you can always install the gtk GUI!

    I guess technically, it's a small bug that should be reported.

  3. #3

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE


  4. #4

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

    I know this is an old topic, but I was curious. What is the difference between having GT GUI and Qt?

  5. #5

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

    QT is a GUI framework used by KDE, GTK is a GUI framework used by Gnome and Xfce.
    you can use GTK YaST under KDE and vica versa but usually the "native" them looks "nativer".
    As long as I know they look a but different, but have the same configuration elements.

  6. #6

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

    There are also some changes in functionality. I'm working on KDE but I prefer GTK GUI. Under GTK I have quick summary of updates, live and very good search (just start typing name and You will get all packages) and so on.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4XFCE

    On 2011-12-22 08:16, xorock wrote:
    >
    > There are also some changes in functionality. I'm working on KDE but I
    > prefer GTK GUI. Under GTK I have quick summary of updates, live and very
    > good search (just start typing name and You will get all packages) and
    > so on.


    Only the software management and update modules are different. The rest are
    the same.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8
    Join Date
    Jun 2008
    Location
    Luleå, Sweden
    Posts
    39

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

    Does anyone know how to get rid of this message or, more important, how to install this GTK GUI under KDE?

    Thanks in advance

    Mimis

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,822
    Blog Entries
    15

    Default Re: YaST - "GTK GUI wanted but not found" message with default 11.4 XFCE

    Quote Originally Posted by mimis-suse10 View Post
    Does anyone know how to get rid of this message or, more important, how to install this GTK GUI under KDE?

    Thanks in advance

    Mimis
    Hi
    Please start a new thread, posting in a 5 year old thread without knowing your openSUSE release won't help...

    Thread closed.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •