Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Clean install 11.4 user auth problems

  1. #1

    Default Clean install 11.4 user auth problems

    I am using Opensuse for years and did many upgrades without problems. But this time everything fails one by one.

    First 11.3 to 11.4 update failed (possibly zypper bug ?)
    Then i did a clean install form DVD with preservering my home partition. Guess what ?

    I can login my system with ANY password with any valid user ?!? Also passwd doesnt works...

    That look likes a pam error but i am not sure how to solve this..

    Here is the error pam gives me when i type passwd:
    mobilix:~ # passwd
    Changing password for root.
    passwd: Permission denied

    mobilix:~ # tail /var/log/messages
    Mar 14 05:47:17 mobilix passwd[9109]: User root: Permission denied
    Mar 14 05:47:17 mobilix passwd[9109]: password change failed, pam error 6 - account=root, uid=0, by=0

    Any ideas ?

  2. #2
    Christoph Schmees NNTP User

    Default Re: Clean install 11.4 user auth problems

    Am 2011-03-14 05:06, schrieb xsdnd:
    >
    > I am using Opensuse for years and did many upgrades without problems.
    > But this time everything fails one by one.
    >
    > First 11.3 to 11.4 update failed (possibly zypper bug ?)
    > Then i did a clean install form DVD with preservering my home
    > partition. Guess what ?
    >
    > I can login my system with ANY password with any valid user ?!? Also
    > passwd doesnt works...
    >
    > That look likes a pam error but i am not sure how to solve this..
    >
    > Here is the error pam gives me when i type passwd:
    > mobilix:~ # passwd
    > Changing password for root.
    > passwd: Permission denied
    >
    > mobilix:~ # tail /var/log/messages
    > Mar 14 05:47:17 mobilix passwd[9109]: User root: Permission denied
    > Mar 14 05:47:17 mobilix passwd[9109]: password change failed, pam error
    > 6 - account=root, uid=0, by=0
    >
    > Any ideas ?
    >


    I seem to remember something about changed user numbering in
    11.4: Add 1000 or the like. Not quite sure. You may search in
    that direction.

    Christoph

    --
    email:
    nurfuerspam -> gmx
    de -> net

  3. #3

    Default Re: Clean install 11.4 user auth problems

    Are you using the root id to change the password for root?
    Code:
    gnomesu 
    ### or 
    kdesu
    ### or 
    su 
    password:
    ~> password
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  4. #4

    Default Re: Clean install 11.4 user auth problems

    Hi,

    same Problem here.
    Env: Clean installed openSUSE 11.4 "Celadon" 2.6.37.1-1.2-desktop
    Encryption: Blowfish

    I can login into my root- and useraccount using any (a wrong/empty) password.

    Being logged in I can 'su' again with any password.

    If i try to change the password of any user i get the message:

    passwd: Berechtigung verweigert (Translation: rc1 - Permission denied)

    e.g.:

    Code:
    Estella@NetOMat:~> su
    Passwort: 
    NetOMat:/home/Estella # id
    uid=0(root) gid=0(root) Gruppen=0(root)
    NetOMat:/home/Estella # passwd
    ndere Passwort fr root.
    passwd: Berechtigung verweigert
    NetOMat:/home/Estella # tail -4 /var/log/messages
    Feb 27 23:33:53 NetOMat su: (to root) Estella on /dev/pts/5
    Feb 27 23:34:00 NetOMat passwd[6930]: User root: Berechtigung verweigert
    Feb 27 23:34:00 NetOMat passwd[6930]: password change failed, pam error 6 - account=root, uid=0, by=0
    NetOMat:/home/Estella #
    A reinstall did not solve this issue.
    Neither switching from blowfish to md5 helped nor did toggling on/off any other option under yast->Security and Users->User and Group Management. e.g. autologin / login without password, etc..

    Estella

  5. #5

    Default Re: Clean install 11.4 user auth problems

    @EstellaDinsmoor
    I only have questions,
    are the permission on /etc/passwd file 0644 ?
    does the password you want have a space but isn't quoted?
    are you making typo errors, 2 key finger, caps?
    ( type the password on a tomboy, copy and paste to passwd

    Or if you have them
    diff3 /etc/passwd /etc/passwd.backup /etc/passwd.YaST2save
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  6. #6

    Default Re: Clean install 11.4 user auth problems

    Quote Originally Posted by tararpharazon View Post
    @EstellaDinsmoor
    I only have questions,
    are the permission on /etc/passwd file 0644 ?
    does the password you want have a space but isn't quoted?
    are you making typo errors, 2 key finger, caps?
    ( type the password on a tomboy, copy and paste to passwd

    Or if you have them
    diff3 /etc/passwd /etc/passwd.backup /etc/passwd.YaST2save
    Oops, you don't have passwords, everything works as a password?
    Even after a clean install? Wasn't there an option during install that asked if you were the only user of the PC?
    If true and you selected that and auto login?

    Can you add a user, who must login, to see if that creates passwords.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  7. #7

    Default Re: Clean install 11.4 user auth problems

    Quote Originally Posted by tararpharazon View Post
    Oops, you don't have passwords, everything works as a password?
    Even after a clean install? Wasn't there an option during install that asked if you were the only user of the PC?
    If true and you selected that and auto login?

    Can you add a user, who must login, to see if that creates passwords.
    Hi,

    lets start with your first reply:
    1. The permissions on /etc/passwd are 0644 root - root.
    /etc/shadow 0640 root shadow.
    2. The passwords do not include space or any other special characters. They are all just alphanumerical.

    Passwords were created successfully (at least the hash can be found in /etc/shadow) for the accounts root, Estella and test. test is the account i created to check if a login with a user who is not the initial user would work. Just as before, i can enter whatever i want to log in as this 'test'-user. What does not work as the test-user is logging into kde. But once i log into kde using Estella or root, i can 'su' to test without a problem. test can not reset his password, just as the other two users.

    On my first install i had separate passwords for my 'main'-user Estella and root, but i selected autologin for Estella. On my second install i switched to Main- and rootuser get the same password but autologin disabeld. Both times i chose blowfish as the encryptionalgorithm. In both cases i was neither able to reset any passwords nor was there any check, whether or not the passwords were correct. Any password was accepted as valid. I discovered this after being sure i had a typo when 'su'ing to root, but it still worked.
    As i said before, i went into yast->Security and Users->User and Group Management an started switching the algorithm, turned autologin on and off etc. I basically tried every option yast offers me, but none would work. I still can't change any passwords.
    My Samba accounts on the other hand are handled as expected. i did not install any other software which has user authentication so far, since it seems it is not worth the effort, if my systemaccounts are broken.

    To sum up, what i did:
    Install Opensuse, online update right at install included.
    install Nvidia drivers (
    Edit /boot/grub/menu.lst and add nomodeset to the boot arguments in the default boot.
    In Yast > System > etc/Sysconfig editor go to System > Kernel > NO_KMS_IN_INTRID and change the default no to yes
    Add the nVidia repo for 11.4: http://download.nvidia.com/opensuse/11.4/
    Now open Yast > Software > Software Management and you will find the driver is automatically added to install - Accept the install
    Reboot
    )
    Turn off apparmor.
    configure Samba.
    configure udev automount rules, to automount my external harddrives and automatically create Sambamounts.

    If one should wonder about turning off apparmor, on my first install it was still running and the same problem occurred. Truning it back on right now, doesn't help either.
    I turned it off to be able to use Samba.

    Besides those steps i have not done anything.

    Right now i don't know what else i could do. Maybe i switch back to 11.3, but thats just avoiding the problems, not solving them...

    Thanks for your help, it's much appreciated!

    Estella

  8. #8

    Default Re: Clean install 11.4 user auth problems

    Quote Originally Posted by EstellaDinsmoor View Post
    Hi,

    lets start with your first reply:
    1. The permissions on /etc/passwd are 0644 root - root.
    /etc/shadow 0640 root shadow.
    2. The passwords do not include space or any other special characters. They are all just alphanumerical.

    Passwords were created successfully (at least the hash can be found in /etc/shadow) for the accounts root, Estella and test. test is the account i created to check if a login with a user who is not the initial user would work. Just as before, i can enter whatever i want to log in as this 'test'-user. What does not work as the test-user is logging into kde. But once i log into kde using Estella or root, i can 'su' to test without a problem. test can not reset his password, just as the other two users.

    On my first install i had separate passwords for my 'main'-user Estella and root, but i selected autologin for Estella. On my second install i switched to Main- and rootuser get the same password but autologin disabeld. Both times i chose blowfish as the encryptionalgorithm. In both cases i was neither able to reset any passwords nor was there any check, whether or not the passwords were correct. Any password was accepted as valid. I discovered this after being sure i had a typo when 'su'ing to root, but it still worked.
    As i said before, i went into yast->Security and Users->User and Group Management an started switching the algorithm, turned autologin on and off etc. I basically tried every option yast offers me, but none would work. I still can't change any passwords.
    My Samba accounts on the other hand are handled as expected. i did not install any other software which has user authentication so far, since it seems it is not worth the effort, if my systemaccounts are broken.

    To sum up, what i did:
    Install Opensuse, online update right at install included.
    install Nvidia drivers (
    Edit /boot/grub/menu.lst and add nomodeset to the boot arguments in the default boot.
    In Yast > System > etc/Sysconfig editor go to System > Kernel > NO_KMS_IN_INTRID and change the default no to yes
    Add the nVidia repo for 11.4: http://download.nvidia.com/opensuse/11.4/
    Now open Yast > Software > Software Management and you will find the driver is automatically added to install - Accept the install
    Reboot
    )
    Turn off apparmor.
    configure Samba.
    configure udev automount rules, to automount my external harddrives and automatically create Sambamounts.

    If one should wonder about turning off apparmor, on my first install it was still running and the same problem occurred. Truning it back on right now, doesn't help either.
    I turned it off to be able to use Samba.

    Besides those steps i have not done anything.

    Right now i don't know what else i could do. Maybe i switch back to 11.3, but thats just avoiding the problems, not solving them...

    Thanks for your help, it's much appreciated!

    Estella
    Good summary, thank you. I'm still clueless but going through your steps the etc/sysconfig from my install of 11.4 the default is "yes" not "no". Also, it states you need to run /sbin/mkinitrd. I haven't tried to change my passwords but I definitely must use the correct passwords for su and logins.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  9. #9

    Default Re: Clean install 11.4 user auth problems

    Hi,

    before you test any configuration:
    I installed my system for the third and forth time now. I still have the same problems right from the start.
    I deselected autologin, chose different passwords for main and root-User, formated everything, what might have left a tiny file, but once installation is done, logins are not checked. I can login using a wrong password, i can 'su' using any pwd i like etc. This is vanilla 11.4 openSUSE, downloaded and burned as a DVD. Not even the nVidia driver was installed. Checked with DVD in drive and taken out.

    Sadly I am not going to install 11.4 again

    I guess I'll take a closer look at Ubuntu.

    Thx for your help, anyway.
    Maybe somebody might be interested in this bug, so I hope this thread ist not useless.

    Estella

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Clean install 11.4 user auth problems

    Can we see the line from /etc/sysconfig/displaymanager that says this
    Code:
    DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
    on my systems? I've seen it saying "yes" once before, don't know how this happened.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •