Results 1 to 7 of 7

Thread: Power button respons slow on HP 6730b upgraded to 11.4

  1. #1

    Default Power button respons slow on HP 6730b upgraded to 11.4

    I tend to use the power button on my HP 5730b notebook to have it showing the logoff/reboot/shutdown dialog. Though this still works as a default settings in 11.4 it responds quite slow.

    Once I press the power button, the KDE panels become unresponsive for about 20 seconds or so, until the logoff/reboot/shutdown dialog is shown. After that the system behaves as usual. I do not have this problem when I perform the same function from the openSUSE KDE menu.

  2. #2

    Default Re: Power button respons slow on HP 6730b upgraded to 11.4

    I did some extra research:
    - It does work when I press perform the same action after switching to the console using ctrl-alt-F1 (still in runlevel 5 though)
    - With acpi_listen running I see the button pressing event appear immediately, but the system waits a while to process is, problably some kind of time out somewhere.

    Therefore I think it is KDE related.

  3. #3
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: Power button respons slow on HP 6730b upgraded to 11.4

    Me too (on a Dell M4500).

    I have the power button set to shutdown, but when I press the button, nothing seems to happen at all. Then the systems seems to freeze for a while, and eventually it shuts itself down.

    It worked fine before upgrading to 11.4, and while a shutdown through the launcher also appears to be much slower now, it is still much faster than pressing the button.

  4. #4
    Join Date
    Mar 2011
    Location
    Waterloo, Ontario, Canada
    Posts
    44

    Default Re: Power button respons slow on HP 6730b upgraded to 11.4

    I experience the same problem as well
    when pressing power button, the shut down prompt takes about 20 seconds to show up, i dont feel any sort of lag or anything
    so i think this is indeed some time-out stuff, maybe a mis-configuration?

  5. #5

    Default Re: Power button respons slow on HP 6730b upgraded to 11.4

    I have Acer 7730G and same problem. I think we should post this to bugzilla or something like this.

  6. #6

    Default Re: Power button respons slow on HP 6730b upgraded to 11.4

    Quote Originally Posted by DenerKup View Post
    I have Acer 7730G and same problem. I think we should post this to bugzilla or something like this.

    I already did, it is bug 680741

  7. #7
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: Power button respons slow on HP 6730b upgraded to 11.4

    Same here (HP DV7 KDE4.6), it also freezes my screen when I press ther power button, cant revive it with ALT+F1 or ALT+CTRL+F1, etc or ALT+CTRL+BACKSPACE. I tried to ping, ssh, etc my notebook from another PC and it wont respond.

    The only thing that works is ALT+CTRL+SYSREQ+b and makes a hard reboot or something (I have this enabled in kernel)

    I see this message error in the pm-poweroff
    Code:
    cat pm-powersave.log
    Running hook /usr/lib/pm-utils/power.d/disable_wol false:
    Setting Wake On Lan for eth0 to enable...Done.
    
    /usr/lib/pm-utils/power.d/disable_wol false: success.
    Running hook /usr/lib/pm-utils/power.d/hal-cd-polling false:
    
    /usr/lib/pm-utils/power.d/hal-cd-polling false: success.
    Running hook /usr/lib/pm-utils/power.d/intel-audio-powersave false:
    
    /usr/lib/pm-utils/power.d/intel-audio-powersave false: success.
    Running hook /usr/lib/pm-utils/power.d/journal-commit false:
    Setting journal commit time for / to 0...Done.
    Setting journal commit time for /DATA to 0...Done.
    Setting journal commit time for /home to 0...Done.
    
    /usr/lib/pm-utils/power.d/journal-commit false: success.
    Running hook /usr/lib/pm-utils/power.d/laptop-mode false:
    Laptop mode disabled.
    
    /usr/lib/pm-utils/power.d/laptop-mode false: success.
    Running hook /usr/lib/pm-utils/power.d/pcie_aspm false:
    
    /usr/lib/pm-utils/power.d/pcie_aspm false: success.
    Running hook /usr/lib/pm-utils/power.d/readahead false:
    Setting readahead for /dev/sda6 to 256...Done.
    Setting readahead for /dev/sda1 to 256...Done.
    Setting readahead for /dev/sdb1 to 256...Done.
    Setting readahead for /dev/sda7 to 256...Done.
    
    /usr/lib/pm-utils/power.d/readahead false: success.
    Running hook /usr/lib/pm-utils/power.d/sata_alpm false:
    Setting SATA APLM on host0 to max_performance...Done.
    Setting SATA APLM on host1 to max_performance...Done.
    Setting SATA APLM on host2 to max_performance...Done.
    Setting SATA APLM on host3 to max_performance...Done.
    Setting SATA APLM on host4 to max_performance...Done.
    Setting SATA APLM on host5 to max_performance...Done.
    
    /usr/lib/pm-utils/power.d/sata_alpm false: success.
    Running hook /usr/lib/pm-utils/power.d/sched-powersave false:
    **sched policy powersave OFF
    
    /usr/lib/pm-utils/power.d/sched-powersave false: success.
    Running hook /usr/lib/pm-utils/power.d/wireless false:
    Turning powersave for wlan0 off...Error for wireless request "Set Power Management" (8B2C) :
        SET failed on device wlan0 ; Operation not supported.
    Failed.
    
    /usr/lib/pm-utils/power.d/wireless false: success.
    Running hook /usr/lib/pm-utils/power.d/xfs_buffer false:
    
    /usr/lib/pm-utils/power.d/xfs_buffer false: success.
    Is this wrong?
    Running hook /usr/lib/pm-utils/power.d/wireless false:
    Turning powersave for wlan0 off...Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.
    Failed.


    Hope this helps...
    Lap #1: openSUSE 11.4 Kernel 2.6.37.6-0.7-desktop | 64bits | i7-720QM 1.60GHz | KDE 4.6 (ex Gnome 2.32.1 user) | ATI HD 5650 1GB | HP Pavilion dv7-4190us | 6GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •