Results 1 to 8 of 8

Thread: After update from 11.3 to 11.4, openSuse no longer remounts root rw.

  1. #1

    Default After update from 11.3 to 11.4, openSuse no longer remounts root rw.

    After updating from 11.3 to 11.4, Suse no longer remounts / as rw, meaning it cannot finish the boot process. This means every time my mom wants to use her computer I have to come up, remount / and the rest of the filesystems in fstab.

    How do I fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.


    -=welcome=- to our forum....been using openSUSE/Linux long?

    how did you upgrade from 11.3 to 11.4

    did this happen from the very first boot after 11.4, or did it work
    right for a while and then suddenly the partitions stopped mounting??

    please do these in a user terminal

    Code:
    cat /etc/fstab
    cat /etc/mtab
    df -h
    and copy/paste the output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.

    Quote Originally Posted by DenverD View Post
    -=welcome=- to our forum....been using openSUSE/Linux long?

    how did you upgrade from 11.3 to 11.4
    The instructions are from here.

    did this happen from the very first boot after 11.4, or did it work
    right for a while and then suddenly the partitions stopped mounting??
    It happened from every boot since the upgrade from 11.4.

    please do these in a user terminal

    cat /etc/fstab
    Code:
    /dev/disk/by-id/ata-TOSHIBA_MK1237GSX_974BTK8YT-part2 /     btrfs noatime 1 1
    /dev/disk/by-id/ata-TOSHIBA_MK1237GSX_974BTK8YT-part1 /boot ext4 noatime 1 2
    /dev/disk/by-id/ata-TOSHIBA_MK1237GSX_974BTK8YT-part3 /home ext4 defaults 1 2
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    cat /etc/mtab
    Code:
    /dev/sda2 / btrfs rw,noatime 0 0
    proc /proc proc rw 0 0
    sysfs /sys sysfs rw 0 0
    debugfs /sys/kernel/debug debugfs rw 0 0
    devtmpfs /dev devtmpfs rw,mode=0755 0 0
    tmpfs /dev/shm tmpfs rw,mode=1777 0 0
    devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
    /dev/sda3 /home ext4 rw,commit=0 0 0
    securityfs /sys/kernel/security securityfs rw 0 0
    /dev/sda3 /home ext4 rw,commit=0 0 0
    /dev/sda3 /home ext4 rw,commit=0 0 0
    /dev/sda3 /home ext4 rw,commit=0 0 0
    /dev/sda3 /home ext4 rw,commit=0 0 0
    df -h
    Code:
    Filesystem                Size  Used Avail  Use%  Mounted on
    /dev/sda2                  20G  6.2G  4.5G   59%  /
    devtmpfs                  488M  188k  488M    1%  /dev
    tmpfs                     495M  740k  494M    1%  /dev/shm
    /dev/sda3                  91G   27G   60G   31%  /home
    /dev/sda3                  91G   27G   60G   31%  /home
    /dev/sda3                  91G   27G   60G   31%  /home
    /dev/sda3                  91G   27G   60G   31%  /home
    /dev/sda3                  91G   27G   60G   31%  /home

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.

    Hmm btrfs. You realise it's still experimental and that you should know what you are doing?

  5. #5

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.

    Quote Originally Posted by ken_yap View Post
    Hmm btrfs. You realise it's still experimental and that you should know what you are doing?
    I do, but it is not as if the data is gone or unreadable.

    It is just every boot I have to go:
    Code:
    mount -n -o remount,rw /
    mount /home
    init 5
    After that, everything is hunky dory.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.

    On 2011-03-13 22:36, beachchairs wrote:
    >
    > After updating from 11.3 to 11.4, Suse no longer remounts / as rw,
    > meaning it cannot finish the boot process. This means every time my mom
    > wants to use her computer I have to come up, remount / and the rest of
    > the filesystems in fstab.
    >
    > How do I fix this?


    You have to look for errors in the log, and disable boot splash. However,
    as you are using btrfs, you are on your own, it is highly experimental. Not
    something to install on somebody else's computer if that person is not an
    expert.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.

    Quote Originally Posted by robin_listas View Post
    You have to look for errors in the log, and disable boot splash. However,
    as you are using btrfs, you are on your own, it is highly experimental. Not
    something to install on somebody else's computer if that person is not an
    expert.
    To be fair, I did the install about 2 years ago when it was my laptop and forgot btrfs was used since it never caused any problems.

    Anyways, I've solved the issue with:
    Code:
    ln -s /sbin/btrfsck /sbin/fsck.btrfs

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: After update from 11.3 to 11.4, openSuse no longer remounts rootrw.

    On 2011-03-14 02:06, beachchairs wrote:
    >
    > robin_listas;2303924 Wrote:



    > To be fair, I did the install about 2 years ago when it was my laptop
    > and forgot btrfs was used since it never caused any problems.


    That explains it :-)

    >
    > Anyways, I've solved the issue with:
    >
    > Code:
    > --------------------
    > ln -s /sbin/btrfsck /sbin/fsck.btrfs
    > --------------------


    Interesting. I think you should report this in a Bugzilla.

    Precisely the fsck code was the bit that needed work.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •