Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 11.4 Upgrade and audio

  1. #1

    Default 11.4 Upgrade and audio

    Audio does not work in the upgrade. The HDMI out does not work, and the USB mic in does not work (nor does it exist as a capture device in phonon settings. The video works fine).

    None of these HDMI options make sound



    What I have tried doing:
    * Delete phonondevicesrc
    * Reconfigure the sound device in yast2

    I also do not understand as I thought I should only see "internal audio" when using pulseaudio?

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: 11.4 Upgrade and audio

    Have you tried test sound?
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Απ: 11.4 Upgrade and audio

    Hi,

    Did sound work before with the 11.3 ?

    Make sure in the multimedia settings of the systems settings that the HDA Nvidia (ALC888 analog) is at the top of every categories.

    Second, did you set up audio as explained here : Multi-media and Restricted Format Installation Guide

  4. #4

    Default Re: Re : Απ: 11.4 Upgrade and audio

    There's another tab on that info box - it displays the Phonon backend module. A couple of my machines started giving me Phonon errors saying my audio chip wasn't working. This happened after a series of typical updates.

    My Phonon backend was Gstreamer. I went into Yast Software Management and selected Delete on the Gstreamer backend and Yast automatically selected the Xine backend as its replacement. I let that install and it fixed ALL my audio problems on 4 Suse 11.3 installations.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Re : Απ: 11.4 Upgrade and audio

    I'm still trying to figure out the behaviour of 11.4 given the changes to audio handling between 11.3 and 11.4.

    One application that I find has helped me a lot is the application 'pavucontrol'. I recommend you install 'pavucontrol' and then run 'pavucontrol' and then try to play an application. Look at 'pavucontrol' and see if you can then tune the output so that audio plays.

    I did find if I installed openSUSE-11.4 with a USB webcam or USB audio device plugged in, its configuration would not be predictable, and that once my USB webcam was configured as the default audio device (even thou it has no speaker - only a mic ! ). So there is a possibility of something being misconfigured.

  6. #6

    Default Re: 11.4 Upgrade and audio

    OK, after a reboot, the analog does not work anymore, but the HDMI and the webcam work. So whatever, as long as it doesn't change again after a reboot I'm ok.

    So now all I need is to figure out how to get flash/skype/alsa programs to output through HDMI.

    Code:
    pcm.!default
    {
        playback.pcm
        {
            type plug
            slave.pcm "hw:0,3"
        }
    }
    this asoundrc no longer seems to work.

  7. #7

    Default Re: 11.4 Upgrade and audio

    Quote Originally Posted by boast View Post
    OK, after a reboot, the analog does not work anymore, but the HDMI and the webcam work. So whatever, as long as it doesn't change again after a reboot I'm ok.

    So now all I need is to figure out how to get flash/skype/alsa programs to output through HDMI.

    Code:
    pcm.!default
    {
        playback.pcm
        {
            type plug
            slave.pcm "hw:0,3"
        }
    }
    this asoundrc no longer seems to work.
    I don't see how to edit posts.

    I also tried removing the asoundrc and setting asound.conf to be
    Code:
    pcm.pulse {
        type pulse
    }
    ctl.pulse {
        type pulse
    }
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }
    but still no luck. And it seems video players like smplayer do not emit sound (even kaffaine which i know uses the phonon settings). Only the "test sound" in the phonon config works and the login chime. Nothing else works. I also checked alsamixer to see if anything was low, but all was well.


    edit: and now the hdmi audio does not work again. Pressing test says the device is not working. The chime works, and then no audio for anything. I switch to xine, and nothing works. Then I switch to gstreamer, and it starts working again.

    I just don't get this pulseaudio implementation openSUSE has going on... I have pulseaudio + kde working fine on my arch box. I would connect the hdmi, relog in, and the hdmi audio would work fine.

  8. #8
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: 11.4 Upgrade and audio

    Since you upgraded (from 11.3?) and depending on how you upgraded, with soundcard configured and PulseAudio enabled in YaST, you could try adding a new userid to get fresh KDE settings and see what that does to phonon device configuration and KMix configuration.

  9. #9
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: 11.4 Upgrade and audio

    IMHO, if you have pulseaudio installed, remove it and taboo it. It gives nothing but pain.
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  10. #10

    Default Re: 11.4 Upgrade and audio

    Quote Originally Posted by boast View Post
    I don't see how to edit posts.

    I also tried removing the asoundrc and setting asound.conf to be
    Code:
    pcm.pulse {
        type pulse
    }
    ctl.pulse {
        type pulse
    }
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }
    but still no luck. And it seems video players like smplayer do not emit sound (even kaffaine which i know uses the phonon settings). Only the "test sound" in the phonon config works and the login chime. Nothing else works. I also checked alsamixer to see if anything was low, but all was well.


    edit: and now the hdmi audio does not work again. Pressing test says the device is not working. The chime works, and then no audio for anything. I switch to xine, and nothing works. Then I switch to gstreamer, and it starts working again.

    I just don't get this pulseaudio implementation openSUSE has going on... I have pulseaudio + kde working fine on my arch box. I would connect the hdmi, relog in, and the hdmi audio would work fine.
    Try to replace your first code with this in the /etc/asound.conf (you have to create the asound.conf)
    Code:
    pcm.!default hdmi:NVidia
    pcm:iec958 hdmi:NVidia
    Add this to your /etc/pulse/default.pa
    Code:
    ### Load HDMI 
    load-module module-alsa-sink device=hw:0,3
    In yast be sure to be a member of the audio group.

    For your second code it's dirty but kinda work but you won't need it if the above is working already. In your /etc/asound-pulse.conf

    Code:
    # PulseAudio plugin configuration
    
    # Let's create a virtual device "pulse" for mixer and PCM
    
    pcm.pulse {
        type pulse
    }
    
    ctl.pulse {
        type pulse
    }
    
    # Let's make it the default!
    
    pcm.!default {
        type plug
        slave.pcm {
        type hw 
            card 0
            device 3      
        } 
    }
    
    ctl.!default {
        type pulse
    }
    With this flash sound should work.

    With your mplayer you have to write your device if not present in the mplayer alsa configuration.

    Lastly you have to delete the .asoundrc in your /home/user
    In my 11.4 asoundrc doesn't seem to work instead /etc/asound.conf
    You need the machine to re-start

    Good luck
    People who do not break things first will never learn to create anything

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •