Me again

Anyone know if it's possible to retain CUPS 1.3.11 in openSuSE 11.4? I reverted from 1.4 in 11.3 because it broke the ink monitor function of my printer driver (had source to that part, but no experience with CUPS programming... hence no idea how to fix. Problem lies in the communication between the status client and CUPS, since the CUPS status for the printer will display the ink status codes. the canon GUI just doesn't read it anymore.)

FWIW, I have a canon iP4200 with the canon driver, v. 2.60.