Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Unrar not installed in 11.4 ?

  1. #1

    Default Unrar not installed in 11.4 ?

    Hi all,

    It seems that unrar isn't installed any more in 11.4?

    When i try to install it via Yast, it shows many dependencies that must be fulfilled, the total download comes to something over 400 MB.

    Just for unrar?

    Does anybody have the same experience?

    TIA

    Lenwolf

  2. #2
    Join Date
    Dec 2008
    Location
    Delhi, INdia
    Posts
    108

    Default Re: Unrar not installed in 11.4 ?

    can uninstall it without problem, its not showing dependencies here....

  3. #3

    Default Re: Unrar not installed in 11.4 ?

    For my 11.4 upgraded from 11.3, "zypper info --requires unrar" shows only libc, libstdc++, libgcc and rpmlib, nothing unexpected. I use the oss, non-oss and update repos.

  4. #4

    Default Re: Unrar not installed in 11.4 ?

    unrar is in the non-oss repo, did you update that repo from 11.3? if oss was 11.4 and non-oss 11.3 that could explain it
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  5. #5

    Default Re: Unrar not installed in 11.4 ?

    Hi,

    thanks for your anwers.

    Here is what "zypper info --requires unrar" tells me :
    Code:
    (...)
    Needs :
    ibc.so.6()(64bit)
    libc.so.6(GLIBC_2.2.5)(64bit)
    libc.so.6(GLIBC_2.4)(64bit)
    libc.so.6(GLIBC_2.3.4)(64bit)
    libgcc_s.so.1()(64bit)
    libstdc++.so.6()(64bit)
    libc.so.6(GLIBC_2.7)(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(GLIBCXX_3.4)(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    This is a "fresh" install of 11.4 from a DVD downloaded (and yes, i checked the installation media which is OK).

    I put fresh between quotes because I elected to keep my /home dir.

    Strange!

    Lenwolf

  6. #6

    Default Re: Unrar not installed in 11.4 ?

    what is output of: zypper install unrar
    -- if output too large use pastebin

    what is top of cmd: zypper info --requires unrar
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,815
    Blog Entries
    15

    Default Re: Unrar not installed in 11.4 ?

    Quote Originally Posted by lenwolf
    This is a "fresh" install of 11.4 from a DVD downloaded (and yes, i
    checked the installation media which is OK).

    I put fresh between quotes because I elected to keep my /home dir.

    Strange!

    Lenwolf
    Hi
    I installed from the Gnome LiveCD and saw unrar come in along with
    other additional packages like flash, LibreOffice etc the first time
    using YaST to add software.

    What happens if you just do zypper in unrar from the command line.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.29-0.3-default
    up 15:58, 2 users, load average: 0.44, 0.45, 0.31
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26


  8. #8

    Default Re: Unrar not installed in 11.4 ?

    Hi,

    Code:
    zypper install unrar
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      unrar 
    
    1 new package to install.
    Overall download size: 107.0 KiB. After the operation, additional 239.0 KiB 
    will be used.
    Continue? [y/n/?] (y): n
    and

    Code:
    zypper info --requires unrar
    Loading repository data...
    Reading installed packages...
    
    (...)
    Requires:                                                                       
    libc.so.6()(64bit)                                                              
    libc.so.6(GLIBC_2.2.5)(64bit)                                                   
    libc.so.6(GLIBC_2.4)(64bit)                                                     
    libc.so.6(GLIBC_2.3.4)(64bit)                                                   
    libgcc_s.so.1()(64bit)                                                          
    libstdc++.so.6()(64bit)                                                         
    libc.so.6(GLIBC_2.7)(64bit)                                                     
    libstdc++.so.6(CXXABI_1.3)(64bit)                                               
    libstdc++.so.6(GLIBCXX_3.4)(64bit)                                              
    libgcc_s.so.1(GCC_3.0)(64bit)                                                   
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    Thanks!

    Lenwolf

  9. #9

    Default Re: Unrar not installed in 11.4 ?

    "zypper install unrar" states 1 new package to install total size of 107.0, additional 239.0 Kib? and yast says 400mb?

    you are running 64bit and the unrar you try installing in yast is the 64bit?

    try cleaning your cache: zypper clean

    what is the top of the cmd zypper info --requires unrar ?
    will look like:
    Information for package unrar: zypper clean

    Repository: @System
    Name: unrar
    Version: 4.0.4-3.1
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 239.0 KiB
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #10

    Default Re: Unrar not installed in 11.4 ?

    HI,

    yes I know it sounds strange.

    Here's the first yast screen after choosing to install unrar :

    SUSE Paste

    Here's the second screen when trying to install it : note the nbr of MBs remaining :

    SUSE Paste

    Thanks

    Lenwolf

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •