Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Need python 2.6 in Suse 11.4

  1. #21
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Default Re: Need python 2.6 in Suse 11.4

    Hello again,

    I had accidently added the packman repo for 11.2, not a good idea seeing as I'm running 11.4, ha ha, silly mistakes we make. Thanks for the tips all

  2. #22
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    DawthLasu wrote:

    >
    > Hello again,
    >
    > I had accidently added the packman repo for 11.2, not a good idea
    > seeing as I'm running 11.4, ha ha, silly mistakes we make. Thanks for
    > the tips all
    >

    I suspected something like that, glad you solved it :-)

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  3. #23

    Angry Re: Need python 2.6 in Suse 11.4

    Me too. I am unable to install Python 2.6 from the source. I have this error:

    Code:
    Failed to find the necessary bits to build these modules:
    _bsddb             bsddb185           dl              
    imageop            sunaudiodev                        
    To find the necessary bits, look in setup.py in detect_modules() for the module's name.
    
    
    Failed to build these modules:
    _curses_panel                                         
    
    running build_scripts
    I have ncurses-devel-32bit in Yast but no 64 version and I am on OpenSuse 11.4.

    Here are the repositories I have for Packman:

    Index of /pub/mirrors/packman/suse/openSUSE_11.4/
    Index of /suse/openSUSE_11.4/Essentials/
    Index of /suse/openSUSE_11.4/Multimedia/

    Where do you get the ncurses-devel?

  4. #24
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    pierreth wrote:

    >
    > Me too. I am unable to install Python 2.6 from the source. I have this
    > error:
    >
    >
    > Code:
    > --------------------
    > Failed to find the necessary bits to build these modules:
    > _bsddb bsddb185 dl
    > imageop sunaudiodev
    > To find the necessary bits, look in setup.py in detect_modules() for the
    > module's name.
    >
    >
    > Failed to build these modules:
    > _curses_panel
    >
    > running build_scripts
    >
    > --------------------
    >

    No it did NOT fail, you succeeded.
    It just tells you that some outdated modules where not built.
    Let me ask a question, what would you use sunaudio or bsddb185 for? I cannot
    even imagine what you would use it for if you can make this bits compile.
    _curses_panel compiles on nearly no operating system known on this planet.

    Just run now "make altinstall" as root.
    The executable is then python2.6 if you want the 2.6 version to run.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #25

    Default Re: Need python 2.6 in Suse 11.4

    I got around the panel.h problem by using /usr/include/ncurses/panel.h but I'm not sure that's the correct way to do it.

    In any case, trying to run python2.6 fails because it can't find modules, even using the process as described (make altinstall).

    I get the following:

    Could not find platform dependent libraries <exec_prefix>
    Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
    Python 2.6.7 (r267:88850, Jan 6 2012, 00:45:23)
    [GCC 4.6.2] on linux3
    Type "help", "copyright", "credits" or "license" for more information.
    Traceback (most recent call last):
    File "/etc/pythonstart", line 7, in <module>
    import readline
    ImportError: No module named readline
    >>>

    also trying import select, and any other module fails. I have ncurses-devel installed

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •