Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Need python 2.6 in Suse 11.4

  1. #11
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    martin_helm wrote:

    > ed v wrote:
    >
    >> panel.h

    > I would say you need ncurses-devel
    >

    Or even simpler
    Code:
    su - -c "zypper si -d python"
    installs (only) the build dependencies for python (2.7 but the build
    dependencies should be identical with the ones for 2.6, in the worst case
    you waste a bit of disk space).

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  2. #12
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Default Re: Need python 2.6 in Suse 11.4

    Hi there,

    I've been reading this thread as I've had some problems with Python 2.6. Whilst I'm no developer I find that occasionally something I install from the Repos, both the default 11.4 or Packman are returning dependencies of python2.6.

    I've followed the instructions left by yourself, Martin, and had no errors returned, however apps that require it still refuse to run, such as my torrent client of choice Deluge, is there any help you could offer?

    Thanks in advance, and great tip Martin!

  3. #13

    Default Re: Need python 2.6 in Suse 11.4

    I have ncurses_devel but not the 32 bit version... I wouldn't think I would need the 32 bit version as I am on a 64 bit machine..
    will give the
    Code:
    su - -c "zypper si -d python"
    a try.

  4. #14
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    DawthLasu wrote:

    > Deluge

    Hi, how do you install that? If you compile python 2.6 yourself it is not
    visible to the package system (you would need to create a rpm for python 2.6
    to make it visible).

    But deluge should be simply installable via yast (it is in the packman
    repo), is something wrong with that version?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #15

    Default Re: Need python 2.6 in Suse 11.4

    same error... after I ran zypper
    Code:
    Failed to find the necessary bits to build these modules:
    _bsddb             bsddb185           dl              
    imageop            sunaudiodev                        
    To find the necessary bits, look in setup.py in detect_modules() for the module's name.
    
    
    Failed to build these modules:
    _curses_panel

  6. #16
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    martin_helm wrote:

    > But deluge should be simply installable via yast (it is in the packman
    > repo), is something wrong with that version?
    >

    @DawthLasu:
    I did a dry run to install deluge from packman (simulated install without
    installing it) and it pulls in some dependencies on 11.4 (additional python
    packages) but nothing it cannot resolve from the standard repositories
    everthing satisfied. Are you sure you configured the correct version of the
    packman repo?

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #17
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    ed v wrote:

    >
    > same error... after I ran zypper
    >
    > Code:
    > --------------------
    >
    > Failed to find the necessary bits to build these modules:
    > _bsddb bsddb185 dl
    > imageop sunaudiodev
    > To find the necessary bits, look in setup.py in detect_modules() for the
    > module's name.
    >
    >
    > Failed to build these modules:
    > _curses_panel
    >
    > --------------------
    >

    Ok I can check this evening, what I had to install on 11.4 to compile it.
    Will come back on this in a few hours.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  8. #18
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Need python 2.6 in Suse 11.4

    martin_helm wrote:

    > ed v wrote:
    >
    >>
    >> same error... after I ran zypper
    >>
    >> Code:
    >> --------------------
    >>
    >> Failed to find the necessary bits to build these modules:
    >> _bsddb bsddb185 dl
    >> imageop sunaudiodev
    >> To find the necessary bits, look in setup.py in detect_modules() for
    >> the module's name.
    >>
    >>
    >> Failed to build these modules:
    >> _curses_panel
    >>
    >> --------------------
    >>

    > Ok I can check this evening, what I had to install on 11.4 to compile it.
    > Will come back on this in a few hours.
    >

    No sorry nonsense just checked your messages again.
    Your build succeeded, the build process just informs you that there exist
    some modules which cannot be build on your environment (this differs a
    little bit from what cannot be built on a 32 bit test machine). On my own 64
    bit also not everything can be built and on solaris and ubuntu and others
    you have slightly different modules which cannot be built.

    Just ignore that, it nearly never works to have all the exotic stuff built.

    Fact is your python build is successfull.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #19

    Default Re: Need python 2.6 in Suse 11.4

    thank you for the help.
    apparently I have working python :shrug:
    thanks
    ed

  10. #20
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Default Re: Need python 2.6 in Suse 11.4

    Hi all,

    With regards to Deluge, I had installed from within YaST, it tells me there are broken dependencies, and indeed it did not work. However following your help to compile and install Python 2.6 alongside the bundle 2.7 helped me build it from source no problem and now it works fine.

    I have all of Packman configured, as in I have the one Packman repo listed to be all of it in the Wiki.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •