Results 1 to 10 of 10

Thread: Enabling touchpad tapping on a synaptics touchpad

  1. #1
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Enabling touchpad tapping on a synaptics touchpad

    11.3 and 11.4 do not come with touchpad tapping enabled; to enable this at the login screen add
    Option "TapButton1" "1"
    to synaptics.conf

    Both KDE and Gnome offer synaptics configuration programs to access the other features of a touchpad.

  2. #2
    Join Date
    Mar 2009
    Location
    Central Utah
    Posts
    43

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    Quote Originally Posted by john_hudson View Post
    Both KDE and Gnome offer synaptics configuration programs to access the other features of a touchpad.
    Version 11.4, KDE installed.

    Cannot get any sort of KDE touchpad configuration to work.

    "Personal Settings" "Input Devices" "Touchpad" selection gives the following message:

    "Warning: Touchpad configuration is not supported on this system. The synaptics driver is either not loaded or too old. Refer to the documentation for information about the required driver version."


    YAST tells me I have SYNAPTIKS version 0.4.0-9.2 "A touchpad management tool for KDE" installed. Other option is gsynaptics - a GNOME tool?? - not installed.


    /etc/x11/xorg.conf.d/50-synaptics.conf contains:

    Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "HorizScrollDelta" "0"
    EndSection

    which doesn't seem useful.

    Where else to look/do?

    Thanks,
    Mike

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,902
    Blog Entries
    3

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    Quote Originally Posted by Relative View Post
    "Warning: Touchpad configuration is not supported on this system. The synaptics driver is either not loaded or too old. Refer to the documentation for information about the required driver version."
    A number of people have reported that with 11.3 also. I guess you could report it as a bug, or just wait until the software catches up with the newer hardware.

    That sometimes happens to me, with a new Dell laptop (with openSuSE 11.3). If I directly boot into openSuSE, then things are fine. But if I first boot to windows, and then reboot (warm restart) into linux, I get that message. On an older (2004 vintage) laptop, I don't have that problem. However some of the touchpad config doesn't work there with 11.4, though it did work with 11.3.

    As far as the default (tapping turned off) - that's good. Windows defaults to it turned on, and people like me with a heavy touch have problems with the initial setup screens on Windows, before you get to a place where you can turn off tappig. The default of no-tapping is safer, and let people turn it on if they wish.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Mar 2009
    Location
    Central Utah
    Posts
    43

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    Quote Originally Posted by nrickert View Post
    As far as the default (tapping turned off) - that's good. Windows defaults to it turned on, and people like me with a heavy touch have problems with the initial setup screens on Windows, before you get to a place where you can turn off tappig. The default of no-tapping is safer, and let people turn it on if they wish.
    Actually, the tap does work on mine. But I would like the rest of its features to work, especially the up/down rocker between the left/right buttons.

    Mike

  5. #5

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    The first posting was accurate, but a little too brief. So I will describe it in more detail. Also valid for OpenSUSE 12.1, for all desktop environments (KDE, Gnome, Xfce, LXDE, ....).

    1. Make yourself root in the terminal (su):
    type:
    Code:
    su
    Press Enter. Fill out your password, this remains entirely invisible, not even dots will show. Press Enter again.

    2. Install Beaver (Gedit used as root, sometimes causes trouble):
    In the terminal (use copy/paste):
    Code:
    zypper install beaver
    Press Enter.

    3. In the terminal, still as root (use copy/paste):
    Code:
    beaver /etc/X11/xorg.conf.d/50-synaptics.conf
    Press Enter.

    4. Add the following option, beneath the option that's already there (use copy/paste):
    Code:
    Option "TapButton1" "1"
    5. Save the file.

    6. Reboot. Tapping should work now.
    Nederlandstalige tips voor openSUSE:
    http://sites.google.com/site/computertip/opensuse

  6. #6

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    I do this but my problem don't be solved.

  7. #7

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    Quote Originally Posted by amir7 View Post
    I do this but my problem don't be solved.
    You should put the new Tap option straight under this existing option:
    Option "HorizScrollDelta" "0"

    It only works when you put it at that place. Then save the text file and reboot your computer.
    Nederlandstalige tips voor openSUSE:
    http://sites.google.com/site/computertip/opensuse

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    This thread was started in the wrong forum. Seems nobody saw the large banner at the top: Please don't ask questions here. I'm going to ask a mod to move it.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,255
    Blog Entries
    15

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    Temporarily closing thread and moving to applications.

    nntp users please don't reply until I confirm thread is moved.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,255
    Blog Entries
    15

    Default Re: Enabling touchpad tapping on a synaptics touchpad

    Quote Originally Posted by john_hudson View Post
    11.3 and 11.4 do not come with touchpad tapping enabled; to enable this at the login screen add
    Option "TapButton1" "1"
    to synaptics.conf

    Both KDE and Gnome offer synaptics configuration programs to access the other features of a touchpad.
    Thread moved and reopened.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •