Results 1 to 6 of 6

Thread: VLC shows black screen when playing movie files (solutions)

  1. #1

    Default VLC shows black screen when playing movie files (solutions)

    Hello,
    With a default 11.4 (64bit) installation, and the one click installer for VLC at VideoLAN - VLC: Free streaming and multimedia solutions for all OS! - if you get a black screen when watching movie files there are 2 solutions.

    1)
    -> Go to Tools->Preferences->Video
    -> Remove the tick for "Accelerated video output (Overlay)"
    -> Try and play the movie again, you should now see output.

    2)
    Download proprietary drivers for your graphics card - I think theres a thread on the forum dedicated to that.
    Example, NVIDIA 8600 using the default 11.4 open source drivers (nouveau?) shows a black screen when VLC uses "Accelerated video output".
    However, installing the proprietary NVIDIA drivers, VLC will successfully show the movie using "Accelerated video output".

    To clarify the default VLC installation with "Accelerated video output" ticked - works with proprietary NVIDIA drivers - and doesn't without.

    Thanks

    ps. Thanks to the team as my integrated ATI Radeon card using default 11.4 open source drivers works with VLC and "Accelerated video output" ticked.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VLC shows black screen when playing movie files (solutions)

    You should post for us please your repo list

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: VLC shows black screen when playing movie files (solutions)

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+----------------------------------+----------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
    1 | 11.4 - VideoLan | 11.4 - VideoLan | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.4/ |
    2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    3 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD+_-RW_GSA-T11N_K0B6B4M4419,/dev/sr0 |
    4 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.4/repo/oss |
    5 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
    6 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    7 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    8 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.4/repo/oss |

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VLC shows black screen when playing movie files (solutions)

    You need to open software manager
    View by repo and select vlc repo
    Then from the top menu, select Packages> All in this list > Delete

    If you are using gnome you need to switch to the QT UI for yast: Switch Yast Interface to QT

    If you can't successfully delete all the packages. Just remove the repo from the list and follow this:
    Multi-media and Restricted Format Installation Guide

    Being sure to make the package switch on Packman
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: VLC shows black screen when playing movie files (solutions)

    Thanks for your help - I will do that.

    So is the 1 click installer from VideoLAN - VLC: Free streaming and multimedia solutions for all OS! no good then - as my 2 workarounds above allow watching movies if the defaults don't.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: VLC shows black screen when playing movie files (solutions)

    Don't use the VLC repo

    There are Oneclick multimedia options via this: Multimedia in One Click

    We even removed VLC repo from the community list in Yast because of the problems it causes.

    VLC (the player) should be installed from Packman
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •