Hello,
With a default 11.4 (64bit) installation with Gnome - and using the 11.4 one click installer on
VideoLAN - VLC: Free streaming and multimedia solutions for all OS! - the 11.3 integration seems to have worked better.

The first issue is that it's no longer automatically integrated into the right click context menu of movie files.

This integration happened in 11.3.

The second, which I think is user error but I really cannot get it to work is dragging and dropping files does not work.

-> Open Nautilus
-> Navigate to folder with movie files
-> Open VLC
-> Click on a file in Nautilus and try and drag it onto VLC
The VLC is hidden during the file click and drag, so a drag to the bottom panel is required to try and activate VLC - however, VLC is never activated. I have tried different positions on screen but still over the VLC entry to try and activate it, but nothing happens.

This same sequence on 11.3 correctly activates VLC so I can drag and drop.

A workaround on 11.4 is to make VLC "Always on top" via the right click menu on the VLC title bar.

Thanks