Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: KPackageKit HTTP_PROXY error on update 11.4

  1. #1

    Default KPackageKit HTTP_PROXY error on update 11.4

    I am having an issue with KPackageKit, actually 2 issues but one makes it unusable.

    The major issue is that when I go to apply the updates I get the following error message (at least here are the details of the message)
    Code:
    Download (curl) error for 'http://download.nvidia.com/opensuse/11.4/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve proxy 'HTTP_PROXY'
    I do not run my connection through a proxy and my internet works correctly. This is on a laptop I upgraded using zypper from 11.3 to 11.4 (I did the same with a desktop which does not have this issue). zypper refresh successfully refreshes the repositories, and the various Yast repo tools all work correctly. Additionally after I am shown the updates and am prompted for root pw, the packages will no longer show up for a while, each time it tries to look for updates the message comes through but they will show up after a while again.

    The other issue I have is that it requests my pw multiple times, this also happens on my desktop that actually will update. I get prompted twice, they are immediate and back to back. This one is a little minor annoyance but there should be no reason that it needs to make this request multiple times.

    Any help would be appreciated, and I am more concerned about the HTTP_PROXY issue. Please note that I use NetworkManager to control my connections on my laptop that has the issue, and my desktop I use the traditional ifconfig to control my connections.

    Additionally I have the same repos setup on both computers.

  2. #2

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    I had the same problem and solved by deleting two files (make a backup first!):

    Code:
    .kde4/share/config/kioslaverc
    .kde/share/config/kioslaverc
    I am not sure why this file is duplicated, maybe a remnant of my openSUSE 11.2 installation.

    Hernan

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    I had the same problem with the beast that is KPackageKit. Updating via Yast/zypper continued to work well and provides more information that is useful at this early stage a new release.

  4. #4

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    I removed .kde4/share/config/kioslaverc however it didnt solve anything, also interestingly enough the file did not get recreated when I restarted kde (or ran kpackagekit manually).

  5. #5

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    Quote Originally Posted by baaldemon View Post
    I removed .kde4/share/config/kioslaverc however it didnt solve anything, also interestingly enough the file did not get recreated when I restarted kde (or ran kpackagekit manually).
    Strange! I started openSuSE, tested KPackageKit (it was not working), deleted these files, rebooted and then KPackageKit was working!

    While I was trying to solve this I found this bug report. You might keep and eye on this to see what the developers say.

    Hernan

  6. #6

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    So I still have the issue, but wanted to give some more information.

    my original ~/.kde4/share/config/kioslaverc file was
    Code:
    [$Version]
    update_info=kioslave.upd:kde2.2/r1,kioslave.upd:kde2.2/r2,kioslave.upd:kde2.2/r3
    
    [Proxy Settings]
    ProxyType=1
    I checked the file on my desktop that works and copied it over. It simply didnt have the Proxy Settings section to it
    Code:
    [$Version]
    update_info=kioslave.upd:kde2.2/r1,kioslave.upd:kde2.2/r2,kioslave.upd:kde2.2/r3
    I also verified that the /root/.kde4/share/config/kioslaverc file did not contain proxy settings (it didnt and matches the above).

    I also checked /etc/kde4/share/config/kioslaverc it matches the file on my desktop that works. It contents are

    Code:
    [Proxy Settings]
    NoProxyFor=NO_PROXY
    ProxyType=4
    ftpProxy=FTP_PROXY
    httpProxy=HTTP_PROXY
    httpsProxy=HTTPS_PROXY
    Still have no clue why its not working.

  7. #7

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    Just an update on this if anyone else is looking at this thread. Another user and myself were able to resolve the issue by switching the network configuration to traditional with ifup restarting kde, and then switching back to network manager and restarting kde.

  8. #8
    Join Date
    Sep 2008
    Location
    Houston, Texas, USA
    Posts
    44

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    Quote Originally Posted by baaldemon View Post
    I am having an issue with KPackageKit, actually 2 issues but one makes it unusable.

    The major issue is that when I go to apply the updates I get the following error message (at least here are the details of the message)
    Code:
    Download (curl) error for 'http://download.nvidia.com/opensuse/11.4/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve proxy 'HTTP_PROXY'
    I do not run my connection through a proxy and my internet works correctly. This is on a laptop I upgraded using zypper from 11.3 to 11.4 (I did the same with a desktop which does not have this issue). zypper refresh successfully refreshes the repositories, and the various Yast repo tools all work correctly. Additionally after I am shown the updates and am prompted for root pw, the packages will no longer show up for a while, each time it tries to look for updates the message comes through but they will show up after a while again.

    The other issue I have is that it requests my pw multiple times, this also happens on my desktop that actually will update. I get prompted twice, they are immediate and back to back. This one is a little minor annoyance but there should be no reason that it needs to make this request multiple times.

    Any help would be appreciated, and I am more concerned about the HTTP_PROXY issue. Please note that I use NetworkManager to control my connections on my laptop that has the issue, and my desktop I use the traditional ifconfig to control my connections.

    Additionally I have the same repos setup on both computers.
    In contrast with the problem above, on my system, I'm not prompted at all for a password. Updating fails using KPackageKit with an authentication error message. I can only use YAST online update. Also, YAST and KPKit don't show the same list of available updates - updates are listed in KPKit that do not appear in YAST.

    Other specifics of my system that might be relevant - I'm operating with a clean install of 11.4 on a newly formatted partition; and, I enabled the superuser (unchecked "use same password" for root) during installation. Perhaps that is adding to KPackageKit's confusion.

    This would appear to be a bug that would presumably be addressed by an update, but any assistance with a workaround for the problem would be appreciated.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,890
    Blog Entries
    3

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    I had that problem occur. This was on a clean install from the live KDE 32 bit CD.

    I did an online update via Yast. The problem has not occurred again, even though additional updates have come through.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: KPackageKit HTTP_PROXY error on update 11.4

    @Rulls I have the same experience; however, the reason why all the updates that appear in KPackageKit do not appear in YaST is that KPackageKit lists both security updates - which appear under Patches in Online update - and new versions - which you can only get in Repositories>System by clicking Packages>All in this list>Update if new version available.

    If you don't have a Repositories tab, go to View and click on Repositories.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •