Results 1 to 4 of 4

Thread: Can't unlock my password in seahorse

  1. #1
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Thumbs down Can't unlock my password in seahorse

    Hello Community:

    I just did a fresh install of 11.4
    My system auto-logs in and I know there's a bug in seahorse that doesn't like that method.

    Anyway, I tried to unlock my "Passwords: login" in seahorse, but it won't budge.

    The details about this user are that I re-used an 11.3 /home/$user directory. Could that be the reason?
    I logged out of the Desktop and back in using my password manually.
    I can sudo with my password. I can change the system with my password everywhere except in seahorse.
    The password is exactly the same in 11.4 as it was in 11.3.

    The .gnupg/ directory is 600 and its contents are all 600 except for agent.info which is 644.

    Following a year old post, I got this from shell:
    Code:
    echo $GPG_AGENT_INFO
    /tmp/keyring-qP4QMk/gpg:0:1
    
    ls -l /tmp/keyring-qP4QMk/gpg
    srwxr-xr-x 1 jj2 users 0 Mar 11 2011  5:18 PM /tmp/keyring-qP4QMk/gpg
    Any help would be greatly appreciated.

    Thank You for your time.

  2. #2
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Can't unlock my password in seahorse

    n/m.

    I figured it out.

    Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Can't unlock my password in seahorse

    On 03/12/2011 08:36 PM, Habitual wrote:
    >
    > I figured it out.


    since another seahorse user might have the same problem after freshly
    installing 11.4, and might google into this thread looking for help:

    please tell us how you solved the problem..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  4. #4
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: Can't unlock my password in seahorse

    DenverD:

    Under a fresh install there is no "Password: login" entry in seahorse.
    Using sftp://mydomain.com just now prompted me to add this entry to my empty keyring along with creating a new password for the seahorse keyring.
    It works as expected.

    My mistake was copying the ~/.gnupg from the other install over to the newly installed 11.4

    I now realize I should have exported my public/private key in the other OS and imported them into 11.4 instead of mass copying .directories from another install.

    However, the "Remember forever" option upon Unmount and reconnect does NOT work as expected.
    I get prompted for user/pass every time even if "Remember forever" is selected and the keyring IS unlocked. Strange.
    So does this now become a nautilus issue or a seahorse one?

    What to do or how to pursue a resolution?

    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •