Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: error while loading shared libraries

  1. #1

    Question error while loading shared libraries

    Hello All....
    I am running suse 11.3 kernel 2.6.34.7-0.7-desktop, trying to get fldigi 3.21.5, a ham radio app, running but I get this error: fldigi: error while loading shared libraries: libportaudio.so.2: cannot open shared object file: No such file or directory

    I have found that this is a quite common error for other apps using this file and have tried many things to try and fix. All audio libraries appear to be installed, the file is the with a soft link pointing to libportaudio.so.2.0.0 which I copied out of /usr/lib64 renamed to libportaudio.so.2 and then put back in /usr/lib64 so both were there. ie I have tried several things but no work! Any help would be appreciated!!
    Thanks
    Greg

  2. #2
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: error while loading shared libraries

    Did you get it working?

    It would be great if we could get a openSUSE rpm for flidigi and WSPR for 11.3 and 11.4. I don't have the slightest idea how to make a package so would have to depend on others to make it.

    My "hardware" shows my SignaLink USB audio device and my Prolific USE to Serial converter on my 11.4 install so all I need is working programs. I am very keen to get this system playing with WSPR otherwise I'll have to run WIndows 7 to do any ham radio activities. I seems everyone is running Ubuntu and pre-compiled binaries exist for Ubuntu and Debian. I really don't want to have to switch away to Ubuntu just to enjoy Amateur Radio under Linux.
    Tumbleweed

  3. #3

    Default Re: error while loading shared libraries

    Which version are you using? Shouldn't be any problem running flidigi from Index of /repositories/hamradio/openSUSE_11.4

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: error while loading shared libraries

    greghv wrote:

    >
    > Hello All....
    > I am running suse 11.3 kernel 2.6.34.7-0.7-desktop, trying to get
    > fldigi 3.21.5, a ham radio app, running but I get this error: fldigi:
    > error while loading shared libraries: libportaudio.so.2: cannot open
    > shared object file: No such file or directory
    >

    Is that the version from the OBS (hamradio repository)? I guess not because
    it has 3.21.9. I cannot comment if it works but would give it a try since it
    is built for 11.3 (also available for 11.4).

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: error while loading shared libraries

    Sorry forgot the link

    http://software.opensuse.org/search?...ude_debug=true

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: error while loading shared libraries

    FlameBait wrote:
    > It would be great if we could get a openSUSE rpm for flidigi and WSPR
    > for 11.3 and 11.4. I don't have the slightest idea how to make a package
    > so would have to depend on others to make it.
    >

    WSPR is also in the hamradio repo, see my link in the other post and just
    search wspr (for 11.3 and 11.4)

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: error while loading shared libraries

    I am wondering why this repo Index of /repositories/hamradio doesn't show up in YAST >Configure Software Repositories >Add ?
    What do I have to do to get it to show up in YAST?

    That was the first place I looked? How would anyone know is there were already binaries? I was totally under the impression that nothing existed?
    Tumbleweed

  8. #8
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: error while loading shared libraries

    I keep getting unresolved dependencies when I try and install both WSPR and fldigi.
    They need hamlib and I can't install that do to another dependency. The whole repo needs to be added in to YAST so YAST can deal with it.
    Tumbleweed

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: error while loading shared libraries

    Open yast -> software -> software repositories
    at the bottom there is a button "add" (please keep in mind it can have
    slightly different names I translate from the german localisation)
    click that and choose "URL ..." then copy the url
    http://download.opensuse.org/reposit...openSUSE_11.3/
    into the second field and click next
    if you are using 11.4 of course change the url accordingly

    I hope I understood your question.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: error while loading shared libraries

    Or simply use the 1-click on the webpage that will add this repo for you.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •