Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Language input method setup in OpenSUSE 11.4?

Hybrid View

  1. #1
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Angry Language input method setup in OpenSUSE 11.4?

    I just switched back from Mint 10, and while setting to work different input method apps like SCIM and Ibus, bumped into a problem(welcome back to SUSE). After installing Scim, my chinese input works only on one application (Goldendict), it doesn't work in any other app. So I tried Ibus, same result. SO far nothing helped me to make them work.
    What I 'm trying to find out. Is where I can setup language input method in SUSE, I haven't found such an option anywhere in KDE, yast. WHile in Mint there is such an option, where you can change your inpud method either to scim, xim, scim-bridge or ibus. I tried qtconfig, there I found it, but that didn't help me.

    P.S. Warning rage words!:
    I feel like I should say it. But my previous SUSE experience and overall usage history proves that there is no better distro than Ubuntu nowadays, this is sad indeed, cause I used to start from SUSE. But its true, SUSE is a real pain in the ***, when it comes to getting things done. It seems like whenever u try to setup something there is always a bad feeling of failure. Don't know, but again I'm been consecutively annoyed but its numbness. I'm sorry, cause I feel like I disregard ppl's hard work and support.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Language input method setup in OpenSUSE 11.4?

    System Settings>Regional>Keyboard layout used to offer a way to set up the keyboard layout - but I understand System Settings has been redesigned in 4.6.

  3. #3
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Default Re: Language input method setup in OpenSUSE 11.4?

    Yes. I was looking for this option everywhere, but to no avail. I think it would be nice to have it under the hood right there.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Language input method setup in OpenSUSE 11.4?

    Quote Originally Posted by letian View Post
    P.S. Warning rage words!:
    I feel like I should say it. But my previous SUSE experience and overall usage history proves that there is no better distro than Ubuntu nowadays, this is sad indeed, cause I used to start from SUSE. But its true, SUSE is a real pain in the ***, when it comes to getting things done. It seems like whenever u try to setup something there is always a bad feeling of failure. Don't know, but again I'm been consecutively annoyed but its numbness. I'm sorry, cause I feel like I disregard ppl's hard work and support.
    Don't feel bad -- it's normal human nature to be frustrated occasionally.

    I like Ubuntu too. But I like openSUSE better. Years ago, when I was not so familiar with openSUSE, I would spend a lot of time hunting for ways to get new configurations to work. And I would sometimes become frustrated like you do. But I nearly always (eventually) found a way. Then I would feel the sweet satisfaction of success.

    Keep trying, it's a worthy battle, and good ppl are here to help you.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Default Re: Language input method setup in OpenSUSE 11.4?

    Quote Originally Posted by swerdna View Post
    Don't feel bad -- it's normal human nature to be frustrated occasionally.

    I like Ubuntu too. But I like openSUSE better. Years ago, when I was not so familiar with openSUSE, I would spend a lot of time hunting for ways to get new configurations to work. And I would sometimes become frustrated like you do. But I nearly always (eventually) found a way. Then I would feel the sweet satisfaction of success.

    Keep trying, it's a worthy battle, and good ppl are here to help you.
    ))) Thank you

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Language input method setup in OpenSUSE 11.4?

    Having now installed 11.4 from a CD, I can tell that you the CD version only comes with the four default languages; you have to install KDE additional languages yourself. So that may be the cause of the problem. Having done that, everything appears fine but I haven't yet found the keyboard layout module in the new setup in order to add/change layouts.

  7. #7
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Default Re: Language input method setup in OpenSUSE 11.4?

    yes, I think that was the reason, after I added Chinese language via "languages" option and rebooted, ibus started work on all apps.
    The only posible way to change a layout input method in KDE, i think, is to open in console "qtconfig" and under a tab "interface" choose a desired option for input method, but it is not available from "personal preferences".

  8. #8
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    115

    Default Re: Language input method setup in OpenSUSE 11.4?

    SuSEconfig drop gtk2 module in 11.4
    after install inputmethod as ibus, you have to run
    gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules for x86
    gtk-query-immodules-2.0-64 > /etc/gtk-2.0/gtk64.immodules for x86_64
    that will enable gtk-immodule support

  9. #9
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Default Re: Language input method setup in OpenSUSE 11.4?

    thanks, but the issue got resolved somehow by himself after reboot I guess.

  10. #10

    Default Re: Language input method setup in OpenSUSE 11.4?

    I could find a solution to this problem using a tricky method. read the full article on How to enable Keyboard Layout on OpenSuSE 11.4

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •