Results 1 to 9 of 9

Thread: Setiing DSL connection in 11.4 KDE

  1. #1
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Setiing DSL connection in 11.4 KDE

    Hi, I just installed 11.4 (64 Bit) KDE.

    I have configured a dsl connection using network manager but still the connection which I named BSNL won't show up in "networking interfaces" or "Connections".

    The auto eth0 is there & connected but no sign of BSNL there.

    "connect automatically" is selected so I tried restarting the pc but still it won't connect.

    I checked in network manager settings & the settings are all there. It just won't show up & therefore I cannot connect to the internet using this PC.

    Please reply.

  2. #2
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Setiing DSL connection in 11.4 KDE

    I googled about the issue & it seems as if it is more a KDE problem than a opensuse specific issue. Didn't find any solution there.

    Finally decided to download the gnome version of 11.4

    KDE is mess.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,833
    Blog Entries
    2

    Default Re: Setiing DSL connection in 11.4 KDE

    Instead of setting up your connection through the desktop, try setting up through YAST.
    YAST configurations are typically "system level" and are implemented during bootup and before the Desktop applications start running, so are also irrelevant to the chosen Desktop.

    HTH,
    Tony

  4. #4
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Setiing DSL connection in 11.4 KDE

    Quote Originally Posted by tsu2 View Post
    Instead of setting up your connection through the desktop, try setting up through YAST.
    YAST configurations are typically "system level" and are implemented during bootup and before the Desktop applications start running, so are also irrelevant to the chosen Desktop.

    HTH,
    Tony
    I tried that but during the configuration process a dialog box appeared saying it wants to install a package (I don't remember the exact name of the package) in order to complete the configuration process. But because there was no internet connection at that point I had to abort the process.

    On 11.3 Gnome I once tried configuring my dsl connection through yast & the process ended successfully without any such demand of addition package installation.

    I have already installed 11.4 Gnome.

    Thanks for trying to help.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,833
    Blog Entries
    2

    Default Re: Setiing DSL connection in 11.4 KDE

    Depending on how satisfied/unsatisfied you might be with your current status, if you try YAST again write down (or camera snapshot) the error, then determine if that package should be in your available repository or not (do you have a DVD?). If it's not in the DVD, that might be considered a bug since it would be logical that all packages necessary for an Internet connection should be available on the DVD.

    Tony

  6. #6
    Join Date
    Mar 2011
    Location
    Belgaum, India
    Posts
    2

    Default Re: Setiing DSL connection in 11.4 KDE

    Hi,
    I was facing the exact same problem while using 11.4 for the first time. I too have a BSNL internet connection. After a lot of searching I found this bug report and a solution to it also. Check this out - New: opensuse 11.4: where is linux-atm-lib package? - opensuse-bugs.opensuse.org - ArchiveOrange
    I have not tried this out yet but will do so over the weekend and see if works out. If you plan to use this solution please post your results.

  7. #7
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: Setiing DSL connection in 11.4 KDE

    Quote Originally Posted by kartoos77 View Post
    Hi,
    I was facing the exact same problem while using 11.4 for the first time. I too have a BSNL internet connection. After a lot of searching I found this bug report and a solution to it also. Check this out - New: opensuse 11.4: where is linux-atm-lib package? - opensuse-bugs.opensuse.org - ArchiveOrange
    I have not tried this out yet but will do so over the weekend and see if works out. If you plan to use this solution please post your results.
    I prefer using Network Manager to connect to the internet. I usually don't use the traditional method. Even if I am able to solve the issue , the network manager which is included with KDE in particular & not specifically openSUSE is buggy too. Therefore there is no point in struggling to solve that problem.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  8. #8
    Join Date
    Mar 2011
    Location
    Belgaum, India
    Posts
    2

    Default Re: Setiing DSL connection in 11.4 KDE

    Ok, Its done. I set up the DSL connection through YAST and the connection woks fine. I disabled network manager plasmoid from the system tray. The connection now starts automatically at boot. But one problem every now and then it keeps dropping for no apparent reason.
    Anyone have any solution for this ?

  9. #9

    Default Re: Setiing DSL connection in 11.4 KDE

    If anyone suffers from this old bug, please just update openSUSE to 12.1 (or later if available at time of reading).

    This bug was fixed in networkmanagement with commit:

    Code:
    commit 68ebd8231f942154cd743d4007b8ab9e8689808b
    Author: Lamarque V. Souza <lamarque@gmail.com>
    Date:   Mon Sep 12 21:52:11 2011 -0300
    
        Allow DSL connections be associated to ethernet interfaces.
        
        CCBUG: 204170
    Upstream bug:
    https://bugs.kde.org/show_bug.cgi?id=204170

    openSUSE 12.1 contains fixed networkmanagement plasmoid.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •