I have a Samsung CLP - 510 laser printer and I am running SuSE 11.2.
The newer Gutenprint supports it nicely however, now and then there is a problem with printing. Sometimes if I want a two sided document printed, I get this error message:
SPL-C ERROR - Incomplete Session by time out POSITION: 0xd5174 (872820) SYSTEM: SPL/os_hook LINE: 1096 VERSION: SPL-C 1.28 09-15-2004
But I finally can get it to print both sides but I had to completely clear the printer queue (from within CUPS: delete ALL jobs) then tried again and then it worked. The problem is that you have to waste paper in order to get it to work. Today, I wanted just one side printed and I got the same error time out message. My husband had to make the printer print from Windows first then it worked for me on Linux.

When I was running SuSE 10.0, I had to follow these manual directions:

this is what I had to do with SuSE 10.0 and Puppy: These instructions have been put here: Puppy Linux Discussion Forum :: View topic - How I got a Samsung CLP-510 Laser printer to work

This is how I added my Samsung CLP-510 laser printer. I got these directions from this Linux Printing.org page: Printer: Samsung CLP-510 | OpenPrinting - The Linux Foundation This gives more instruction on which folders to look in.

Get the Samsung CLP driver from here Samsung CLP-510 Linux Driver | Software Driver Download

Copy mfp to: /usr/lib/cups/backend/ Copy all the samsung filters to: /usr/lib/cups/filter Copy libmfp.so.1.0.1 to: /usr/lib and the Samsung ppd to: /usr/share/cups/model/

I got the duplex mode to work (on Puppy and SuSE 10.0): There was another ppd file that I had on my SuSE 10.0 system so I just copied that one over to Puppy also. I don't remember where I got the original from, maybe from the Samsung install disk. So, the 2 ppd's are named: samsungCLP510.ppd and CLP-510splc.ppd. At this point, I don't remember which folder these were put in, most likely /usr/share/cups/model .
My question is: would it do any good or confuse Gutenprint/CUPS if I were to add the samsungCLP510.ppd and CLP-510splc.ppd to the /usr/share/cups/model/Samsung directory?
And how can I find out what is causing the timeout error message? The printer or CUPS or Gutenprint?