Problem bei mir war, dass der X Server nicht mehr gestartet hat. Hatte auch noch ein altes fglrx Packet von 11.2 Zeiten installiert

Also erstmal das installierte alte Packet lschen:

Code:
rpm -qa|grep fglrx
fglrx64_7_4_0_SUSE112-8.741-1.x86_64.rpm
zypper remove fglrx64_7_4_0_SUSE112
Den aktuellen ATI-Catalyst Treiber (ati-driver-installer-11-2-x86.x86_64.run) vom Hersteller runterladen und wenn man sich mal die Mhe macht, das Packet zu entpacken, sieht man auch, wie man fr 11.4 ein rpm bastelt (supportedOS.sh)

Code:
UNSUPPORTED="yes" ./ati-driver-installer-11-2-x86.x86_64.run --buildpkg SuSE/SUSE114-AMD64
erstellt dann ein rpm mit den Namen

Code:
fglrx64_xpic_SUSE114-8.821-1.x86_64.rpm
welches mit

Code:
zypper install fglrx64_xpic_SUSE114-8.821-1.x86_64.rpm
installiert werden kann.

Nicht vergessen: ihr braucht auch noch die Kernel-Sourcen und Build-Tools, aber das ist an anderer Stelle schon beschrieben.

Ansonsten habe ich noch in /boot/grub/menu.lst den nomodeset parameter hinzugefgt und in /etc/sysconfig/kernel ist der Parameter NO_KMS_IN_INITRD auf yes gesetzt.

Ansonsten upgrade ich seit 10.3 Problemlos mit zypper:

Code:
cd /etc/zypp
mv repos.d repos.d.bak
mkdir repos.d
zypper ar http://download.opensuse.org/distribution/11.4/repo/oss OSS
zypper ar http://download.opensuse.org/distribution/11.4/repo/non-oss NON-OSS
zypper ar http://download.opensuse.org/update/11.4 Updates
zypper mr -r OSS
zypper mr -r NON-OSS
zypper mr -rk -p 80 Updates
zypper ref
zypper dup
Hier auch nochmal als Script fr Rechner mit NVIDIA Grakas (die brauchen nopat in Grub's menu.lst)

Code:
#!/bin/sh

oldversion=$(cat /etc/SuSE-release |grep VERSION|awk '{ print $3 }')
newversion="11.4"

udir="/root/upgrade-${newversion}"

datum=$(date +"%Y%m%d")

echo "Migration ${oldversion} -> ${newversion}"

mkdir -p ${udir}
cd ${udir}

tar cfz etc-${oldversion}-${datum}.tgz /etc
rpm -qa|sort > rpm-${oldversion}.txt
zypper -x lr > zypper-${oldversion}.txt
uname -a > uname-${oldversion}.txt
netstat -auntp > netstat-${oldversion}.txt
ifconfig > ifconfig-${oldversion}.txt
route -n > route-${oldversion}.txt


if [ ! -d /etc/zypp/repos.d-${oldversion} ]; then
  mv /etc/zypp/repos.d /etc/zypp/repos.d-${oldversion} && mkdir /etc/zypp/repos.d
  zypper ar http://download.opensuse.org/distribution/${newversion}/repo/oss/ OSS
  zypper ar http://download.opensuse.org/distribution/${newversion}/repo/non-oss/ NON-OSS
  zypper ar http://download.opensuse.org/update/${newversion}/ Updates
  zypper ar ftp://download.nvidia.com/opensuse/${newversion}/ Nvidia
  zypper mr -r OSS
  zypper mr -r NON-OSS
  zypper mr -rk -p 80 Updates
  zypper mr -r -p 70 Nvidia
  zypper ref
#  zypper dup
  echo ""
  echo "*************************************"
  echo "Now it's time for zypper dup"
  echo "Don't forget to add the nvidia driver with"
  echo "zypper in nvidia-gfxG02-kmp-default"
  echo "and add 'nopat' to /boot/grub/menu.lst for each boot entry"
  echo "*************************************"
  echo ""
  exit 0
else
  echo "Aborted - already upgraded ?"
  exit 1
fi