Results 1 to 3 of 3

Thread: Bluedevil under openSUSE 11.4 RC2

  1. #1

    Default Bluedevil under openSUSE 11.4 RC2

    It half works:

    + I had struggled with getting it to work on 11.3, KDE 4.4. Brought in the KDE 4.5 repos and did zypper dup with fabulous success. Bluedevil 1.0-2.9 was a charm.

    + We're only days away from 11.4, and that was so painless I figured I'd go ahead and upgrade to 11.4. After hours of RTFM on zypper I got all the 11.4 repos (all I could find) and did zypper dup again.

    + Smooth, painless. Geen probleme.

    + Except:
    - the upgrade also upgraded bluedevil to 1.0-3.8.1. I've tried rolling back but the problems remain.

    + The problems are:
    - I cannot send files from the PC to the phone, although I can send files from the phone to the PC.

    - The PC prompts are very short-lived and are obscured by the taskbar unless you are primed for them to bring up the notification manager instantly, so pairing from the phone to the PC is difficult

    -I cannot browse the phone despite the app suggesting I can. I also had to manually install a directory (/home/$user/$phone_name) to avoid an error message. Presumably the app tries to mount the phone to this directory, but it does not succeed.

    + I do think I have all the necessary devel files, but would love to do a file list comparison with someone who has this working on OS 11.4/KDE 4.5.5

    Yes, I know this is beta so don't abuse me, I'm more than willing to do trials and submit explicit data as I have here. But I also would like to get it to work. I had it working on 11.3 / KDE 4.5.5.

    FWIW, pretty much everything else works flawlessly on OS 11.4. Firefox 4 beta has a few problems, but that is not an OS 11.4 issue...

    Cheers, Andy
    Last edited by alavarre; 08-Mar-2011 at 14:46. Reason: correction

  2. #2

    Default Re: Bluedevil under openSUSE 11.4 RC2

    Here is my list of repositories...

    P1630:~ # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+------------------------------+------------------------------+---------+---------+----------+--------+----------------------------------------------------------------+--------
    1 | Debug | openSUSE-11.4-Debug | Yes | Yes | 99 | yast2 | Index of /debug/distribution/11.4/repo/oss |
    2 | openSUSE-11.4-Education | openSUSE-11.4-Education | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    3 | openSUSE-11.4-KDE:Release:45 | openSUSE-11.4-KDE:Release:45 | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    4 | openSUSE-11.4-Main | openSUSE-11.4-Main | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    5 | openSUSE-11.4-Non-Oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    6 | openSUSE-11.4-NonFree | openSUSE-11.4-NonFree | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    7 | openSUSE-11.4-OpenOffice.org | openSUSE-11.4-OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    8 | openSUSE-11.4-Oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    9 | openSUSE-11.4-Packman | openSUSE-11.4-Packman | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    10 | openSUSE-11.4-Source | openSUSE-11.4-Source | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    11 | openSUSE-11.4-Update | openSUSE-11.4-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    12 | openSUSE-11.4-UpdatedApps | openSUSE-11.4-UpdatedApps | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
    13 | openSUSE-11.4-update | openSUSE-11.4-update | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |

    Cheers, AndyL

  3. #3

    Default Re: Bluedevil under openSUSE 11.4 RC2

    SOLVED:

    You need to have obexd and obexd-client installed.

    Great application, but the documentation needs help. I'll work on a new README tomorrow.

    Cheers, Andy

    ============= Details =============
    Googling bluedevil nokia file transfer I find a fellow who solved this by adding openobex:


    So I give it a try:

    - libopenobex1 is already installed
    - Add openobex-apps, openobex-devel (all that are available in YaST)

    But this does not help. It still dies when you select the destination and click Next. It reports Connecting to [$Destination] and then dies.

    Another source
    http://old.nabble.com/bluedevil-and-...d30539609.html

    suggests that you have to set it up first in the Bluetooth section of the kickoff > Personal Settings menu. Sure enough, I go there and do not see the Nokia N8, so use the wizard to add it.

    But no change.

    The same article also suggest you need obex-data-server. OK, back we go:

    + obex-data-server is already installed but none of the other obex files are so we add:
    - obexd
    It doesn't require anything else, so give it a go, following our step-by-step process (thanks to bpa for this).

    No change, but then, one by one, try adding:
    +obexd-client

    Woohoo!! It works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •