Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: YAST Samba server configuration problem

  1. #1
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default YAST Samba server configuration problem

    Hello, I installed 11.4 of one of the official mirrors and did a reinstall (wiped the root partition).
    I always use yast to setup samba server (no domaincontroller, just to open up some shares and the printer to the window boxes).
    Executed the same steps as always in yast and set samba server to automatically start and not act as a DC, added the shares and hit ok. Tryed to access it from a windows laptop, no luck.
    Then tryed to access it from the server itself using Dolphin and a smb:// url -again no luck. Opened the error log and there seem to be some permisssion issues (odd since yast samba server is run as root).

    error log:
    Code:
    [2011/03/08 16:10:28,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 16:10:28,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 16:10:28.003778,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 16:10:28.004751,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:13:26,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:13:26,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:13:26.710398,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unabgle to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:13:26.711993,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:23:52,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:23:52,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:23:52.103203,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:23:52.105142,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:31:15,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:31:15,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:31:15.093489,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:31:15.094870,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:32:58,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:32:58,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:32:58.878114,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:32:58.879051,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:33:56,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:33:56,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:33:56.820780,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:33:56.822631,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:36:03,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:36:03,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:36:03.975324,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:36:03.976233,  0] smbd/server.c:1149(main)
      error opening config file
    [2011/03/08 17:38:26,  0] lib/fault.c:250(dump_core_setup)
      Unable to setup corepath for smbd: Permission denied
    [2011/03/08 17:38:26,  0] smbd/server.c:1134(main)
      smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2010
    [2011/03/08 17:38:26.665994,  1] ../lib/util/params.c:513(OpenConfFile)
      params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/dhcp.conf":
      	Permission denied
    [2011/03/08 17:38:26.666889,  0] smbd/server.c:1149(main)
      error opening config file
    any help would be welcome. (My apologies for errors/spelling posting this all from my phone - ISP issues.. no internet)
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  2. #2
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: YAST Samba server configuration problem

    Now that my internet is working normally again I found the solution.
    Apparently it's a bug with AppArmor in openSUSE 11.4.

    So if you need your shares, don't upgrade yet and wait for the bug to get fixed.
    If you already upgraded YaST > AppArmor Control Panel > unmark the "Enable AppArmor" checkbox and hit ok.
    Rerun the YaST Samba Server module and everything should be working (no reboot required).

    Do note that disabling AppArmor will negatively affect your system securitywise. iirc a recent exploit using an usb stick was stopped by AppArmor.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: YAST Samba server configuration problem

    Thanks............ my smbd is also dead. But I can get there easily with the IP address e.g. smb:/10.0.0.2 in Dolphin
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  4. #4

    Default Re: YAST Samba server configuration problem

    Rather than disabling the whole of AppArmor, I wonder if a better compromise (which seems to work) is to do:

    Yast -> Novell AppArmor -> AppArmor Control Panel,

    Click on Set profile modes (Configure) button,

    Highlight the entries 'usr.sbin.nmbd' and 'usr.sbin.smbd' in turn and, for each, click the Toggle Mode button to set the mode from 'enforce' to 'complain'.

    Click Done, OK etc etc.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: YAST Samba server configuration problem

    Quote Originally Posted by plodder View Post
    Rather than disabling the whole of AppArmor, I wonder if a better compromise (which seems to work) is to do:

    Yast -> Novell AppArmor -> AppArmor Control Panel,

    Click on Set profile modes (Configure) button,

    Highlight the entries 'usr.sbin.nmbd' and 'usr.sbin.smbd' in turn and, for each, click the Toggle Mode button to set the mode from 'enforce' to 'complain'.

    Click Done, OK etc etc.
    Yes indeed. [and furthermore, you only need to set smbd, not both]
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  6. #6

    Default Re: YAST Samba server configuration problem

    Quote Originally Posted by plodder View Post
    Rather than disabling the whole of AppArmor, I wonder if a better compromise (which seems to work) is to do:

    Yast -> Novell AppArmor -> AppArmor Control Panel,

    Click on Set profile modes (Configure) button,

    Highlight the entries 'usr.sbin.nmbd' and 'usr.sbin.smbd' in turn and, for each, click the Toggle Mode button to set the mode from 'enforce' to 'complain'.

    Click Done, OK etc etc.
    Thank you. It solves the issue. I actually made a patch to automatically fix the problem on other servers.

    Code:
    --- /etc/apparmor.d/usr.sbin.smbd.orig	2011-05-02 04:52:59.000000000 -0700
    +++ /etc/apparmor.d/usr.sbin.smbd	2011-05-02 04:39:47.000000000 -0700
    @@ -2,7 +2,7 @@
     # Last Modified: Wed Jun 20 13:34:25 2007
     #include <tunables/global>
     
    -/usr/sbin/smbd {
    +/usr/sbin/smbd flags=(complain) {
       #include <abstractions/authentication>
       #include <abstractions/base>
       #include <abstractions/consoles>
    =============================================================================
    --- /etc/apparmor.d/usr.sbin.nmbd.orig	2011-05-02 04:52:47.000000000 -0700
    +++ /etc/apparmor.d/usr.sbin.nmbd	2011-05-02 04:36:41.000000000 -0700
    @@ -2,7 +2,7 @@
     # Last Modified: Wed Jun 20 13:22:50 2007
     #include <tunables/global>
     
    -/usr/sbin/nmbd {
    +/usr/sbin/nmbd flags=(complain) {
       #include <abstractions/base>
       #include <abstractions/nameservice>
       #include <abstractions/samba>
    * I guess it's a hack that shouldn't be needed anymore as soon as the bug is fixed (?)

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: YAST Samba server configuration problem

    Quote Originally Posted by please_try_again View Post
    Thank you. It solves the issue. I actually made a patch to automatically fix the problem on other servers.

    Code:
    --- /etc/apparmor.d/usr.sbin.smbd.orig	2011-05-02 04:52:59.000000000 -0700
    +++ /etc/apparmor.d/usr.sbin.smbd	2011-05-02 04:39:47.000000000 -0700
    @@ -2,7 +2,7 @@
     # Last Modified: Wed Jun 20 13:34:25 2007
     #include <tunables/global>
     
    -/usr/sbin/smbd {
    +/usr/sbin/smbd flags=(complain) {
       #include <abstractions/authentication>
       #include <abstractions/base>
       #include <abstractions/consoles>
    =============================================================================
    --- /etc/apparmor.d/usr.sbin.nmbd.orig	2011-05-02 04:52:47.000000000 -0700
    +++ /etc/apparmor.d/usr.sbin.nmbd	2011-05-02 04:36:41.000000000 -0700
    @@ -2,7 +2,7 @@
     # Last Modified: Wed Jun 20 13:22:50 2007
     #include <tunables/global>
     
    -/usr/sbin/nmbd {
    +/usr/sbin/nmbd flags=(complain) {
       #include <abstractions/base>
       #include <abstractions/nameservice>
       #include <abstractions/samba>
    * I guess it's a hack that shouldn't be needed anymore as soon as the bug is fixed (?)
    Good one. Thanks
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8

    Default Re: YAST Samba server configuration problem

    This problem has been fixed in the latest apparmor userspace code and profiles update (4816). However it won't update the modified /etc/apparmor.d/usr.sbin.smbd and /etc/apparmor.d/usr.sbin.nmbd. Maybe it did if you used YaST to set the 'complain' mode, I don't know. Otherwise, you should either reverse the patch posted here - meaning delete flags=(complain) from these two files before updating apparmor or - as it is probably already to late - rename the files /etc/apparmor.d/usr.sbin.smbd.rpmnew and /etc/apparmor.d/usr.sbin.nmbd.new:

    Code:
    mv /etc/apparmor.d/usr.sbin.smbd{.rpmnew,}
    mv /etc/apparmor.d/usr.sbin.nmbd{.rpmnew,}

  9. #9

    Default Re: YAST Samba server configuration problem

    Quote Originally Posted by please_try_again View Post
    or - as it is probably already to late - rename the files /etc/apparmor.d/usr.sbin.smbd.rpmnew and /etc/apparmor.d/usr.sbin.nmbd.new
    *after* you updated apparmor.

  10. #10
    Join Date
    Aug 2008
    Location
    Houghton, MI
    Posts
    49

    Question Re: YAST Samba server configuration problem

    Hi All,

    I'm wondering what I missed. I'm still having the permissions problem. The only way to enter a shared directory is by being a "guest" but that doesn't allow me to write into the dirs. I've tried deleting usr.sbin.smbd and usr.sbin.nmdb, disabling the whole Apparmor, but nothing works. Made a new configuration from scratch, but still no access. My smb.conf is the following:

    Code:
    [global]
    	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    	domain master = No
    	include = /etc/samba/dhcp.conf
    	passdb backend = smbpasswd
    	usershare max shares = 100
    	workgroup = Lago
    	wins support = No
    	security = share
    	usershare allow guests = No
    
    [Hercules]
    	path = /media/Hercules/
    	guest ok = no
    	read only = no
    
    [Argos]
    	path = /media/Argos/
    	guest ok = no
    	read only = no
    
    [Luk]
    	path = /home/Luk/
    	guest ok = no
    	read only = no

    Any help would be appreciated! I don't know what else to do.
    Thanks!

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •