Results 1 to 3 of 3

Thread: Wie kann man Perl mit rpm downgraden ?

  1. #1

    Default Wie kann man Perl mit rpm downgraden ?

    Hallo,
    Ich habe von der SUSE Version 11.2 die Pakete aaa_base,kdebase,coreutils auf die der Version 11.3 mit Yast upgegradet.
    Nachdem ich das Perl-Paket samt abhngigen Paketen wider aller Vernunft ohne Bercksichtigung der Abhngigkeiten auf das der Version 11.3 geupgradet habe erhalte ich die Meldung:


    Error loading language plugin /usr/lib64/YaST2/plugin/libpy2lang_perl.so: libperl.so: cannot open shared object file: No such file or directory
    Error while creating client module sw_single

    Seit dem komme ich weder ber KDE noch ber die Konsole mit yast in die Paketverwaltung.
    Das Problem msste sich lsen lassen, wenn ich das Perl-Paket, mit den davon abhngigen Paketen, downgraden knnte.

    Wie kann ich so ein Downgrade mit RPM durchfhren ?
    Gibt es andere Lsungsmglichkeiten ?

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Wie kann man Perl mit rpm downgraden ?

    Code:
    su
    Code:
    # zypper install libperl.so
    Schreib das in Terminal.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Wie kann man Perl mit rpm downgraden ?

    Also ich habe "zypper install libperl.so" ausgefhrt. Geholfen hat es allerdings nicht.

    Ich habe die Datei libperl.so nun in folgenden Verzeichnissen:
    file:///usr/lib/perl5/5.12.1/x86_64-linux-thread-multi/CORE/libperl.so
    file:///usr/lib/perl5/5.12.1/i586-linux-thread-multi/CORE/libperl.so

    Ich komme nach wie vor mit erwhnter Fehlermeldung nicht in die Paketverwaltung

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •