Results 1 to 3 of 3

Thread: garbage in Yast2 in text mode

  1. #1

    Default garbage in Yast2 in text mode

    hey,

    if I open Yast2 via SSH I see the garbage (code page related issue; similar to this). If I set some other than UTF-8 in PuTTY (KOI8-U, iso-8859 etc) Yast looks good, but then the same problem appears with Midnight Commander.
    How can I have Yast to use 'right' UTF-8 instead of any legacy code pages? Or how better deal with the situation?

    Thanks a lot for your help

    (openSuSE 11.3 x64)

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,651

    Default Re: garbage in Yast2 in text mode

    Yast runs under the root account so follows the rules set up in the /root directory which is the home for root user. So you need to set the roots preferences to your liking.

    Note this can be done by editing config files in /root/yourdeskenvironment and as a rule it is best not to log into a GUI as root, but in this case if you avoid any user directories in any way while logged in as root I think you can use your desktop as root to set the root preferences.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: garbage in Yast2 in text mode

    On 2011-03-05 19:36, dimicc wrote:
    >
    > hey,
    >
    > if I open Yast2 via SSH I see the garbage (code page related issue;
    > similar to 'this' (http://tinyurl.com/49rrfao)). If I set some other
    > than UTF-8 in PuTTY (KOI8-U, iso-8859 etc) Yast looks good, but then the
    > same problem appears with Midnight Commander.
    > How can I have Yast to use 'right' UTF-8 instead of any legacy code
    > pages? Or how better deal with the situation?
    >


    Try ssh from a linux computer.

    Execute "locale" under an ssh to the server.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" GM (Minas Tirith))

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •