Results 1 to 3 of 3

Thread: kde and samba shares. How to mount them?

  1. #1

    Default kde and samba shares. How to mount them?

    From Konqueror/Dolphin is possible to access samba shares. If your computer is joined to a Active Directory domain and you use a domain user, you can access samba shares with smb://server.domain/share and you are not ask for user/pass (you use a kerberos tiquet).

    Kde programs as Amarok, K3b, ... can access files in samba shares without problem. But other programs, specially gnome programs (including the popular OpenOffice), are unable to use files in a samba share.
    If instead of using Konqueror/dolphin you use Nautilus, there is no problem because it maps the share to a local folder ($HOME/.gvfs/share in sever/) and the program are able to access files in samba shares without problems as the folder is mounted locally (as if you use cifs.mount).
    Its a problem to use konqueror/dolphin and have to change to nautilus to access samba shares....
    If you use Windows you can mount it in an easy way. That's what I try to do from konqueror, not having to open a konsole and be able to mount the share in an easy way.
    I've tried with smb4k, but is has not worked for me (tried in 2 OpenSuse 11.3 and 1 opensuse 11.2).
    What Nautilus does when accessing a samba shares like smb://server.domain.dom/share is to execute the command:
    gvfs-mount smb://computer.domain.dom/share
    and the share is mounted in
    $HOME/.gvfs/share in server/

    What I try is to do the same, but just form Konqueror/Dolphin. I'd like to add a button to Konqueror/dolphin that pressing the button and if the URL points to a samba share, the share is mounted in $HOME/LocalNetwork/server/share.
    As I say, it can be as easy as executing the gvfs-mount, but don't know how.

    Can any give me any help?


  2. #2
    Join Date
    Apr 2009
    Plantation, FL

    Default Re: kde and samba shares. How to mount them?

    Follow the instructions for permanent mounts.

    Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 11 plus FAQs

    The only problem is that if for any reason the shared drive gets disconnected and reconnected, the share does not reconnect automatically like in windows. I have not been able to fix that. Also, if the share is not available at boot time, then it does not work.

  3. #3

    Default Re: kde and samba shares. How to mount them?

    Finally I use a script which:
    - Adds an action to Konqueror/Dolphin for mounting/unmounting the share.
    - Mounts the share with gvfs-mount.
    - Creates a link to $HOME/Resources.
    - Maintains the mount between session.

    Not a good solution, but a least, works until I find a better solution.

    What I try to do is detailed (in Spanish and only tried with OpenSuse 11.3 in SPANISH):
    - Directorio Activo - GNU/Linux Docs


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts