After reporting just another OOo/LibO kde4 related bug I filled this openFATE feature:
[openFATE 311353]Move libvclplug_kde4lx.so library to libreoffice-kde4 package
in order to make the uninstalling of that "integration" easier (now you need to manually delete libvclplug_kde4lx.so library).
If you find this feature request interesting, please vote for it and add your comments.