Results 1 to 4 of 4

Thread: Creating RPMs for Qt apps

  1. #1
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Creating RPMs for Qt apps

    I'm learning how to create RPMs. A tutorial on the openSUSE wiki has served me well, but now I'm trying to package Qt apps. rpmbuild automatically detected these dependencies:

    Code:
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    libc.so.6()(64bit)  
    libc.so.6(GLIBC_2.2.5)(64bit)  
    libgcc_s.so.1()(64bit)  
    libgcc_s.so.1(GCC_3.0)(64bit)  
    libm.so.6()(64bit)  
    libpthread.so.0()(64bit)  
    libpthread.so.0(GLIBC_2.2.5)(64bit)  
    libQtCore.so.4()(64bit)  
    libQtGui.so.4()(64bit)  
    libstdc++.so.6()(64bit)  
    libstdc++.so.6(CXXABI_1.3)(64bit)  
    libstdc++.so.6(GLIBCXX_3.4)(64bit)  
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)  
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    How do I find out which other dependencies should be added?

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Creating RPMs for Qt apps

    Hi,

    The compiler seems to have noted all that you are missing in your list. To be sure, you have to check the doc of the Qt apps.

    I'll try installing those and check afterward if it passes.

  3. #3
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Re: Re : Creating RPMs for Qt apps

    I found these documents...

    Qt Library Cross Dependencies | Qt Wiki | Qt Developer Network
    Show library dependencies | Qt Wiki | Qt Developer Network

    Is there a way to know the minimum version of the Qt libraries required to run my code?

  4. #4
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Re : Creating RPMs for Qt apps

    It surely depends on the version of Qt programming language you are using and the libraries associated.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •