Page 1 of 10 123 ... LastLast
Results 1 to 10 of 97

Thread: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

  1. #1

    Default security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    I'm new to OpenSUSE, though somewhat familiar with Ubuntu and Linux Mint. After installing OS11.3, I keep getting the securtiy update icon on my taskbar, but the update doesn't work. Here's the latest example:

    "lvm2: lvcreate--snapshot" results in scary error messages"
    Result:
    Dependency resolution failed:
    Details:
    "nothing provides libsepol.so.1 needed by device-mapper-1.02.49-4.1.1.i586"

    Tried opening YasT to manually resolve:
    Warning:
    "There was an error in the repository initialization.
    'repo-oss': [|] Valid metadata not found at specified URL(s)
    History:
    - File /var/tmp/TmpFile.kk2eD9 doesn't contain public key data"

    On clicking OK, YasT offers 3 choices:
    - list of consequent actions
    - do not install patch: device-mapper-2924.noarch
    - break device mapper by ignoring some of its dependencies

    This set of options has come up before - I have avoided taking any action as I have no clue what is the safe option here

    Could someone please advise how I should (a) preventsuch repeated failures in security updates (b) decide which is the safe option in case I have to use manual YasT again?
    Thanks in advance

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    Quote Originally Posted by sakusa View Post
    I'm new to OpenSUSE, though somewhat familiar with Ubuntu and Linux Mint. After installing OS11.3, I keep getting the securtiy update icon on my taskbar, but the update doesn't work. Here's the latest example:

    "lvm2: lvcreate--snapshot" results in scary error messages"
    Result:
    Dependency resolution failed:
    Details:
    "nothing provides libsepol.so.1 needed by device-mapper-1.02.49-4.1.1.i586"

    Tried opening YasT to manually resolve:
    Warning:
    "There was an error in the repository initialization.
    'repo-oss': [|] Valid metadata not found at specified URL(s)
    History:
    - File /var/tmp/TmpFile.kk2eD9 doesn't contain public key data"

    On clicking OK, YasT offers 3 choices:
    - list of consequent actions
    - do not install patch: device-mapper-2924.noarch
    - break device mapper by ignoring some of its dependencies

    This set of options has come up before - I have avoided taking any action as I have no clue what is the safe option here

    Could someone please advise how I should (a) preventsuch repeated failures in security updates (b) decide which is the safe option in case I have to use manual YasT again?
    Thanks in advance
    Open a terminal

    Code:
    su
    Code:
    # zypper lr -d
    Post the output.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    And try to install this library
    Code:
    su
    Code:
    # zypper install libsepol.so.1
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  4. #4

    Default Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    Hi thanks very much for that zippy reply
    Sorry for being so dumb, but I can't figure out how to copy/paste the output from my terminal to this post. Ctrl C/ V don't seem to work. What's the secret for OpenSuse copy /paste?
    Thanks

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    Quote Originally Posted by sakusa View Post
    Hi thanks very much for that zippy reply
    Sorry for being so dumb, but I can't figure out how to copy/paste the output from my terminal to this post. Ctrl C/ V don't seem to work. What's the secret for OpenSuse copy /paste?
    Thanks
    The secret?
    What do you mean with that?
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    With right click.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  7. #7

    Default Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    Sorry - was using the XTerm instead of Gnome Terminal

    Here's the output
    # zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-------------------------------------+-------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    2 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    3 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    4 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /distribution/11.3/repo/non-oss |
    5 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | rpm-md | Index of /distribution/11.3/repo/oss |
    6 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |

    Thanks again

  8. #8
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    Now the problem was fixed?
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  9. #9

    Default Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    Result:
    zypper install libsepol.so.1
    Retrieving repository 'openSUSE-11.3-Non-Oss' metadata [error]
    Repository 'openSUSE-11.3-Non-Oss' is invalid.
    File /var/tmp/TmpFile.yTVuCY doesn't contain public key data
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Disabling repository 'openSUSE-11.3-Non-Oss' because of the above error.
    Retrieving repository 'openSUSE-11.3-Oss' metadata [error]
    Repository 'openSUSE-11.3-Oss' is invalid.
    File /var/tmp/TmpFile.kLrDft doesn't contain public key data
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Disabling repository 'openSUSE-11.3-Oss' because of the above error.
    Loading repository data...
    Reading installed packages...
    'libsepol.so.1' not found in package names. Trying capabilities.
    No provider of 'libsepol.so.1' found.
    Resolving package dependencies...

    Nothing to do.
    -------------------------------
    Doesn't look like it's fixed???

  10. #10
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: security updates keep failing on OpenSUSE 11.3 Gnome i386 32-bit

    No it does not.

    Try again and write this
    Code:
    su
    Code:
    # zypper install libsepol.so.1-32bit
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

Page 1 of 10 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •