Results 1 to 2 of 2

Thread: Festplatte nervt im Akkubetrieb mit Stop-And-Go

Hybrid View

  1. #1
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Festplatte nervt im Akkubetrieb mit Stop-And-Go

    Eben hat mir Powertop etwas wie:
    Suggestion: increase the VM dirty writeback time from 5.00 to 15 seconds with:
    echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
    This wakes the disk up less frequenty for background VM activity
    vorgeschlagen.

    Ich habe aber erst mal in /proc/sys/vm/dirty_writeback_centisecs nachgeschaut und da steht sogar schon:
    Code:
    60000
    also 600 Sekunden also 10 Minuten.

    Da mich das wiederholte Anwerfen und Stoppen der Festplatte im Akkubetrieb bei openSUSE 11.4 sowieso nervt (und ich mich auch frage, ob dass die Lebensdauer meiner Festplatte nicht negativ beeinflusst) werde ich mal den umgekehrten Weg gehen und den Wert auf 500 (also 0,5 Sekunden) heruntersetzen.

    Mit
    Code:
    # echo 500 > /proc/sys/vm/dirty_writeback_centisecs
    habe ich den Wert nun heruntergesetzt.
    Die Festplatte stoppet und startet aber noch immer ca. im 5-10 Sekundentakt.
    Ich bin zwar eher Bahnfahrer aber ich halte das fr schlimmer als im Stop-And-Go-Verkehr in der Frankfurter Innenstadt - mit hnlichen Konsequenzen fr Festplatte/Motor und Energieverbrauch

    Was haltet Ihr davon?

    puzzled
    pistazienfresser

  2. #2
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Question Re: Festplatte nervt im Akkubetrieb mit Stop-And-Go

    Mal sehen, ob es so etwas wird:

    Code:
    linux-o7fu:~ # hdparm -i /dev/sda
    
    /dev/sda:
    
     Model=SAMSUNG HM160HC, FwRev=LQ100-10, SerialNo=S12TJF0PB50899
     Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
     RawCHS=16383/16/63, TrkSize=34902, SectSize=554, ECCbytes=4
     BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=16
     CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=312581808
     IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
     PIO modes:  pio0 pio1 pio2 pio3 pio4 
     DMA modes:  mdma0 mdma1 mdma2 
     UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 
     AdvancedPM=yes: unknown setting WriteCache=disabled
     Drive conforms to: ATA/ATAPI-7 T13 1532D revision 0:  ATA/ATAPI-1,2,3,4,5,6,7
    
     * signifies the current active mode
    
    linux-o7fu:~ # hdparm -C /dev/sda
    
    /dev/sda:
     drive state is:  standby
    linux-o7fu:~ # hdparm -B /dev/sda
    
    /dev/sda:
     APM_level	= 1
    linux-o7fu:~ # hdparm -B60 /dev/sda
    
    /dev/sda:
     setting Advanced Power Management level to 0x3c (60)
     APM_level	= 1
    linux-o7fu:~ # hdparm -B90 /dev/sda
    
    /dev/sda:
     setting Advanced Power Management level to 0x5a (90)
     APM_level	= 1
    linux-o7fu:~ # hdparm -B100 /dev/sda
    
    /dev/sda:
     setting Advanced Power Management level to 0x64 (100)
     APM_level	= 1
    linux-o7fu:~ # hdparm -B110 /dev/sda
    
    /dev/sda:
     setting Advanced Power Management level to 0x6e (110)
     APM_level	= 1
    linux-o7fu:~ # hdparm -B129 /dev/sda
    
    /dev/sda:
     setting Advanced Power Management level to 0x81 (129)
     APM_level	= 128
    linux-o7fu:~ #
    LG
    Martin

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •