Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Mplayer Error

  1. #1
    Join Date
    Apr 2009
    Location
    Plantation, FL
    Posts
    143

    Default Mplayer Error

    I recently got this error which is preventing mplayer to work

    Code:
    Option ,alsa, needs a parameter at line 86
    Im running opensuse 11.3 64 bit KDE 4.4 on Gstreamer backend
    I had upgraded to kde 4.5 but id created some errors and had to downgrade by doing a new install, leaving home folder untouched.

    any ideas? It used to work perfectly.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,725
    Blog Entries
    20

    Default Re: Mplayer Error

    Is it the same with smplayer
    What if you switch audio output in the player, try different ones (alsa, oss, pulse)....
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Apr 2009
    Location
    Plantation, FL
    Posts
    143

    Default Re: Mplayer Error

    The player does not even start.

  4. #4
    Join Date
    Apr 2009
    Location
    Plantation, FL
    Posts
    143

    Default Re: Mplayer Error

    in smplayer it says that

    Code:
    mplayer has finished unexpectedly. Exit code: 1

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Mplayer Error

    On 2011-02-21 22:36, cepiolidus wrote:
    >
    > I recently got this error which is preventing mplayer to work
    >
    >
    > Code:
    > --------------------
    > Option ,alsa, needs a parameter at line 86
    > --------------------


    Look into the mplayer configuration files on your home. One of them will
    probably have a line 86 that is wrong.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,725
    Blog Entries
    20

    Default Re: Mplayer Error

    Worth a try on Robin/Carlos idea
    Look in the .mplayer folder and just rename config file with a ~
    ~config
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Apr 2009
    Location
    Plantation, FL
    Posts
    143

    Default Re: Mplayer Error

    I had tried that already. First thing I did. it seems these is some alsa config file, where the error is. do you know where can I find it?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Mplayer Error

    On 2011-02-22 19:06, cepiolidus wrote:
    >
    > I had tried that already. First thing I did. it seems these is some alsa
    > config file, where the error is. do you know where can I find it?


    Nope.

    Try ls ~/.alsa* ~/alsa* /etc/alsa*

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  9. #9
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Mplayer Error

    Hello,

    What about the audio in general? If it works fine I do not think it is alsa specific.

    What if you switch audio output in the player, try different ones (alsa, oss, pulse)....
    You could edit .mplayer/guiconfig and change the audio output driver manually or you could run mplayer from terminal: mplayer -ao <drv> 'somefile'.avi (set drv to e.g alsa/oss/sdl etc)

    Code:
    olav@localhost:~> mplayer -ao help
    MPlayer dev-SVN-r32749-4.4-openSUSE Linux 11.2 (x86_64)-Packman (C) 2000-2010 MPlayer TeamAvailable audio output drivers:
            oss     OSS/ioctl audio output
            alsa    ALSA-0.9.x-1.x audio output
            esd     EsounD audio output
            pulse   PulseAudio audio output
            jack    JACK audio output
            sdl     SDLlib audio output
            mpegpes DVB audio output
            v4l2    V4L2 MPEG Audio Decoder output
            null    Null audio output
            pcm     RAW PCM/WAVE file writer audio output

  10. #10
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Mplayer Error

    Quote Originally Posted by caf4926 View Post
    Worth a try on Robin/Carlos idea
    Look in the .mplayer folder and just rename config file with a ~
    ~config
    I believe you have to rename/edit the guiconfig file not the config file. The config file is available for user-preference settings but it is left blank if untouched.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •