I recently got this error which is preventing mplayer to work

Code:
Option ,alsa, needs a parameter at line 86
Im running opensuse 11.3 64 bit KDE 4.4 on Gstreamer backend
I had upgraded to kde 4.5 but id created some errors and had to downgrade by doing a new install, leaving home folder untouched.

any ideas? It used to work perfectly.