Results 1 to 10 of 10

Thread: dbus cpu usage problems

  1. #1

    Default dbus cpu usage problems

    Periodically, my cpu usage goes way up. Top doesn't show anything using the cpu to any great extent. I did a "ps -ax" and statred doing process kills. I kiilled a dbus pre-fork first, which brought, which stopped the cpu hogging. This is the process line:

    /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session

    Does anyone know what that does, or what I killed?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,282

    Default Re: dbus cpu usage problems

    Code:
    man dbus-daemon
    ??
    Henk van Velden

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: dbus cpu usage problems

    Wild guess you have a hung print job.

  4. #4

    Default Re: dbus cpu usage problems

    Quote Originally Posted by gogalthorp View Post
    Wild guess you have a hung print job.
    I checked with the HP-Tool box. No print jobs showing.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,282

    Default Re: dbus cpu usage problems

    I see no connection whatsoever between the dbus-daemon and print jobs. The --print-pid and --print-address options are for somehing completely different.

    Did you realy read the man page as I suggested?
    Henk van Velden

  6. #6

    Default Re: dbus cpu usage problems

    Quote Originally Posted by hcvv View Post
    I see no connection whatsoever between the dbus-daemon and print jobs. The --print-pid and --print-address options are for somehing completely different.

    Did you realy read the man page as I suggested?
    You posted the line of code calling the dbus man page, and then 2 question marks. I had no idea what that meant. Perhaps you might consider making the suggestion to read the man page as you just did, as opposed to you original suggestion?


    I have now read the man page, and still haven't figured out an answer to my question.

    I have figured out PID relates to watchdog. I haven't yet been able to figure out what that is, or why it chews up some many cpu cycles. I don't understand the /etc/dbus-1/session.conf file.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,282

    Default Re: dbus cpu usage problems

    Does anyone know what that does, or what I killed?
    This is what you asked.

    My assessment of the few lines you wrote was that you know something about Unix/Linux (seeing you using ps, killing processes, etc.). Thus my question was:
    "You ask for the details about a Linux program, did you try to find information about it by checking for it's man page?". Many Unix/Linux users would be a bit ashamed that they forgot about the man page, thus I put it a bit short, guessing that you would get the hint.

    I seem to be wrong. Sorry for that. But I guess now that you did find the man page information and the link provided there for more info about dbus.

    I am afraid that I have no information to add except that I have two of those processes running on my system, one owned by root and one owned by the (only) loged in end-user.
    I have two more prcosess lists from this and another system saved earlier. They have each TWO of those owned by root and one by the end-user.
    Thus they seem to be rather common and the number of them varies.
    Running top, none of hem comes to the fore.

    The above will not help very much I am afraid, but this is as much as I can find out now.
    Henk van Velden

  8. #8

    Default Re: dbus cpu usage problems

    Actually, it does help somewhat. Some of what you stated is the same in my system. Thanks.

  9. #9
    Join Date
    Oct 2008
    Location
    Greece
    Posts
    24

    Default Re: dbus cpu usage problems

    I've recently did a fresh install 11.4 x86_64, AMD Athlon II X2 260, ATI RS880 Radeon 4250.
    The system was running fine for 2-3 weeks when I suddenly noticed 99% cpu usage from clean boot. This happens every time I boot my machine.

    With the top command, dbus comes first with about 20% cpu (no other app has high number) and when I kill it cpu usage drops to 50%. Then another app, mostly python or prepare_preload appears on top with 45% cpu usage and after I kill it the system runs smooth at low cpu usage numbers.

    Any ideas?

  10. #10
    Join Date
    Oct 2008
    Location
    Greece
    Posts
    24

    Default Re: dbus cpu usage problems

    Quote Originally Posted by petrogazz View Post
    I've recently did a fresh install 11.4 x86_64, AMD Athlon II X2 260, ATI RS880 Radeon 4250.
    The system was running fine for 2-3 weeks when I suddenly noticed 99% cpu usage from clean boot. This happens every time I boot my machine.

    With the top command, dbus comes first with about 20% cpu (no other app has high number) and when I kill it cpu usage drops to 50%. Then another app, mostly python or prepare_preload appears on top with 45% cpu usage and after I kill it the system runs smooth at low cpu usage numbers.

    Any ideas?
    Just found out what was causing the high cpu usage. I've set up tightvnc server using this how-to TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections).
    Killed the service and the cpu usage went back to normal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •