Results 1 to 8 of 8

Thread: Question about zypper

  1. #1
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Question about zypper

    Hey Guys I have the following situation I want to run all my updates with the exception of

    kernel-default | 2.6.27.54-0.2.1 | x86_64
    kernel-default-base | 2.6.27.54-0.2.1 | x86_64
    kernel-source | 2.6.27.54-0.2.1 | x86_64


    When I run

    zypper list-updates -t package

    I get a huge list, so if I do

    zypper update

    All packages will be installed, The question is how can I run all the updates but the 3 above.

    note: I do not want to use -> yast2 online_update and the reason why I don't want to run the kernel updates is because I'm not ready to reboot yet.

    Thanks.....
    Hmmmm I wonder how long before im good at this????????????

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Question about zypper

    I write a guide about zypper it is in greek translate it Η Εντολή Zypper
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Απ: Question about zypper

    There isn't an option to skip a package, but you can specify a patch with the --type switch:

    Code:
    zypper up -t patch <packagename>

  4. #4
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: Απ: Question about zypper

    Quote Originally Posted by chief_sealth View Post
    There isn't an option to skip a package, but you can specify a patch with the --type switch:

    Code:
    zypper up -t patch <packagename>
    Hey Chief_sealth thanks for the info but, It would be kind of hard to include all of this:

    Code:
    Loading repository data...
    Reading installed packages...
    S | Repository     | Name                              | Version                 | Arch  
    --+----------------+-----------------------------------+-------------------------+-------
    v | SLES11-Updates | NetworkManager-glib               | 0.7.0.r4359-15.20.10.12 | x86_64
    v | SLES11-Updates | PolicyKit                         | 0.9-14.33.28.1          | x86_64
    v | SLES11-Updates | PolicyKit-32bit                   | 0.9-14.33.28.1          | x86_64
    v | SLES11-Updates | PolicyKit-doc                     | 0.9-14.33.28.1          | x86_64
    v | SLES11-Updates | bzip2                             | 1.0.5-34.253.1          | x86_64
    v | SLES11-Updates | cifs-mount                        | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | cups                              | 1.3.9-8.37.1            | x86_64
    v | SLES11-Updates | cups-client                       | 1.3.9-8.37.1            | x86_64
    v | SLES11-Updates | cups-libs                         | 1.3.9-8.37.1            | x86_64
    v | SLES11-Updates | cups-libs-32bit                   | 1.3.9-8.37.1            | x86_64
    v | SLES11-Updates | curl                              | 7.19.0-11.24.23.1       | x86_64
    v | SLES11-Updates | dbus-1-glib                       | 0.76-34.10.1            | x86_64
    v | SLES11-Updates | dbus-1-glib-32bit                 | 0.76-34.10.1            | x86_64
    v | SLES11-Updates | diffutils                         | 2.8.7-143.23.1          | x86_64
    v | SLES11-Updates | freetype2                         | 2.3.7-25.17.1           | x86_64
    v | SLES11-Updates | freetype2-32bit                   | 2.3.7-25.17.1           | x86_64
    v | SLES11-Updates | gdm                               | 2.24.0-24.39.1          | x86_64
    v | SLES11-Updates | gdm-branding-upstream             | 2.24.0-24.39.1          | x86_64
    v | SLES11-Updates | gdm-lang                          | 2.24.0-24.39.1          | x86_64
    v | SLES11-Updates | glibc                             | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | glibc-32bit                       | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | glibc-devel                       | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | glibc-devel-32bit                 | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | glibc-i18ndata                    | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | glibc-locale                      | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | glibc-locale-32bit                | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | ipmitool                          | 1.8.10-3.15.2           | x86_64
    v | SLES11-Updates | ivman                             | 0.6.14-201.25.1         | x86_64
    v | SLES11-Updates | kernel-default                    | 2.6.27.54-0.2.1         | x86_64
    v | SLES11-Updates | kernel-default-base               | 2.6.27.54-0.2.1         | x86_64
    v | SLES11-Updates | kernel-source                     | 2.6.27.54-0.2.1         | x86_64
    v | SLES11-Updates | krb5                              | 1.6.3-133.39.1          | x86_64
    v | SLES11-Updates | krb5-32bit                        | 1.6.3-133.39.1          | x86_64
    v | SLES11-Updates | libHX13                           | 1.23-4.1.1              | x86_64
    v | SLES11-Updates | libHX13-32bit                     | 1.23-4.1.1              | x86_64
    v | SLES11-Updates | libbz2-1                          | 1.0.5-34.253.1          | x86_64
    v | SLES11-Updates | libbz2-1-32bit                    | 1.0.5-34.253.1          | x86_64
    v | SLES11-Updates | libcurl4                          | 7.19.0-11.24.23.1       | x86_64
    v | SLES11-Updates | libcurl4-32bit                    | 7.19.0-11.24.23.1       | x86_64
    v | SLES11-Updates | libfreebl3-32bit                  | 3.12.8-1.2.1            | x86_64
    v | SLES11-Updates | libgnutls26                       | 2.4.1-24.32.1           | x86_64
    v | SLES11-Updates | libgnutls26-32bit                 | 2.4.1-24.32.1           | x86_64
    v | SLES11-Updates | libmysqlclient_r15                | 5.0.67-13.26.1          | x86_64
    v | SLES11-Updates | libopenssl0_9_8                   | 0.9.8h-30.22.28.1       | x86_64
    v | SLES11-Updates | libopenssl0_9_8-32bit             | 0.9.8h-30.22.28.1       | x86_64
    v | SLES11-Updates | libpng12-0                        | 1.2.31-5.18.1           | x86_64
    v | SLES11-Updates | libpng12-0-32bit                  | 1.2.31-5.18.1           | x86_64
    v | SLES11-Updates | libpoppler-glib4                  | 0.10.1-1.37.1           | x86_64
    v | SLES11-Updates | libpoppler4                       | 0.10.1-1.37.1           | x86_64
    v | SLES11-Updates | libpython2_6-1_0                  | 2.6.0-8.8.6.1           | x86_64
    v | SLES11-Updates | libsmbclient0                     | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libsmbclient0-32bit               | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libtalloc1                        | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libtalloc1-32bit                  | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libtdb1                           | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libtdb1-32bit                     | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libwbclient0                      | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libwbclient0-32bit                | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | libxml2                           | 2.7.1-10.11.1           | x86_64
    v | SLES11-Updates | libxml2-32bit                     | 2.7.1-10.11.1           | x86_64
    v | SLES11-Updates | lvm2                              | 2.02.39-18.26.3         | x86_64
    v | SLES11-Updates | microcode_ctl                     | 1.17-102.18.1           | x86_64
    v | SLES11-Updates | mozilla-nspr-32bit                | 4.8.6-1.2.1             | x86_64
    v | SLES11-Updates | mozilla-nss-32bit                 | 3.12.8-1.2.1            | x86_64
    v | SLES11-Updates | mozilla-xulrunner191              | 1.9.1.15-0.5.1          | x86_64
    v | SLES11-Updates | mozilla-xulrunner191-gnomevfs     | 1.9.1.15-0.5.1          | x86_64
    v | SLES11-Updates | mozilla-xulrunner191-translations | 1.9.1.15-0.5.1          | x86_64
    v | SLES11-Updates | nscd                              | 2.9-13.11.1             | x86_64
    v | SLES11-Updates | openslp                           | 1.2.0-172.10.7.1        | x86_64
    v | SLES11-Updates | openslp-32bit                     | 1.2.0-172.10.7.1        | x86_64
    v | SLES11-Updates | openslp-server                    | 1.2.0-172.10.7.1        | x86_64
    v | SLES11-Updates | openssl                           | 0.9.8h-30.22.28.1       | x86_64
    v | SLES11-Updates | pcsc-lite                         | 1.4.102-1.31.1          | x86_64
    v | SLES11-Updates | pcsc-lite-32bit                   | 1.4.102-1.31.1          | x86_64
    v | SLES11-Updates | poppler-tools                     | 0.10.1-1.37.1           | x86_64
    v | SLES11-Updates | popt                              | 1.7-37.18.1             | x86_64
    v | SLES11-Updates | popt-32bit                        | 1.7-37.18.1             | x86_64
    v | SLES11-Updates | python                            | 2.6.0-8.9.6.2           | x86_64
    v | SLES11-Updates | python-base                       | 2.6.0-8.8.6.1           | x86_64
    v | SLES11-Updates | python-xml                        | 2.6.0-8.8.6.1           | x86_64
    v | SLES11-Updates | release-notes-sles                | 11.0.0.32-0.21.1        | x86_64
    v | SLES11-Updates | rpm                               | 4.4.2.3-37.18.1         | x86_64
    v | SLES11-Updates | rpm-32bit                         | 4.4.2.3-37.18.1         | x86_64
    v | SLES11-Updates | samba                             | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | samba-32bit                       | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | samba-client                      | 3.2.7-11.21.1           | x86_64
    v | SLES11-Updates | supportutils                      | 1.20-0.6.1              | noarch
    v | SLES11-Updates | syslog-ng                         | 2.0.9-27.27.24.2        | x86_64
    v | SLES11-Updates | sysstat                           | 8.1.5-7.9.1             | x86_64
    v | SLES11-Updates | system-config-printer             | 1.0.8-9.9.6.1           | x86_64
    v | SLES11-Updates | system-config-printer-lang        | 1.0.8-9.9.6.1           | x86_64
    v | SLES11-Updates | timezone                          | 2010l-0.7.7.1           | x86_64
    v | SLES11-Updates | ulimit                            | 1.2-1.23.1              | noarch
    v | SLES11-Updates | util-linux                        | 2.14.1-11.23.1          | x86_64
    v | SLES11-Updates | util-linux-lang                   | 2.14.1-11.23.1          | x86_64
    v | SLES11-Updates | xinetd                            | 2.3.14-130.8.1          | x86_64
    v | SLES11-Updates | xorg-x11                          | 7.4-9.29.1              | x86_64
    v | SLES11-Updates | xorg-x11-xauth                    | 7.4-9.29.1              | x86_64
    v | SLES11-Updates | yast2-network                     | 2.17.78.5-0.1.1         | x86_64
    v | SLES11-Updates | yast2-registration                | 2.17.28.3-0.1.3         | noarch
    v | SLES11-Updates | yast2-registration-branding-SLE   | 2.17.28.3-0.1.3         | noarch
    Hmmmm I wonder how long before im good at this????????????

  5. #5
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Question about zypper

    On Sat, 19 Feb 2011 23:36:02 +0530, chief sealth
    <chief_sealth@no-mx.forums.opensuse.org> wrote:

    >
    > There isn't an option to skip a package, but you can specify a patch
    > with the --type switch:
    >
    >
    > Code:
    > --------------------
    > zypper up -t patch <packagename>
    > --------------------
    >


    you can start from the other end, lock the packages you don't want to
    update: "zypper addlock <alias|#|URI>"

    and remove the locks when rebooting is an option again: "zypper removelock
    <alias|#|URI>"


    --
    phani.

  6. #6
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Question about zypper

    On Sat, 19 Feb 2011 23:52:40 +0530, phanisvara <listmail@phanisvara.com>
    wrote:

    > ...
    > you can start from the other end, lock the packages you don't want to
    > update: "zypper addlock <alias|#|URI>"
    >
    > and remove the locks when rebooting is an option again: "zypper
    > removelock <alias|#|URI>"
    >


    i'm sorry, checking the manual i see that i made a mistake: you have to
    specify the package name, i.e., "zypper addlock <packagename>"

    the other thing, with alias, repo-no., or URI is for restrickting the lock
    to one particular repository, in case that package is available in more
    than one.

    --
    phani.

  7. #7

    Default Re: Question about zypper

    Hi,

    I know htat you don't want to use yast to do the update, but did youknow that you can use it to stop packages frol being updated through it?

    Just right-click the package in the add/remove software section and you can set it never to be updated...

    (NB don't know whether that has ant effect on zypper, though).

    HTH

    Lenwolf

  8. #8
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: Question about zypper

    Quote Originally Posted by lenwolf View Post
    Hi,

    I know htat you don't want to use yast to do the update, but did youknow that you can use it to stop packages frol being updated through it?

    Just right-click the package in the add/remove software section and you can set it never to be updated...

    (NB don't know whether that has ant effect on zypper, though).

    HTH

    Lenwolf
    Hey Thanks Lenwolf, yeah I was aware of that but I kind of wanted to learn How to do it with zypper.
    Hmmmm I wonder how long before im good at this????????????

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •