Results 1 to 8 of 8

Thread: openOffice

  1. #1

    Default openOffice

    Hi, My previously working OpenOffice is now only accessible as root. Still appears in the KDE desktop start menues but doesn't respond unless I'm logged in as root. Any advice how I can resolve this would be greatly appreciated.
    haydonde openSuse 11.3 P4 -2G

  2. #2

    Default Re: openOffice

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    What happens if you start soffice from the command line as a non-root
    user? Post the output.

    Good luck.





    On 02/17/2011 07:36 PM, haydonde wrote:
    >
    > Hi, My previously working OpenOffice is now only accessible as root.
    > Still appears in the KDE desktop start menues but doesn't respond unless
    > I'm logged in as root. Any advice how I can resolve this would be
    > greatly appreciated.
    > haydonde openSuse 11.3 P4 -2G
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJNXeBjAAoJEF+XTK08PnB5YpYQAMumG+UzUT4AZMPB/uRQpGUx
    THqdD5u6935RASDfQQKrxfJJ+PCPNmH/8dLWWN+YuPP+yiHhBnqqkHzakAiRUVUl
    slmkZNpNcfXegXuAYP2qzTR41XgElUTFkBPOR8GTMpRIh/yVJGjsYyASc+VyPjL6
    Fscx3canzhbxtg4GyWP/xnwQ+CJa31RgzhfLLQ6h/qM0DX6+Zd6n+M8GeaxlDSY+
    5TY2fJ4su4Hte2B5koPRYwRVoAKUZugb7GJYd8jOoQBHP8jJ21TuYhpPifEiFfNd
    shZIYq2XKdIB1RSMG65qZ/5CBNTXNTeeVOQiBNEbp3zGkLhdmmjC+jBy005IGsZV
    5PG0zBMqMXeLWgxYBb3MIzPKFdxmt4Y3fxCVkbSKnsijbg4kk9GKY2h1RYhGOjgB
    P0s0YqeYn9S3V1zWoNk7buUwe0IvYW7LAahez9Y2otej5h3kSn+Mf+fawXn9A84i
    ScfWN59BEqZv9bTVXwNGWP5Q0jPkUl8OmB+/dRbMktl0+ECldkTqNp4QcpgmBcKz
    aQd9cN0zQ3aRqha+c0lEiXopipwLXCWm9sE51Ivx2yA+4OqOsOX753X+VN4R2xVj
    hsQwWMSF9HhzdBAsxDxpzyxT8BAcLIb0n0yHNZVhIdgM/gJF2Mp/zRYUwk8EQAH6
    8wtHZgTMKO5/s0FOKhE9
    =w5WJ
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: openOffice

    On 02/18/2011 03:36 AM, haydonde wrote:

    > Hi, My previously working OpenOffice is now only accessible as root.
    > Still appears in the KDE desktop start menues but doesn't respond unless
    > I'm logged in as root. Any advice how I can resolve this would be
    > greatly appreciated.


    i do not know what has damaged your OpenOffice in which way, however
    it is often the case when a folks log into KDE as root, that suddenly
    one day strange problems (like, applications will ONLY run when logged
    in as root, or the user can't log in at all) pop-up and ruin the day..

    it is because of problems exactly like you describe that i say you
    should never log into KDE/Gnome/XFCE or any other *nix-like graphical
    user interface desktop environment as root..

    doing so 1) opens you up to several different security problems if you
    (for example) browse the net, 2) too many too easy ways to damage your
    system no matter how careful your actions (for example: well
    documented cases of unintended change of ownership of ~/.ICEauthority
    and ~/.Xauthority from user to root sometimes occurs), 3) and, anyway
    logging into KDE/etc as root is *never* required to do any and all
    administrative duties..

    so, always log in as yourself, and "become root" by using a root
    powered application (like YaST, File Manager Superuser Mode) or using
    "su -", sudo, kdesu, or gnomesu in a terminal to launch whatever tool
    is needed (like Kwrite to edit a config file)...read more on all that
    here:

    http://en.opensuse.org/SDB:Login_as_root
    http://tinyurl.com/ydbwssh
    http://tinyurl.com/6ry6yd

    additionally: after logging into KDE/Gnome/etc as root, if you
    experience problems (for example, with uncommanded file ownership and
    permissions changes) and if you can provide us with details of what
    you were doing while you were logged in as root, that would help us
    identify if there's a bug that needs to be fixed...thanks for your help..

    sorry, i have NO idea how to unravel all the damage to your system,
    nor restore OpenOffice to a useful application..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  4. #4

    Default Re: openOffice

    Thanks. Only logged in as root to see if openoffice would launch when it wouldn't start as an ordinary user but appeared to be intact.

  5. #5

    Default Re: openOffice

    Thanks, but nothing happens. No output.

  6. #6
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: openOffice

    Quote Originally Posted by haydonde View Post
    Thanks. Only logged in as root to see if openoffice would launch when it wouldn't start as an ordinary user but appeared to be intact.
    Did you try running OOo in a different user account to be sure?

  7. #7

    Default Re: openOffice

    Quote Originally Posted by chief_sealth View Post
    Did you try running OOo in a different user account to be sure?
    Yes. - opened new (different) user account and everything works. - looks like the opening link for the original user must be damaged?

  8. #8
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: openOffice

    Try deleting the OOo config files in your account by the command

    Code:
    mv ~/.ooo3 ~/.ooo3-old
    Launch OpenOffice after that and tell us what happens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •