I' want to install IPFW/Dummynet on SUSE Enterprise version
however, I don't know how to install ncurses-dev from Internet
someone suggests using "yast", is it possible to use it as if using "apt-get" or "yum"?

1 The current version is:

suttas1:~ # lsb_release -a
LSB Version: core-2.0-noarch:core-3.0-noarch:core-2.0-ia32:core-3.0-ia32:desktop-3.1-ia32:desktop-3.1-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID: SUSE LINUX
Description: SUSE Linux Enterprise Server 10 (i586)
Release: 10
Codename: n/a
suttas1:~ # cat /etc/issue

Welcome to SUSE Linux Enterprise Server 10 SP2 (i586) - Kernel \r (\l).

2 I'm not able to install ncurses-dev.

I found a link where there are ncurses-dev RPM, however, no .rpm files for SESU Enterprise are available.I tried several .rpm files for OpenSUSE and SUSE factory, but they are errors or dependencies-not-available. I tried to install those dependencies, and the system prompted me to install other dependencies for these dependencies....

RPM resource ncurses-devel

I also tried command zypper, since the version of the SESU OS is not openSUSE but enterprise, the system prompted me to insert media...

3 the procedures for installing IPFW/DUMMYNET are :

***** Linux 2.6.x ******

make KERNELPATH=/path/to/linux USRDIR=/path/to/usr

where the two variables are optional an point to the linux kernel
sources and the /usr directory. Defaults are USRDIR=/usr and
KERNELPATH=/lib/modules/`uname -r`/build --- XXX check ?

NOTE: make sure CONFIG_NETFILTER is enabled in the kernel
configuration file. You need the ncurses devel library,
that can be installed according your distro with:
apt-get install ncurses-dev # for debian based distro
yum -y install ncurses-dev # for fedora based distro
You can enable CONFIG_NETFILTER by doingdevel:

"(cd ${KERNELPATH}; make menuconfig)"

and enabling the option listed below:

Networking --->
Networking options --->[*] Network packet filtering framework (Netfilter)

If you have not yet compiled your kernel source, you need to
prepare the build environment:

(cd $(KERNELPATH); make oldconfig; make prepare; make scripts)

thank you!