Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Automount fails with external USB drive

  1. #1

    Default Automount fails with external USB drive

    Ok, this used to work a few weeks ago..... (I know, not very useful)

    When I plug my USB drive in, the kernel sees it and I can mount it manually. However, it won't automount. Can someone point me the way to dig deeper into this? I've done plenty of google searches but nothing I've tried has worked for 'GNOME, SUSE 11.3.' I am not sure if it is a permissions problem, configuration problem, a kernel automount, HID, or USB problem.

    uname -a (stock SUSE desktop kernel):
    Code:
    Linux linux-hez9 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 i686 i686 i386 GNU/Linux

    Here is the output from /var/log/messages:

    Code:
    Feb 14 15:47:09 linux-hez9 kernel: [16258.620213] usb 1-1: new high speed USB device using ehci_hcd and address 6
    Feb 14 15:47:09 linux-hez9 kernel: [16258.749549] usb 1-1: New USB device found, idVendor=1058, idProduct=1023
    Feb 14 15:47:09 linux-hez9 kernel: [16258.749553] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Feb 14 15:47:09 linux-hez9 kernel: [16258.749557] usb 1-1: Product: Elements 1023
    Feb 14 15:47:09 linux-hez9 kernel: [16258.749561] usb 1-1: Manufacturer: Western Digital
    Feb 14 15:47:09 linux-hez9 kernel: [16258.749563] usb 1-1: SerialNumber: 575838314337304837363334
    Feb 14 15:47:09 linux-hez9 kernel: [16258.756315] scsi7 : usb-storage 1-1:1.0
    Feb 14 15:47:10 linux-hez9 kernel: [16259.800513] scsi 7:0:0:0: Direct-Access     WD       Elements 1023    2005 PQ: 0 ANSI: 4
    Feb 14 15:47:10 linux-hez9 kernel: [16259.800737] sd 7:0:0:0: Attached scsi generic sg2 type 0
    Feb 14 15:47:10 linux-hez9 kernel: [16259.819561] sd 7:0:0:0: [sdb] 1953519616 512-byte logical blocks: (1.00 TB/931 GiB)
    Feb 14 15:47:10 linux-hez9 kernel: [16259.829423] sd 7:0:0:0: [sdb] Test WP failed, assume Write Enabled
    Feb 14 15:47:10 linux-hez9 kernel: [16259.829429] sd 7:0:0:0: [sdb] Assuming drive cache: write through
    Feb 14 15:47:10 linux-hez9 kernel: [16259.845620] sd 7:0:0:0: [sdb] Test WP failed, assume Write Enabled
    Feb 14 15:47:10 linux-hez9 kernel: [16259.845626] sd 7:0:0:0: [sdb] Assuming drive cache: write through
    Feb 14 15:47:10 linux-hez9 kernel: [16259.845638]  sdb: sdb1
    Feb 14 15:47:10 linux-hez9 kernel: [16259.865437] sd 7:0:0:0: [sdb] Test WP failed, assume Write Enabled
    Feb 14 15:47:10 linux-hez9 kernel: [16259.865442] sd 7:0:0:0: [sdb] Assuming drive cache: write through
    Feb 14 15:47:10 linux-hez9 kernel: [16259.865447] sd 7:0:0:0: [sdb] Attached SCSI disk

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: Automount fails with external USB drive

    Is this formated with NTFS by chance? Maybe the 'dirty' bit is set.

    From root console, (with device plugged in), type

    Code:
    fdisk -l

  3. #3

    Default Re: Automount fails with external USB drive

    Yes, it is NTFS, but I don't think the dirty bit is set:

    Code:
    Disk /dev/sdb: 1000.2 GB, 1000202043392 bytes
    255 heads, 63 sectors/track, 121600 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00021631
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1               1      121601   976758784    7  HPFS/NTFS

  4. #4
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Automount fails with external USB drive

    Did you use it recently with windows ? Did you disconnect it properly ?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: Re : Re: Automount fails with external USB drive

    As DaaX has suggested, not unmounting correctly (Windows or Linux) can cause problems. The best method is to mount within Windows and let it check/reset/repair the partition.

    However, you could try the ntfsfix utility from a console:

    Code:
    sudo ntfsfix /dev/sdb1

  6. #6

    Default Re: Re : Re: Automount fails with external USB drive

    I understand, but this is managed by the VM that I have SUSE installed into and the dirty bit isn't set.

  7. #7
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Re : Re: Automount fails with external USB drive

    Yes, but if you used it improperly in windows, you'll have to go back in windows, plug the drive and disconnect it properly. It doesn't cost a lot to try it.

    After that, try mounting and unmounting it in openSUSE.

  8. #8

    Default Re: Re : Re: Re : Re: Automount fails with external USB drive

    It mounts fine. However, automount doesn't work. Same log as before.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: Re : Re: Re : Re: Automount fails with external USB drive

    Sorry, I missed that. Your using Gnome right? Maybe check media mounting with 'gconf-editor' utility. If the media mounting settings look ok, then we may have to look at policykit settings....

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Automount fails with external USB drive

    On 2011-02-14 22:06, mark3397 wrote:
    >
    > Ok, this used to work a few weeks ago..... (I know, not very useful)


    Try creating a new user, and try with that one.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •