Results 1 to 10 of 10

Thread: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

  1. #1
    Join Date
    Feb 2011
    Location
    Russia, GMT+3
    Posts
    5

    Default OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    Привет всем.

    Прошу меня не пинать, если чего не так пишу - я в линухе еще чайник .)

    Вчера вечером (13.02.2011) заметил, что при выключении системы появились странные сообщения в консоли, а сегодня у меня в кде вообще звук отвалился. в гноме звук есть...

    заметил что процесс events/3 берет под себя многовато процессора - пошел смотреть в журнал системных логов и увидел, что в разделе messages непрерывно генерятся пачками в бешеном темпе сообщения следующего вида:

    Feb 14 22:45:26 linux-4kd2 kernel: [ 495.066395] ice1724: i2c busy timeout
    Feb 14 22:45:27 linux-4kd2 kernel: [ 495.079133] ice1724: Too long irq loop, status = 0xff
    Feb 14 22:45:27 linux-4kd2 kernel: [ 495.079134] ice1724: Disabling MPU_TX


    у меня в компе 2 аудиоинтерфейса:
    • встроенный в маму intel HD (думаю, можно точно не искать модель - мама для проца icore3)

    • pci плата infrasonic quartet

    так вот думаю что правильно запомнил, что под infrasonic quartet линух использует как раз драйверы ice1724 - т.е. правильно предполагаю, что какие-то проблемы появились с infrasonic quartet? м.б. какое-то системное обновление было перед этим установлено (до этого в кедах был звук точно на встроенном чипе, на инфрасонике не знаю может и был - я там его не слушал, а теперь в кедах вообще пропал звук и со встроенного чипа)? .. не знаю, куда думать и где искать ...

    Буду благодарен хотя бы за подсказки, в каком направлении мне рыть дальше ..)

  2. #2
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    чет как-то непонятно: у вас параллельно два DE (KDE+Gnome)? О_о

  3. #3
    Join Date
    Feb 2011
    Location
    Russia, GMT+3
    Posts
    5

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    да

    поставил две среды рядом - посмотреть, сравнить - кстати пригодилось пока что тем, что в кедах звука сейчас нет, а в гноме есть..) Прочитал, что в кедах вроде вовсю должна использоваться технология фонон для управления звуком - может, из-за нее траблы? жаль, не знаю где можно увидеть ее состояние и проблемы с ней, если они есть..

  4. #4
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    в KDE- Phonon, в Гноме- Gstreamer.
    Ну вот, посмотрели? Вот и выбирайте то, что действительно работает- Гном.

    ____________________________________________________________________
    Либо, если проблема для вас действительно критична,
    напишите в соответствующий раздел- разные разделы просматривают разные люди.

  5. #5
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,113

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    Не надо больше ни в какой раздел, давайте здесь разберёмся. Если действительно наличествует проблема с железом (раз в лог ядра валятся ошибки "в бешеном темпе"), то каким образом в гноме звук работает? Или при входе в гном ошибки в лог не валятся? Так не бывает
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

  6. #6
    Join Date
    Feb 2011
    Location
    Russia, GMT+3
    Posts
    5

    Exclamation Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    Спасибо.

    Цели:
    Думаю, недостаточно подробно вчера описал ситуацию - дополняю :
    в качестве основного звука для системы думаю использовать встроенный чип на маме плюс еще есть в системе звуковая карточка инфрасоник квартет, которую планирую использовать для обработки звука в аудиоредакторах и т.п. (в домашней музыкальной студии).

    Предыстория:
    Несколько дней поставил на комп OpenSUSE 11.3 x64 с КДЕ и Гномом (ну я еще чайник, хочу сравнить обе среды, может-думаю так оно даже и надежней где-то - не знаю может это неправильно в принципе? кеды и гном может лучше рядом не ставить?. Пока что больше хочу пользоваться кедами.) В кедах сразу звука с чипа в маме почти нигде не было (ни системных звуков, ни в rosegarden и musescore, ни в интернет-браузере, ни в аудио-плеерах, которых поставил штук 6 из-за того что думал что в них проблема). Выяснил, что звук с мамы в КДЕ у меня идет только в амароке.

    Через пару дней заметил странные сообщения в консоли во время перехода системы в спячку, их было много - сотни - мелькали на экране - разглядел что какая-то проблема с ice1724. Потом через пару перезагрузок в КДЕ звук пропал и в амароке. Потом заметил, что процессор вдруг стал все время чем-то занят (у меня сисмон выведен на экран), в списке процессов я увидел, что процесс events3 все время что-то делает ... Что делать в этой ситуации чайнику? Тут я и вспомнил, что у меня же еще есть Гном ..., а в нем я видел прогу Log File Viewer Я перешел в него и - ! - во-первых: звук появился везде, где его не было; во-вторых: в Log File Viewer было море сообщений, о которых я и написал в первом посте этого топика.

    Вот такие у меня дела.

    По состоянию на сейчас, сообщения в Log File Viewer, о которых писал выше, появились, но уже не сыплются непрерывно, а были только во время пробуждения системы. Звука в кедах нет по-прежнему нигде. Пишу все это из Гнома, слушая музыку в Clementine ...

    Очень жду какого-нибудь совета/наводки чего где поискать - горю желанием стать линуксоидом

  7. #7
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,001
    Blog Entries
    1

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    Там, в KDE4, есть настройки для выбора приоритетного звукового устройства. Посмотрите, поиграйтесь.

  8. #8
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,113

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    Таки да, я думаю, это две разные проблемы: сообщения в лог при засыпании/просыпании и отсутствие звука в КДЕ. Параметры системы --> Мультимедиа прояснит ситуацию со вторым вопросом.
    Во время работы в Гноме процессор всё равно отжирается? А сообщения в лог ядра новые идут? (команда dmesg|grep ice1724)
    Last edited by Minton; 15-Feb-2011 at 12:35.
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

  9. #9
    Join Date
    Feb 2011
    Location
    Russia, GMT+3
    Posts
    5

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    выяснил, почему пропал звук в КДЕ - скотина микшер ушел в ноль ... ну не ожидал я такого, не проверял его уровень прошу прощения ... так что сейчас все как в начале топика: в кде звук есть, но только в амароке + системные уведомления (тоже, оказывается, дело было в уровне в микшере - оказывается, еще надо было выставить уровни в свойствах звуковой платы в ясте правда, пока что услышал их всего 1 раз - может, еще с ними и есть траблы, но скорее всего, все ОК). Похоже, с этими вопросами мне быть на форуме по КДЕ

    Проблема осталась тем, что кернел ругается на ice 1724.
    Сообщения в логе есть, сыплются не бесконечно, но временами помногу.
    Скриншот окна со списков звуковых устройств выложить?

  10. #10
    Join Date
    Feb 2011
    Location
    Russia, GMT+3
    Posts
    5

    Default Re: OpenSUSE 11.3 x64 - проблема со звуком появилась (ice1724)

    Quote Originally Posted by Minton View Post
    Во время работы в Гноме процессор всё равно отжирается? А сообщения в лог ядра новые идут? (команда dmesg|grep ice1724)
    Процессор сегодня ни в гноме, ни в кедах на эти сообщения почти не уходит, они перестали валиться непрерывно. Но они появляются в логе, это по команде dmesg|grep ice1724 это тоже видно.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •