Results 1 to 10 of 10

Thread: Strange behaviour in Dolphin

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Strange behaviour in Dolphin

    I have a directory which is filled up with lots of saved html files, + some .pdf, .txt, .ps etc. It has been a while since I browsed this directory so I can't say when the following started. The problem is that when I browse this folder with Dolphin, and hover the mouse pointer over the files, a dialogue box will appear asking for which application to open this file with (as if I clicked on a unknown file). And this will continue over and over again if I continue to hover the mouse pointer over the files, new boxes will continue to pop-up.

    When I look at the processes running/starting I see that lots of kio-file processes starts during the Dolphin session.

    I also had a look at file permission and found that several files were marked as executable. I don't know if that could be an issue, however, is it any point in having .html/pdf ... files executable under any circumstances?

    When I browse the directory with konqueror nothing is triggered, and all seems normal.

    Any views on this?

    (system specs at the bottom)

    Thanks
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Strange behaviour in Dolphin

    You could delete all your hidden dolphin config folders and files
    .kde4/share/apps/dolphin

    .kde4/share/config/dolphinrc

    Bit of a pain I know
    or test a new user, see if it's the same first
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange behaviour in Dolphin

    Thanks caf,

    I found out that enabling or disabling the Information panel: (dolphin) View > Panels > Information (or F11) makes the difference. Having the Information panel enabled makes kdeinit4 fire up lots of kio_file processes (in the scenario described above), and the dialogue boxes appear. Disabling the Information panel, and none of this happens.

    I have recently upgraded from kde 4.5.4 which behaved similar. Whether 4.3.5 (default) behaved without flaws I can't remember.

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange behaviour in Dolphin

    I also had a look at file permission and found that several files were marked as executable. I don't know if that could be an issue, however, is it any point in having .html/pdf ... files executable under any circumstances?
    I'm a bit curious, do you now if the text files should be like this: (permission) 755. Everyone has executable permission. Would anyone/any program want/need to run e.g. a .pdf or a .html file?
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange behaviour in Dolphin

    PS

    A hypothetical conclusion perhaps, but it seem like the issue is related to directories containing html files with a matching folder that contains images and elements saved alongside the html file initially. I remember that this was the way html files were saved from web with konqueror on kde3.(Sorry if this was a bit unclear)

    In any case, browsing dirs which contains newly saved html files does not make dolphin (so far) behave oddly with or without the info panel enabled.


    And I should mention that I have tried your suggestions caf.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Strange behaviour in Dolphin

    Permissions can vary, depending on the files origins. But 755 is normal I think. And I'm pretty sure, in Gnome, when click a .txt file it asks you what to do based on the file being executable.

    Did you test a new user?
    If it's the same with that, then something is amiss because I do not have this strange behaviour.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange behaviour in Dolphin

    Quote Originally Posted by caf4926 View Post
    Permissions can vary, depending on the files origins. But 755 is normal I think. And I'm pretty sure, in Gnome, when click a .txt file it asks you what to do based on the file being executable.

    Did you test a new user?
    If it's the same with that, then something is amiss because I do not have this strange behaviour.
    Yes, I did test that, similar behaviour.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  8. #8
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange behaviour in Dolphin

    I just upgraded my second computer, copied the directory over and ran a test. Same problem there as well, must be something strange with one or several of the elements in that dir.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  9. #9

    Default Re: Strange behaviour in Dolphin

    Hello F_Sauce,

    Quote Originally Posted by F_Sauce
    I just upgraded my second computer, copied the directory over and ran a test. Same problem there as well, must be something strange with one or several of the elements in that dir.
    Maybe it's a setting in a .directory file that dolphin creates?
    This would explain why konqueror doesn't have this problem and why it happens on multiply computer.

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  10. #10
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Strange behaviour in Dolphin

    Sorry for the late reply, and thanks.

    I actually think it has to do with the old html files . Not just one but several. I have not managed to have dolphin behave this way if I create a dir, download some websites and browse in that place.

    Cheers .
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •