Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problem with Install/remove software Yea a noob!

  1. #1
    Join Date
    Feb 2011
    Location
    Grand Rapids, MI
    Posts
    6

    Default Problem with Install/remove software Yea a noob!

    Anyone ever see this before?

    System management is locked by the application with pid 9781 (/usr/lib/YaST2/bin/y2base).
    Close this application before trying again.

    I get this after I try and open the software update or Yast with opensuse 11.3. After I installed 11.3 it worked fin for the first big update I did. Then I read about programs that I think will help me make the jump from windows, so I open up my software install and this comes up? I have never played with any Linux OS before and am trying to figure it all out. Seem like years of reading and trying.. heh
    Thanks for the help..

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Problem with Install/remove software Yea a noob!

    Hi,

    You are probably trying to acces install/remove software while you have an update going on or while the dialog to manage repos is open. You can check what is the pid 9781 with this command in terminal:

    Code:
    ps -e

  3. #3
    Join Date
    Feb 2011
    Location
    Grand Rapids, MI
    Posts
    6

    Default Re: Re : Problem with Install/remove software Yea a noob!

    Thanks for that little tidbit! It's kind of like MS task manager to where you can see whats running. Seems I have to find a command dictionary to read. I have not played with a c\> since my old TRS-80 back in the day. So not to ask to much, but what would be the easiest way to stop that process from running after I find it?
    Thanks again... I now have 30 yr old DOS commands flowing through my mind... What a haze....

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Problem with Install/remove software Yea a noob!

    Quote Originally Posted by Nakedmason View Post
    Anyone ever see this before?

    System management is locked by the application with pid 9781 (/usr/lib/YaST2/bin/y2base).
    Close this application before trying again.

    I get this after I try and open the software update or Yast with opensuse 11.3. After I installed 11.3 it worked fin for the first big update I did. Then I read about programs that I think will help me make the jump from windows, so I open up my software install and this comes up? I have never played with any Linux OS before and am trying to figure it all out. Seem like years of reading and trying.. heh
    Thanks for the help..
    In kde the updater applet in the tray can be configured via right click. I tell it not to start at boot and quit it. Then when you reboot it's gone. It's that applet that is causing the issue for you.
    I then use online update from Yast, but you have to remember to do it once a week or so.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Problem with Install/remove software Yea a noob!

    Hi,

    Like caf tell you, you can do as he suggests. But I'd rather wait a little after the boot before lauching yast->install/remove software.

    But you know, this is not a real problem. It is only a little annoyance that'll show upfrom time to time when it happen that you wish to install a new package at the same time the system is checking or installing updates. Just use a little patience.

    So, don't bother too much with that. It is not a real issue.

  6. #6

    Default Re: Problem with Install/remove software Yea a noob!

    On 02/11/2011 11:06 AM, Nakedmason wrote:
    >
    > Thanks for that little tidbit! It's kind of like MS task manager to
    > where you can see whats running. Seems I have to find a command
    > dictionary to read. I have not played with a c\> since my old TRS-80
    > back in the day. So not to ask to much, but what would be the easiest
    > way to stop that process from running after I find it?


    Probably waiting 5 minutes. When I've encountered that it's usually
    because I tried to run Yast Online Updater or zypper just after turning
    on my computer. The little updater app jobbie runs automatically so if
    it hasn't finished, it locks the files.

    To see what's running, at the command line enter:
    ps aux | more

    HTH...

    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: Problem with Install/remove software Yea a noob!

    FYI you can kill a process with the kill command

    kill PID where PID is the process ID listed ps command

    Note in this case unless a process is truly hung doing an update you should wait until it finishes since killing an update in midstream may cause serious problems.

  8. #8
    Join Date
    Feb 2011
    Location
    Grand Rapids, MI
    Posts
    6

    Default Re: Problem with Install/remove software Yea a noob!

    Thanks to all of you. I sat back, drank a beer, and played with Gimp for a while. Then I tried it again, and it ran just fine. Also I did a "Suggested" update of about 200 megs. WOW that was smoother and faster than what my Windoze did just booting up. So far I'm getting into this SUSE stuff. And you know what? Ive been at this keyboard for around 49 hrs now after my install of SUSE 11.3 and I have not had one lockup. SUSE 0 Windows Vista 10 in that time frame..

    Thanks again to you all..Redbull and Twinkies for everyone!

  9. #9
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Problem with Install/remove software Yea a noob!

    Glad you have fun.

    Enjoy your openSUSE!

  10. #10
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Re : Re: Problem with Install/remove software Yea a noob!

    Quote Originally Posted by gogalthorp
    Note in this case unless a process is truly hung doing an update you should wait until it finishes since killing an update in midstream may cause serious problems.
    Just for the record: *actually* it should not, as by default 'kill' is sending a SIGTERM, which is simply trying to stop a process the regular way (the process is stopped 'the clean way'). You probably are referring to something like 'kill -9 $PID', which indeed will stop a process brutally with a SIGKILL (might sometimes be necessary, but should be avoided if possible).

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •