Results 1 to 10 of 10

Thread: KDE 4 Failing to Load

  1. #1

    Default KDE 4 Failing to Load

    After installing QtCurve 1.8-41 from software.opensuse (I've been playing around with themes), whenever I try to boot my computer, it gets to stage 1 of loading (the less colorful splash screen), and about halfway through loading that, the screen goes black and a box in the top left corner says: "Could not start kdeinit4. Check your installation". I'm then taken to failsafe, where I login. When I try to run kdeinit4 from the command line, I get this error:

    kdeinit 4: symbol lookup error: /usr/lib/libQtSvg.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv.

    I've tried uninstalling through zypper, but it can never find the package I specify.

    I'm on 11.3.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4 Failing to Load

    Rename your .kde4 folder from the command line login with

    Code:
    mv .kde4 .kde4-messedup
    Code:
    startx
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: KDE 4 Failing to Load

    Thanks for the answer, but it didn't quite work. On "startx", a whole of text flashed across the screen (too fast to see), and I was returned to the screen saying "Could not start kdeinit4".

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,371
    Blog Entries
    1

    Default Re: KDE 4 Failing to Load

    It might be useful to see what repos you have configured currently

    Code:
    zypper lr -d
    Maybe

    Code:
    zypper ve
    will restore any package conflict issues that have occurred (an currently breaking the desktop)

  5. #5

    Default Re: KDE 4 Failing to Load

    Here's the output. I recently had to upgrade the kernel to get virtualbox working (I did it through yast). Sorry if line breaks are in the wrong place. I of course don't have any copy and paste functions on the misbehaving computer, so I had to output the command to a text file, which stuffed up the line breaks.

    Code:
    Abort, retry, ignore? [a/r/i/?] (a): Repository 'KDE:Release:46' is out-of-date. You can run 'zypper refresh' as root to update it.
    
    Abort, retry, ignore? [a/r/i/?] (a): 
    
    Repository 'Libdvdcss repository' is out-of-date. You can run 'zypper refresh' as root to update it.
    
    Abort, retry, ignore? [a/r/i/?] (a): 
    
    Repository 'Packman Repository' is out-of-date. You can run 'zypper refresh' as root to update it.
    
    Abort, retry, ignore? [a/r/i/?] (a): 
    
    Repository 'openSUSE-11.3-Non-Oss' is out-of-date. You can run 'zypper refresh' as root to update it.
    Abort, retry, ignore? [a/r/i/?] (a): 
    
    Repository 'openSUSE-11.3-Oss' is out-of-date. You can run 'zypper refresh' as root to update it.
    Abort, retry, ignore? [a/r/i/?] (a): 
    
    Repository 'openSUSE-11.3-Update' is out-of-date. You can run 'zypper refresh' as root to update it.
    
    
    Loading repository data...
    
    Reading installed packages...
    
    
    8 Problems:
    
    
    Problem: compat-wireless-kmp-default-2.6.35_k2.6.34.0_12-5.1.i586 requires kernel(default:drivers_usb_core) = 6faa2c62dac4f41d, but this requirement cannot be provided
    
    Problem: libQtWebKit4-4.7.1-150.2.i586 requires libqt4-x11 = 4.7.1, but this requirement cannot be provided
    
    Problem: kdelibs4-core-4.4.4-2.5.i586 requires libkdecore4 = 4.4.4, but this requirement cannot be provided
    
    Problem: qt4-qtscript-0.1.0-7.1.i586 requires libqt4 = 4.6.3, but this requirement cannot be provided
    
    Problem: libstrigi0-0.7.3.99-58.1.i586 requires libqt4 >= 4.7.1, but this requirement cannot be provided
    
    Problem: libsoprano4-2.5.63-92.2.i586 requires libqt4 >= 4.7.1, but this requirement cannot be provided
    
    Problem: libqt4-sql-4.7.1-150.2.i586 requires libqt4 = 4.7.1, but this requirement cannot be provided
    
    Problem: python-kde4-4.4.4-1.5.i586 requires python-sip = 4.10.2, but this requirement cannot be provided
    
    
    Problem: compat-wireless-kmp-default-2.6.35_k2.6.34.0_12-5.1.i586 requires kernel(default:drivers_usb_core) = 6faa2c62dac4f41d, but this requirement cannot be provided
      uninstallable providers: kernel-default-2.6.34-12.3.i586[repo-oss]
                       kernel-default-base-2.6.34-12.3.i586[repo-oss]
     
    
    Solution 1: Following actions will be done:
      downgrade of kernel-default-2.6.34.7-0.7.1.i586 to kernel-default-2.6.34-12.3.i586
      downgrade of preload-kmp-default-1.1_k2.6.34.7_0.7-19.1.11.i586 to preload-kmp-default-1.1_k2.6.34.0_12-18.2.i586
     
    Solution 2: deinstallation of compat-wireless-kmp-default-2.6.35_k2.6.34.0_12-5.1.i586
     
    Solution 3: downgrade of kernel-default-base-2.6.34.7-0.7.1.i586 to kernel-default-base-2.6.34-12.3.i586
     
    Solution 4: break compat-wireless-kmp-default by ignoring some of its dependencies
    
    
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c):
    Also, I have XFCE installed, so is there any way to start that from failsafe?

    Thank you.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,371
    Blog Entries
    1

    Default Re: KDE 4 Failing to Load

    The easiest way may be to boot into runlevel 3. Type '3' at grub menu, then it will start up in console mode. Log in at the prompt, and type 'startxfce4'.

    You can automate this by editing /etc/sysconfig/windowmanager' (as root). Look for an entry like

    Code:
    DEFAULT_WM="startkde"
    Change it to

    Code:
    DEFAULT_WM="startxfce4"
    Save the change, then check that /etc/sysconfig/displaymanager also has DISPLAYMANAGER="xdm" set.

    Save and start XFCE desktop with

    Code:
    init 5

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4 Failing to Load

    I recently had to upgrade the kernel to get virtualbox working
    Why? It's just odd.

    Boot to yast level 3
    Boot to Level 3, then Yast and More....
    Make sure the repos are enabled and refreshed.
    Then back at the root CLI do

    Code:
    zypper dup
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4 Failing to Load

    If that gets you back to a desktop. Then we can start putting the rest of it back together
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: KDE 4 Failing to Load

    Any attempt to refresh or run dup fails, because I don't have an internet connection. I normally use wifi, should I use ethernet at this particular stage?

    And also, @deano_ferrari, startxfce4 gives be command not found. But I do have xfce, I know that because I can use it! Oh well.

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: KDE 4 Failing to Load

    Yes use a wired connection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •