Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: KDE 4.6 system tray problem - vanishing icons

  1. #1

    Default KDE 4.6 system tray problem - vanishing icons

    Hello ladies and gentlemen.

    I have a few problems with my openSUSE 11.3 (I were using openSUSE 9 ages ago, then I moved to Debian, jet after few years I though way not to give openSUSE another chance ).

    Basically all is great except for 1 little annoying problem - system tray. Applications like Amarok, Network Manager, SUSE updater, etc just does not show up in system tray! Amarok keeps playing music after I minimalize it to tray, but its no where to be found XD.

    I'm using the following repositories:
    download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.3/
    download.opensuse.org/repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.3/
    packman.unixheads.com/suse/11.3/

    Do you ppl know any way to fix this? Thanks in advance.

    PS
    Do you know a command for zypper to install newest packages, ignoring branding (from who package is)? That is one of things that truly is a pain, and which I never experienced while using Debian.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: KDE 4.6 system tray problem - vanishing icons

    Please let me see your proper repo list with:

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: KDE 4.6 system tray problem - vanishing icons

    I have the same problem and my repos. is :
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------------+-------------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------------------------+--------
    1 | Atualizaes para openSUSE 11.3 11.3-1.82 | Atualizaes para openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    2 | KDEistro:Factory | KDEistro:Factory | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.3 |
    3 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.3/ |
    4 | aplications_11.3 | aplications 11.3 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/UpdatedApps/openSUSE_11.3 |
    5 | extras_factory | extras factory | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Extra/openSUSE_11.3_KDE_Distro_Factory |
    6 | mozilla_11.3 | mozilla 11.3 | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.3 |
    7 | packman_11.3 | packman 11.3 | Yes | Yes | 99 | rpm-md | Index of /suse/11.3 |
    8 | playground_factory | playground factory | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Unstable:/Playground/openSUSE_11.3_KDE_Distro_Factory |
    9 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    10 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    11 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    12 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    13 | vlc | vlc | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.3/ |
    14 | wine | wine | Yes | Yes | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.3 |


    thnk

  4. #4

    Default Re: KDE 4.6 system tray problem - vanishing icons

    # | Name | Active | Refresh | Priority | Type | URI |
    ---+-------------------------------------+--------+---------+----------+--------+-------------------------------------------------------------------------------------+
    1 | ATI/AMD fglrx non-official | Yes | Yes | 99 | rpm-md | Index of /mirror/ati/openSUSE_11.3 |
    2 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 50 | rpm-md | Index of /update/11.3 |
    3 | Factory | No | Yes | 200 | yast2 | Index of /factory/repo/oss |
    4 | Games | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/accAgon/openSUSE_11.3 |
    5 | Grief openSUSE | Yes | Yes | 90 | rpm-md | Index of /repositories/home:/Grieff/openSUSE_11.3 |
    6 | Java | Yes | Yes | 98 | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.3 |
    7 | KDE core | Yes | Yes | 69 | rpm-md | Index of /repositories/KDE:/Release:/46/openSUSE_11.3 |
    8 | KDE extra | Yes | Yes | 70 | rpm-md | Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.3 |
    9 | Mozilla Nightly FF | Yes | Yes | 1 | rpm-md | Index of /repositories/mozilla:/Factory/openSUSE_11.3 |
    10 | Newest kernels | Yes | Yes | 1 | rpm-md | Index of /repositories/Kernel:/HEAD/openSUSE_11.3 |
    11 | OpenOffice | Yes | Yes | 90 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.3 |
    12 | Pacman | Yes | Yes | 98 | rpm-md | Index of /suse/11.3 |
    13 | Qt | Yes | Yes | 70 | rpm-md | Index of /repositories/KDE:/Qt48/openSUSE_11.3 |
    14 | openSUSE-11.3-Contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/11.3:/Contrib/standard |
    15 | openSUSE-11.3-Standard | Yes | Yes | 99 | rpm-md | Index of /distribution/11.3/repo/oss/suse |
    16 | openSUSE-11.3 11.3-1.82 | Yes | Yes | 51 | yast2 | Index of /distribution/11.3/repo/oss |
    17 | openSUSE 11.3-Multimedia | Yes | Yes | 99 | rpm-md | Index of /repositories/multimedia:/libs/openSUSE_11.3 |
    18 | openSUSE-11.3-Debug | No | Yes | 99 | yast2 | Index of /debug/distribution/11.3/repo/oss |
    19 | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    20 | openSUSE-11.3-Source | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.3/repo/oss |

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: KDE 4.6 system tray problem - vanishing icons

    You are using Factory kde repos
    Why not remove those and use the Release 46 repos!?
    And remove 13, 8 and 4

    The repos you need to replace #2 and 5
    Index of /repositories/KDE:/Release:/46/openSUSE_11.3
    Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.3

    Then switch to those with the switcher
    http://dl.dropbox.com/u/10573557/Swi...itch%20kde.png

    Lastly do
    http://dl.dropbox.com/u/10573557/Swi...man-switch.png

    If that all seems too much
    Just try a new user account to test how that behaves first
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: KDE 4.6 system tray problem - vanishing icons

    Quote Originally Posted by caf4926 View Post
    You are using Factory kde repos
    Why not remove those and use the Release 46 repos!?
    And remove 13, 8 and 4

    The repos you need to replace #2 and 5
    Index of /repositories/KDE:/Release:/46/openSUSE_11.3
    Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.3

    Then switch to those with the switcher
    http://dl.dropbox.com/u/10573557/Swi...itch%20kde.png

    Lastly do
    http://dl.dropbox.com/u/10573557/Swi...man-switch.png

    If that all seems too much
    Just try a new user account to test how that behaves first
    It solved the problems . Sounds like Packman repositories are not compatible with KDE 4.6...

    Thank you .

    BTW. Do you know where is my favorite 'update-grub2' command? It is strangely not available after installing package grub2 from official repositories ;].

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: KDE 4.6 system tray problem - vanishing icons

    BTW. Do you know where is my favorite 'update-grub2' command? It is strangely not available after installing package grub2 from official repositories ;].
    Not a good idea
    Don't do it
    Stick with legacy in openSUSE
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: KDE 4.6 system tray problem - vanishing icons

    Quote Originally Posted by caf4926 View Post
    Not a good idea
    Don't do it
    Stick with legacy in openSUSE
    Why not? I kinda got used to Grub2 in Debian. I find it very comfortable, and customizable. I just cant find update-grub2 command XD.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,697

    Default Re: KDE 4.6 system tray problem - vanishing icons

    For one thing other tools in the stack (yast) don't know grub2 they know grub legacy so kernel update for one thing will break things badly.

  10. #10
    Join Date
    Jul 2008
    Location
    Planet Earth
    Posts
    194

    Default Re: KDE 4.6 system tray problem - vanishing icons

    I've got this bug too using the 4.6 factory Repo for 11.3, not seeing it on my 11.2 machine using 4.6 factory though.

    Issue with the systray widget in kde 4.6 11.3 factory ?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •