Results 1 to 6 of 6

Thread: Possible Yast bug

  1. #1

    Question Possible Yast bug

    Hi

    I am trying to add HTTPS Repository for YAST to install some software.

    content of /etc/zypp/repos.d/ria.repo
    [ria]
    name=RIA
    enabled=1
    autorefresh=1
    baseurl=https://installer.id.ee/media/opensuse/
    type=rpm-md
    gpgcheck=1
    gpgkey=https://installer.id.ee/media/install-scripts/ria-public.key
    keeppackages=1

    According of technical support of this repository yast is not able to handle HTTPS repository and as result yast going to point error of download failed. There are no other repository available than HTTPS.

    It would be nice if someone have ideas about that? Is it really bug or is it have work around available?

    Idea was try with some other HTTPS repository for random software but i did not find any from the Internet.

    Tanx

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Possible Yast bug

    i don't think there is a bug..

    use YaST > Software (on left) > Software Repositories (on the right),
    when the new widow opens, click "Add" and look at

    http://www.imagebam.com/image/498799118535951 image one to show how to
    mark that page, then hit "Next" in YaST, and "Next Image" in
    imagebam.com, and make the YaST image look like the imagebam . . .

    and follow your nose....and, then your list of repos in your YaST
    should look like mine (imagebam # 3)

    does the repo work now?

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3

    Default Re: Possible Yast bug

    No repo is not working still, what happen if you press OK button on your last screen. Do you see the error message, and what happens if you start yast installation manager do you see error message at the beginning. Auto-refresh should enabled!

    I would very interested about results because if you got the error, i am not the only one, if not then probably there are something missing on my system.

    Tanx.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Possible Yast bug

    On 02/07/2011 10:06 PM, pingviin wrote:

    > I would very interested about results because if you got the error, i
    > am not the only one, if not then probably there are something missing on
    > my system.


    my apology, i took the screen shot and then clicked cancel (or abort
    or whatever)....sorry!

    i think you should log it in bugzilla:
    http://en.opensuse.org/Submitting_Bug_Reports [careful, be sure and
    search for previous bugs on "yast https repo" or some such...this may
    be a known problem...if it is add to the writeup anything you think is
    important]

    and please come back here and post the bug number (so following with
    the same problem which find this thread can track in the bugzilla)

    in the meantime i _guess_ it *might* be possible to, using a browser,
    go to https://installer.id.ee/media/opensuse/RPMS/ and click on the
    main basic program rpm and when the firefox pop up asks what you wanna
    do, click "Open with install/remove software. (default)" and cross
    your fingers

    i didn't try it (because i don't want it) so there MAY be a dependency
    hell waiting...if so i think i'd either wait for the bug to be cleared
    or carefully download all of the packages you need (careful, there is
    a mix of both 64 and 32 packages) into one directory on your directory
    and then install them with YaST/zypper or however..

    maybe someone else will come along and help! (hey, maybe if there is a
    bug logged there is also directions for a work around)

    let us (and following) know how you get on, please..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  5. #5

    Default Re: Possible Yast bug


  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Possible Yast bug

    On 02/09/2011 11:36 AM, pingviin wrote:
    >
    > Bug is posted at https://bugzilla.novell.com/show_bug.cgi?id=670343


    thank you!

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •