Results 1 to 2 of 2

Thread: Dual Monitor question.

  1. #1
    Join Date
    Apr 2009
    Location
    Plantation, FL
    Posts
    143

    Default Dual Monitor question.

    I have openSUSE 11.3 with an nvidia card connected with two monitors. In the past I used xinerama which was ok, but now I need to have two separate desktops, one on each screen. I set the nvidia driver with x screen, and now one screen works perfect and the other only shows a black screen. When I move the mouse over the black screen, the mouse pointer turns into an X, but moves correctly, which seems to me that the problem is that I need to set the second desktop to that screen.

    I looked on forums on how to do so, and no luck.

    Can somebody point me to a page with the instructions to accomplish this, or give me the steps needed?

    If more information is needed, please let me know!

  2. #2
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Dual Monitor question.

    I have an Nvidia card with 2 monitors. Each one have it's own separate Desktop, and when i move the cursor, it moves from 1 to the other as a long continuous screen.

    1. installed the Nvidia driver from here: 1-click-collection - openSUSE Community Wiki. Restart the computer

    2. run nvidia-settings as root: in kde you can run 'kdesu nvidia-settings' (terminal or Alt+F2), or in terminal login as root: 'su -', then run 'nvidia-settings'

    3. on the left click "X Server Display Configuration".
    4. Hit "Configure" button, choose "TwinView".
    5. set one screen as the primary (mine is the left monitor). Set the other one to to have a relevant position to the primary (mine is on the right).
    6. Click Apply and set the view. it might take several seconds until both screens appear correctly. if not hit "ESC" and the settings will revert.

    7. if everything is ok, save to X config file: /etc/X.11/xorg.conf.

    Works for me every time...
    One thing that might happen is that the desktops might switch between screens. Just log out and log in again and it will be corrected.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •