Results 1 to 10 of 10

Thread: kdm remote graphical login not working

  1. #1

    Default kdm remote graphical login not working

    I had an old SuSE installation (v9 or 10, I forget) on which I used to remotely login to a kde session using xdmcp. I blew this away and installed 11.3, and I just can't get it to work. I'm pretty sure I've enabled all the things I should have. Is there a bug?

    (Incidentally, I had the same problem with Ubuntu 10.10 (with Gnome), and eventually found I needed an updated version of gdm. With X tunneled through a PuTTy ssh session I can display individual X windows no probs. Also, a VNC session is rejected out of hand.)

    Regards - Philip

  2. #2

    Default Re: kdm remote graphical login not working

    As far as I know gdm in Ubuntu since 10.04 doesn't support xdmcp any more. So remote login is not possible with gdm. xdm still works. kdm should work too - I can not check now.

  3. #3

    Default Re: kdm remote graphical login not working

    I had it working on Ubuntu 10.10, but only after I installed a later gdm than came with the package (2.30.5 I think). So what's the deal with kdm?

  4. #4

    Default Re: kdm remote graphical login not working

    This works:
    Code:
    X -query  <serverIP> -from <clienIP>
    That does not:
    Code:
    X -query  <serverIP>

  5. #5

    Default Re: kdm remote graphical login not working

    Ummm... No, that doesn't work. No difference at all.

    I get the X-shaped cursor after a bit. Does that indicate it's getting somewhere, or is that rendered locally until SuSE sends its own cursor?

  6. #6

    Default Re: kdm remote graphical login not working

    I don't know what you're trying to do. I just rebooted two openSUSE machines, launched kdm on the one and X -query on the other one and got a login screen there. I didn't login though but I know it works.

    Code:
    sed '/^#/d' /usr/share/kde4/config/kdm/kdmrc
    
    [General]
    ConfigVersion=2.4
    SUSEConfigVersion=2
    StaticServers=:0
    ReserveServers=:1,:2,:3
    ServerVTs=-7
    ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
    ExportList=LANG,LD_LIBRARY_PATH,WINDOW_MANAGER,REMOTEHOST,XBMLANGPATH,HOMEC,TMPDIR,PATH,EDITOR,Xres,DISPLAY,REALUSER
    
    [Xdmcp]
    
    [Shutdown]
    
    
    [X-*-Core]
    SessionsDirs=/usr/local/share/xsessions
    ClientLogFile=.xsession-errors-%d
    
    [X-*-Greeter]
    GUIStyle=Oxygen
    ColorScheme=OpenSUSE
    LogoPixmap=/usr/local/share/images/openSUSE/Oslogo.png
    MinShowUID=1000
    MaxShowUID=65000
    ForgingSeed=1239937001
    UseTheme=true
    
    [X-:*-Core]
    ServerArgsLocal=-br -nolisten tcp
    ServerArgsRemote=-br
    
    [X-:*-Greeter]
    PreselectUser=Previous
    FocusPasswd=true
    LoginMode=DefaultLocal
    AllowClose=true
    
    [X-:0-Core]
    TerminateServer=true
    ClientLogFile=.xsession-errors
    
    [X-:93-Core]
    TerminateServer=true
    
    [X-:0-Greeter]
    "-br" is irrelevant. What's important is to remove "-nolisten tcp" from ServerArgsRemote. I don't remember if it was there by default but it's quite possible.

    And of course you have to set DISPLAYMANAGER_REMOTE_ACCESS and DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN to yes. Check in YaST -> System -> /etc/sysconfig Editor -> Desktop -> Display manager.

  7. #7

    Default Re: kdm remote graphical login not working

    Thanks for your reply. Yes, I'm trying to do pretty much what you've demonstrated (if I've understood you correctly - SuSE 11.3 on one machine, and trying to get a GUI login to it on another running Cygwin/X under WinXP (which worked previously with an old SuSE installation, and recently with Gnome (gdm 2.30.5) under Ubuntu 10.10).

    Your suggestions all check out except that DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN was "no" - but setting it to "yes" hasn't made any difference.

    Does kdm keep a log file, and if so, can I bump up the logging level? I tried Wireshark on the SuSE box and I can see the UDP:177 requests coming in, but nothing going out.

    And which kdmrc is active? The one in /etc/kde4/kdm, or /usr/share/kde4/config/kdm ? Strangely, the last update date on neither file changes if I toggle Yast - Local Security - Login Settings - Allow Remote Graphical Login ! From your posting, I presume the latter. Mine doesn't appear materially different (I just added [Xdmcp] Enable=true at the suggestion of the kdm documentation):

    Code:
    leriche-p25:/usr/share/kde4/config/kdm # sed '/^#/d' kdmrc
    
    [General]
    ConfigVersion=2.4
    SUSEConfigVersion=2
    StaticServers=:0
    ReserveServers=:1,:2,:3
    ServerVTs=-7
    ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
    
    [Xdmcp]
    Enable=true
    
    [Shutdown]
    
    
    [X-*-Core]
    ClientLogFile=.xsession-errors-%d
    
    [X-*-Greeter]
    LogoPixmap=/usr/share/kde4/apps/kdm/pics/kdelogo.png
    MinShowUID=500
    MaxShowUID=65000
    ForgingSeed=1296565839
    UseTheme=true
    
    [X-:*-Core]
    
    [X-:*-Greeter]
    PreselectUser=Previous
    FocusPasswd=true
    LoginMode=DefaultLocal
    AllowClose=false
    
    [X-:0-Core]
    TerminateServer=true
    ClientLogFile=.xsession-errors
    
    [X-:93-Core]
    TerminateServer=true
    
    [X-:0-Greeter]

  8. #8

    Default Re: kdm remote graphical login not working

    Quote Originally Posted by pleriche View Post
    Does kdm keep a log file, and if so, can I bump up the logging level?
    /var/log/kdm.log

    Quote Originally Posted by pleriche View Post
    I tried Wireshark on the SuSE box and I can see the UDP:177 requests coming in, but nothing going out.
    What about firewall?

    Quote Originally Posted by pleriche View Post
    And which kdmrc is active? The one in /etc/kde4/kdm, or /usr/share/kde4/config/kdm ?
    I don't have any in /etc/kde4/kdm

    Quote Originally Posted by pleriche View Post
    I just added [Xdmcp] Enable=true at the suggestion of the kdm documentation:
    I assume that since it is missing in my kdmrc and it works without, it must be enable by default


    If all you need is to log in to your desktop from a Windows box, you might try something like Nomachine NX or FreeNX. It doesn't use xdmcp at all, only ssh. Once you get it configured properly, it works amazing well. Nomachine is a commercial product. FreeNX is open source and available for all distros. You just need to install a small client from Nomachine (which is free). You don't need cygwin at all.

    Code:
    zypper info freenx
    NoMachine NX - Documentation: Some NX Screenshots

  9. #9

    Default Re: kdm remote graphical login not working

    Sorted.

    This is a laptop I use for semi-official purposes at work such as wifi auditing. I'd brought it home to set up and was running it on my home network and trying to access it from Windoze by putting its domain name in the Win hosts file (not having DNS at home). This worked for Samba and ssh but not for kdm. Possibly it tries to do a reverse DNS lookup, which obviously wouldn't work. Back in the office I got a KDE gui login on Win almost instantly.

    Thanks for your help anyway - much appreciated.

    Regards - Philip

  10. #10

    Default Re: kdm remote graphical login not working

    Notice that in the example in post #4, I used IPs and not names. I thought it was obvious enough and forgot to mention that it didn't work with names.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •