Results 1 to 10 of 10

Thread: KDE/Openbox plasmoid offset off screen

  1. #1

    Default KDE/Openbox plasmoid offset off screen

    Hi,

    I like to run KDE with openbox instead of kwin. System:
    openSUSE 11.3
    KDE 4.5.4
    openbox 3.4.11

    My problem is that all plasmoids are displayed off screen when I boot into KDE. The only way to fix it is by opening the cashew on the task bar and closing it - which seems to cause a refresh of the plasmoids locations.

    My question is: is there a way to fix this? If not, is there a workaround to have the plasmoids refreshed upon login?

    Thanks,
    g

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,293
    Blog Entries
    2

    Default Re: KDE/Openbox plasmoid offset off screen

    Guessing a bit, I'm not an Openbox User, but 'way back years ago on VMware I saw the same thing. Problem was a faulty display driver(OEM problem, nothing you can do).

    My solution then was to find a different default Guest screen resolution where the Desktop icons (Widgets now) stay put. Try smaller and larger.

    HTH,
    Tony

  3. #3

    Default Re: KDE/Openbox plasmoid offset off screen

    Didn't work.

    I forgot to mention that this occurs on three different laptops all different models with different graphics hardware.

    Also, this is something that was not introduced with KDE 4.5.4 just released, it has occured since I started using KDE at 4.5.1.

    g

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,293
    Blog Entries
    2

    Default Re: KDE/Openbox plasmoid offset off screen

    My mistake, Openbox isn't a virtualization technology, it's a Windows Manager.

    I guess my question is why you are using it?
    Am wondering if you have the same problem without Openbox...

    Tony

  5. #5

    Default Re: KDE/Openbox plasmoid offset off screen

    I guess my question is why you are using it?
    Because I like it. Should there be any other reason?

    And no, the problem is only with KDE/Openbox.

    g

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,293
    Blog Entries
    2

    Default Re: KDE/Openbox plasmoid offset off screen

    Quote Originally Posted by greenmachine View Post
    Because I like it. Should there be any other reason?

    And no, the problem is only with KDE/Openbox.

    g
    As good a reason as any :}
    But, was wondering if there was some feature you craved which took you off the most beaten path.

    It would probably still be informative to determine whether it's likely a problem specific to Openbox. That could suggest whether you should follow up by searching KDE or Openbox support resources to get more eyeballs.

    Tony

  7. #7

    Default Re: KDE/Openbox plasmoid offset off screen

    Since you are curious: I like openbox because it is fast replacement for non-compositing kwin in KDE 4.5 on laptops with older hardware.

    Since there hasn't been a suggestion on how to fix this problem, what about how to automate the workaround: open and close the toolbox for the taskbar on startup. Is this part possible?

    g

  8. #8

    Default Re: KDE/Openbox plasmoid offset off screen

    workaround

    1. Change your default login to the standard KDE session (kwin)
    2. Put an executable script in ~/.kde/Autostart like the following:
    Code:
    #!/bin/bash
    
    openbox --replace &
    3. log in like normal.

    The script will replace kwin with openbox upon start up and the offset seems to be gone. Not very clean, but it works.

    g

  9. #9

    Default Re: KDE/Openbox plasmoid offset off screen

    I have this problem as well. Fedora 14, KDE 4.5 and Openbox.

    I currently run KDE/Openbox (no kwin), and have found a work-around.
    When I log in, the menu and volume control windows open off screen, as for you. The fix is to click in the rightmost part of the panel, to open the panel setup controls.

    Just open the panel control and close it at once. After this kmenu and volume control open where they should!

  10. #10

    Default Re: KDE/Openbox plasmoid offset off screen

    Try and boot with the kernel option "nomodeset"
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •