Results 1 to 8 of 8

Thread: Gnome terminal size issue

  1. #1

    Default Gnome terminal size issue

    I'm using the Gnome desktop in openSUSE 11.3.
    I've set the "Command" to gnome-terminal --geometry=80x58
    for the Gnome terminal in its Launcher Properties. This opens
    a terminal of the size I want every time I click it. However,
    when I right-click the desktop and click "open in terminal" it
    opens a terminal of a much smaller size and I can't figure out
    how to correct this. The same thing happens when I click
    File->Open Terminal from a terminal window, and also when
    I click File->Open in Terminal from from the File Browser.

    Why am I getting a much smaller window and how do I fix it?

    Thanks

    Ron

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Gnome terminal size issue

    On 02/06/2011 12:06 AM, rderosier wrote:
    >
    > I'm using the Gnome desktop in openSUSE 11.3.
    > I've set the "Command" to gnome-terminal --geometry=80x58
    > for the Gnome terminal in its Launcher Properties. This opens
    > a terminal of the size I want every time I click it. However,
    > when I right-click the desktop and click "open in terminal" it
    > opens a terminal of a much smaller size and I can't figure out
    > how to correct this. The same thing happens when I click
    > File->Open Terminal from a terminal window, and also when
    > I click File->Open in Terminal from from the File Browser.
    >
    > Why am I getting a much smaller window and how do I fix it?
    >
    > Thanks
    >
    > Ron
    >
    >

    probably you could change the executable 'gnome-terminal' to (say)
    'gnometerm2' and then set a system alias like:

    alias gnome-terminal='gnometerm2 --geometry=80x58'

    and, revert the launcher properties back to the original...then no
    matter how 'gnome-terminal' is executed, it will incluse the geometry
    you wish...

    don't know how to set a system alias? its easy, but i don't wanna
    explain just now [hint: see the words at the top of /etc/bash.bashrc
    and if yours does not already exist, add an /etc/bash.bashrc.local,
    however this will change the terminal for ALL system users, if you
    just want it changed for yourself i _think_ you put the alias in your
    /home's .bashrc, but MAYBE it goes in an added to your home's
    ..bashrc.local]

    if you don't know how, read up some on it or ask questions--and make
    recovery plans [be SURE and save off a backup of the original that
    you can sub back in if stuff gets out of shape], because a mashed
    bashrc results in not a pretty mess..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3

    Default Re: Gnome terminal size issue

    The proper way to change gnome-terminal default size is to replace the default number of columns and rows (highlighted in red below) in the file /usr/share/vte/termcap/xterm. In your case, you'll have to replace 24 with 58. You have to edit this file as root. I posted the whole code in case you screw it up, as it is an important file. Depending of versions however, gnome-terminal might ignore this file. It works for the moment with gnome 2.30 under openSUSE 11.3. I'm not sure it works with gnome 2.32.

    Code:
    # This is a cut-down version of the termcap file from my box with some entries
    # removed (add them back in to override the terminal's behavior):
    # kI (Insert, Delete is handled programmatically)
    # kP/kN (Page Up, Page Down)
    # ku/kd/kl/kr (Up, Down, Left, Right)
    # k1/kd2/k3/k4/k5/k6/k7/k8/k9/k; (F1-F10)
    # K1/K2/K3/K4/K5 (KP Up, Down, Left, Right, Begin)
    xterm-xfree86|xterm-new|xterm terminal emulator (XFree86):\
            :am:km:mi:ms:xn:\
            :co#80:it#8:li#24:\
            :AL=\E[%dL:DC=\E[%dP:DL=\E[%dM:DO=\E[%dB:IC=\E[%d@:\
            :LE=\E[%dD:\
            :RI=\E[%dC:UP=\E[%dA:ae=^O:al=\E[L:as=^N:bl=^G:bt=\E[Z:\
            :cd=\E[J:ce=\E[K:cl=\E[H\E[2J:cm=\E[%i%d;%dH:cr=^M:\
            :cs=\E[%i%d;%dr:ct=\E[3g:dc=\E[P:dl=\E[M:do=^J:ec=\E[%dX:\
            :ei=\E[4l:ho=\E[H:im=\E[4h:is=\E[!p\E[?3;4l\E[4l\E>:\
            :kD=\177:\
            :kb=^H:ke=\E[?1l\E>:\
            :ks=\E[?1h\E=:le=^H:mb=\E[5m:md=\E[1m:\
            :me=\E[m\017:mr=\E[7m:nd=\E[C:rc=\E8:sc=\E7:se=\E[27m:\
            :sf=^J:so=\E[7m:sr=\EM:st=\EH:ta=^I:te=\E[?1047l\E[?1048l:\
            :ti=\E[?1048h\E[?1047h:ue=\E[24m:up=\E[A:us=\E[4m:\
            :vb=\E[?5h\E[?5l:ve=\E[?25h:vi=\E[?25l:vs=\E[?25h:
    # xterm-redhat is identical to xterm-xfree86 with the addition of a small
    # VT220-ism regarding the backspace and delete keys; this is mandated by
    # the keyboard configuration section of the Debian Policy Manual.
    xterm-redhat|Red Hat xterm (backspace and delete changed):\
            :kD=\E[3~:kb=\177:tc=xterm-xfree86:
    # This is the only entry which you should have to customize, since "xterm"
    # is widely used for a variety of incompatible terminal emulations including
    # color_xterm and rxvt.
    xterm|X11 terminal emulator:\
            :tc=xterm-redhat:
    * or maybe it will still work for gnome-terminal and not anymore for Terminal (xfce terminal) - I don't remember - as several xterm emulations read this definition.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Gnome terminal size issue

    On 02/06/2011 12:06 PM, please try again wrote:
    >
    > The proper way to change gnome-terminal default size is to


    cool! maybe not proper, but i do think mine would work...and persist
    through the next upgrade (or non-format install) because *.local and
    its alias would remain....maybe(?)

    [not disputing, just asking]

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,630
    Blog Entries
    3

    Default Re: Gnome terminal size issue

    Quote Originally Posted by DenverD View Post
    probably you could change the executable 'gnome-terminal' to (say)
    'gnometerm2' and then set a system alias like:

    alias gnome-terminal='gnometerm2 --geometry=80x58'
    If you are using aliases, you could probably use
    alias gnome-terminal='/usr/bin/gnome-terminal --geometry=80x58'
    That way, you wouldn't need to rename the executable.

  6. #6

    Default Re: Gnome terminal size issue

    Quote Originally Posted by DenverD View Post
    On 02/06/2011 12:06 PM, please try again wrote:
    >
    > The proper way to change gnome-terminal default size is to


    cool! maybe not proper, but i do think mine would work...and persist
    through the next upgrade (or non-format install) because *.local and
    its alias would remain....maybe(?)
    Well, you can always alias everything to everything else, but it might not be considered as a solution. And if you want to make an alias don't rename the program or it won't be updated properly! Create an alias with another name. You should not use aliases in place of program names, as they might not always work as expected in situations where the programs are passed arguments. In other words, to the system or any tool or script, "gnome-terminal" should mean "gnome-terminal" and not "gnometerm2 --geometry=80x58", since the later won't work within applications or scripts which evaluate the program name (which for instance get stored in the variable $0 in shell scripts) and parse the rest of the command line as arguments - rather than options.

    Quote Originally Posted by DenverD View Post
    [not disputing, just asking]
    [just explaining] then.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Gnome terminal size issue

    On 02/06/2011 02:06 PM, please try again wrote:
    >
    > since the later won't work within
    > applications or scripts which evaluate the program name (which for
    > instance get stored in the variable $0 in shell scripts) and parse the
    > rest of the command line as arguments - rather than options.


    slaps forehead, says "AH!"

    and "thanks!"

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  8. #8

    Default Re: Gnome terminal size issue

    The suggestion of changing the xterm file works for me for all the cases I listed
    as not working.

    Thanks

    Ron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •