Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Yast Repositories

  1. #1

    Default Yast Repositories

    I am running Suse 11.1.

    I do the following:

    Click on Software Repositories
    Click Add
    Click Community Repositories
    Click Next.

    I receive an error, "Unable to download list of Repositories or no repositories defined."

    in the /etc/YaST2/control.xml the external repository is:

    download.opensuse.org/YaST/Repos/openSUSE_111_Servers.xml

    Any ideas?

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Yast Repositories

    11.1 support has ended

    What repo do you want?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Yast Repositories

    This is still happening with 11.4. When I try to add the community repositories I get the same error message as the OP got on 11.1. In my 11.4 /etc/YaST2/control.xml the external_sources_link points to:

    http://download.opensuse.org/YaST/Re...14_Servers.xml

    But when I try to access that link with a browser it gives a 404 error. If I try to walk to it directory by directory it fails on the initial "YaST2" directory, which in fact does not exist.

    Do I need to file a bug on this or is it a temporarily hosed server setup on the suse end?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Yast Repositories

    Please post result of

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Yast Repositories

    Code:
    # zypper lr -d
    # | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                 | Service
    --+----------------------------------+----------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------+--------
    1 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                           |        
    2 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-PIONEER_DVD-RW_DVR-112D,/dev/sr0 |        
    3 | repo-debug                       | openSUSE-11.4-Debug              | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/      |        
    4 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                     |        
    5 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/        |        
    6 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/            |        
    7 | repo-source                      | openSUSE-11.4-Source             | No      | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/     |
    This is a newly installed system, and I have not done anything with the repositories other than try to add the community ones.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Yast Repositories

    That looks OK
    Do you know what repo you want to add?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Yast Repositories

    Well, I was hoping the program would work correctly and give me a list to choose from. Packman, Nvidia, Mozilla, etc.. would be nice. There is undoubtedly a manual way to add them one by one, but shouldn't the "add" button work properly?

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Yast Repositories

    It should work

    Lets try the multi-media Oneclick
    Choose the gnome or kde to suit you
    Multimedia in One Click

    If that doesn't work, let me know
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Yast Repositories

    Quote Originally Posted by caf4926 View Post
    It should work

    Lets try the multi-media Oneclick
    Choose the gnome or kde to suit you
    Multimedia in One Click

    That did work... it installed everything but vlc, which generated an error I did not record because I don't care about vlc anyway. But all the other stuff installed.

    It looks to me like the instruction in the control.xml is wrong or the server is missing some directories.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Yast Repositories

    I used that oneclick today and had that error with vlc too

    I'm not sure why vlc has been removed from packman, something I have to check on.

    Anyway. Make sure your system is updated

    su - terminal

    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •