Results 1 to 2 of 2

Thread: personal settings -> keyboard & mouse -> global keyboard shortcuts problem

  1. #1

    Default personal settings -> keyboard & mouse -> global keyboard shortcuts problem

    First let me start out by saying I'm new to Linux.

    Having said that, I'm running openSUSE 11.3 with both the Gnome and KDE desktops
    installed, but so far I'm only using Gnome. I was looking for a way to assign sound
    volume increase/decrease to some keyboard keys instead of having to click on the
    speaker icon at the bottom of the screen. I found what I included in the Title of this
    message. Under the Global Keyboard Shortcuts was an item for each increase and
    decrease sound volume. These were set to (I believe) meta+ and meta-, respectively.
    I changed them to F12 and F11, respectively (to match my Apple keyboard). After the
    changes, I started a game which takes over the entire screen (which is why I wanted
    to assign the volume to keys in the first place) to see if the changes worked. They
    did not! So, I tried to go back and change them to something else and now I can't
    even access Global Keyboard Shortcuts at all. I keep getting the following error:

    Sorry - System Settings

    Failed to contact the KDE global shortcuts daemon
    Message: Could not get owner of name 'org.kde.kglobalaccel': no such name
    Error: org.freedesktop.DBus.Error.NameHasNoOwner

    What's up and how do I recover from this (if I even care)?
    Also, how do I assign volume increase/decrease to keys?

    Thanks

    Ron

  2. #2

    Default Re: personal settings -> keyboard & mouse -> global keyboard shortcuts problem

    I forgot to mention in my original post that the assignment of the sound volume increase/decrease to the F12 and F11
    keys does work outside of the game, just not while the game is playing, so it doesn't accomplish what I really wanted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •